diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2010-12-04 21:35:37 +0100 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2010-12-04 21:35:37 +0100 |
commit | 1857df74ac9bfec16d0274fe972fda7bb1f99e6b (patch) | |
tree | 5b6ffb80c60f44afc1b9048408717d032b0a0e49 /recipes-multimedia | |
parent | 9601fff416b251cf5e5ca3c93b0e102ad63dff52 (diff) | |
download | meta-openembedded-1857df74ac9bfec16d0274fe972fda7bb1f99e6b.tar.gz |
meta-openembedded: overlay gst-plugins-base to get rid of gnome-vfs(-native) dep
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-multimedia')
3 files changed, 80 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gst-plugins-base-0.10.30/gst-plugins-base-tremor.patch b/recipes-multimedia/gstreamer/gst-plugins-base-0.10.30/gst-plugins-base-tremor.patch new file mode 100644 index 000000000..a6494fd4a --- /dev/null +++ b/recipes-multimedia/gstreamer/gst-plugins-base-0.10.30/gst-plugins-base-tremor.patch | |||
@@ -0,0 +1,17 @@ | |||
1 | Remove -DTREMOR option since Tremor has dropped its internal | ||
2 | libogg2, and gst-plugins-base has dependency on that. | ||
3 | |||
4 | Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com> | ||
5 | |||
6 | diff -ruN gst-plugins-base-0.10.30-orig/ext/vorbis/Makefile.am gst-plugins-base-0.10.30/ext/vorbis/Makefile.am | ||
7 | --- gst-plugins-base-0.10.30-orig/ext/vorbis/Makefile.am 2010-11-17 16:11:03.000000000 +0800 | ||
8 | +++ gst-plugins-base-0.10.30/ext/vorbis/Makefile.am 2010-11-17 16:12:41.000000000 +0800 | ||
9 | @@ -28,7 +28,7 @@ | ||
10 | libgstivorbisdec_la_SOURCES = gstivorbisdec.c \ | ||
11 | gstvorbisdec.c gstvorbisdeclib.c gstvorbiscommon.c | ||
12 | libgstivorbisdec_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS) \ | ||
13 | - -DTREMOR $(IVORBIS_CFLAGS) | ||
14 | + $(IVORBIS_CFLAGS) | ||
15 | libgstivorbisdec_la_LIBADD = \ | ||
16 | $(top_builddir)/gst-libs/gst/tag/libgsttag-@GST_MAJORMINOR@.la \ | ||
17 | $(top_builddir)/gst-libs/gst/audio/libgstaudio-@GST_MAJORMINOR@.la \ | ||
diff --git a/recipes-multimedia/gstreamer/gst-plugins-base_0.10.30.bb b/recipes-multimedia/gstreamer/gst-plugins-base_0.10.30.bb new file mode 100644 index 000000000..9347ef493 --- /dev/null +++ b/recipes-multimedia/gstreamer/gst-plugins-base_0.10.30.bb | |||
@@ -0,0 +1,22 @@ | |||
1 | require gst-plugins.inc | ||
2 | |||
3 | LICENSE = "GPLv2+ & LGPLv2+" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \ | ||
5 | file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=622921ffad8cb18ab906c56052788a3f \ | ||
6 | file://COPYING.LIB;md5=55ca817ccb7d5b5b66355690e9abc605 \ | ||
7 | file://gst/ffmpegcolorspace/utils.c;beginline=1;endline=20;md5=9c83a200b8e597b26ca29df20fc6ecd0" | ||
8 | |||
9 | DEPENDS += "virtual/libx11 alsa-lib freetype liboil libogg libvorbis libxv libtheora" | ||
10 | |||
11 | SRC_URI += " file://gst-plugins-base-tremor.patch" | ||
12 | |||
13 | PR = "r2" | ||
14 | |||
15 | inherit gettext | ||
16 | |||
17 | EXTRA_OECONF += "--disable-freetypetest --disable-pango" | ||
18 | |||
19 | do_configure_prepend() { | ||
20 | # This m4 file contains nastiness which conflicts with libtool 2.2.2 | ||
21 | rm -f ${S}/m4/lib-link.m4 | ||
22 | } | ||
diff --git a/recipes-multimedia/gstreamer/gst-plugins.inc b/recipes-multimedia/gstreamer/gst-plugins.inc new file mode 100644 index 000000000..cd3e0a0a9 --- /dev/null +++ b/recipes-multimedia/gstreamer/gst-plugins.inc | |||
@@ -0,0 +1,41 @@ | |||
1 | DESCRIPTION = "Plugins for GStreamer" | ||
2 | HOMEPAGE = "http://gstreamer.freedesktop.org/" | ||
3 | BUGTRACKER = "https://bugzilla.gnome.org/enter_bug.cgi?product=Gstreamer" | ||
4 | SECTION = "multimedia" | ||
5 | PRIORITY = "optional" | ||
6 | DEPENDS = "gstreamer" | ||
7 | |||
8 | inherit autotools pkgconfig | ||
9 | |||
10 | SRC_URI = "http://gstreamer.freedesktop.org/src/${PN}/${PN}-${PV}.tar.bz2" | ||
11 | |||
12 | EXTRA_OECONF = "--disable-valgrind --disable-debug --disable-examples " | ||
13 | |||
14 | acpaths = "-I ${S}/common/m4 -I ${S}/m4" | ||
15 | |||
16 | LIBV = "0.10" | ||
17 | #FILES_${PN} += "${libdir}/gstreamer-${LIBV}/*.so" | ||
18 | #FILES_${PN}-dev += "${libdir}/gstreamer-${LIBV}/*.la ${libdir}/gstreamer-${LIBV}/*.a" | ||
19 | FILES_${PN}-dbg += "${libdir}/gstreamer-${LIBV}/.debug" | ||
20 | |||
21 | PACKAGES_DYNAMIC = "${PN}-*" | ||
22 | |||
23 | # orc.m4 calls pkg-config ----variable=orcc orc-0.4 to get the path to orcc, | ||
24 | # resulting in /usr/bin/orcc. Force it to use the staged orcc. | ||
25 | do_configure_append() { | ||
26 | for i in $(find ${S} -name "Makefile") ; do | ||
27 | sed -i -e s:${bindir}/orcc:${STAGING_BINDIR_NATIVE}/orcc:g $i | ||
28 | done | ||
29 | } | ||
30 | |||
31 | python populate_packages_prepend () { | ||
32 | gst_libdir = bb.data.expand('${libdir}/gstreamer-${LIBV}', d) | ||
33 | postinst = bb.data.getVar('plugin_postinst', d, 1) | ||
34 | |||
35 | # Can't package separate debug packages yet | ||
36 | # do_split_packages(d, gst_libdir, '\.debug/libgst(.*)\.so$', bb.data.expand('${PN}-%s-dbg', d), 'GStreamer plugin for %s (with debugging symbols)', recursive=True, extra_depends=bb.data.expand('${PN}-dbg', d), match_path=True) | ||
37 | do_split_packages(d, gst_libdir, 'libgst(.*)\.so$', bb.data.expand('${PN}-%s', d), 'GStreamer plugin for %s', postinst=postinst, extra_depends=bb.data.expand('${PN}',d)) | ||
38 | do_split_packages(d, gst_libdir, 'libgst(.*)\.l?a$', bb.data.expand('${PN}-%s-dev', d), 'GStreamer plugin for %s (development files)', extra_depends=bb.data.expand('${PN}-dev',d)) | ||
39 | } | ||
40 | |||
41 | ALLOW_EMPTY = "1" | ||