summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-01-05 13:19:57 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-01-05 13:19:57 +0100
commit6f1647aa9079471a2062166660ab9fb6b074817e (patch)
tree86dccf0ebf5e6818fe2342d4a068cf5171740ccb /recipes-devtools
parent46f1070d70f731f171b12e5f52c006abc9f8768b (diff)
downloadmeta-openembedded-6f1647aa9079471a2062166660ab9fb6b074817e.tar.gz
gcc 4.5: import http://git.yoctoproject.org/cgit/cgit.cgi/poky/commit/?id=f13cb20ed19c41b9ff85ef1c9ec0883a21d1d5bf and convert to INC_PR
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/gcc/gcc-4.5.inc3
-rw-r--r--recipes-devtools/gcc/gcc-4.5/GPLUSPLUS_INCLUDE_DIR_with_sysroot.patch33
-rw-r--r--recipes-devtools/gcc/gcc-configure-cross.inc2
-rw-r--r--recipes-devtools/gcc/gcc-configure-sdk.inc2
-rw-r--r--recipes-devtools/gcc/gcc-cross-canadian_4.5.bb4
-rw-r--r--recipes-devtools/gcc/gcc-cross-initial_4.5.bb2
-rw-r--r--recipes-devtools/gcc/gcc-cross-intermediate_4.5.bb2
-rw-r--r--recipes-devtools/gcc/gcc-cross_4.5.bb2
-rw-r--r--recipes-devtools/gcc/gcc-crosssdk-initial_4.5.bb2
-rw-r--r--recipes-devtools/gcc/gcc-crosssdk-intermediate_4.5.bb2
-rw-r--r--recipes-devtools/gcc/gcc-crosssdk_4.5.bb2
-rw-r--r--recipes-devtools/gcc/gcc-runtime_4.5.bb2
-rw-r--r--recipes-devtools/gcc/gcc_4.5.bb2
13 files changed, 48 insertions, 12 deletions
diff --git a/recipes-devtools/gcc/gcc-4.5.inc b/recipes-devtools/gcc/gcc-4.5.inc
index 3728fa0e6..ddd9f9839 100644
--- a/recipes-devtools/gcc/gcc-4.5.inc
+++ b/recipes-devtools/gcc/gcc-4.5.inc
@@ -14,6 +14,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
14 14
15SRCREV = "167948" 15SRCREV = "167948"
16PV = "4.5" 16PV = "4.5"
17INC_PR = "r11"
18
17# BINV should be incremented after updating to a revision 19# BINV should be incremented after updating to a revision
18# after a minor gcc release (e.g. 4.5.1 or 4.5.2) has been made 20# after a minor gcc release (e.g. 4.5.1 or 4.5.2) has been made
19# the value will be minor-release+1 e.g. if minor release was 21# the value will be minor-release+1 e.g. if minor release was
@@ -162,6 +164,7 @@ SRC_URI = "svn://gcc.gnu.org/svn/gcc/branches;module=${BRANCH} \
162 \ 164 \
163 file://optional_libstdc.patch \ 165 file://optional_libstdc.patch \
164 file://64bithack.patch \ 166 file://64bithack.patch \
167 file://GPLUSPLUS_INCLUDE_DIR_with_sysroot.patch \
165 " 168 "
166 169
167SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 " 170SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 "
diff --git a/recipes-devtools/gcc/gcc-4.5/GPLUSPLUS_INCLUDE_DIR_with_sysroot.patch b/recipes-devtools/gcc/gcc-4.5/GPLUSPLUS_INCLUDE_DIR_with_sysroot.patch
new file mode 100644
index 000000000..9ae01c3fc
--- /dev/null
+++ b/recipes-devtools/gcc/gcc-4.5/GPLUSPLUS_INCLUDE_DIR_with_sysroot.patch
@@ -0,0 +1,33 @@
1# by default c++ include directories are not relative to "--sysroot"
2# which brings one trouble when using the toolchain in an environment
3# where the build directory generating that toolchain doesn't exist,
4# e.g. in sstate, machine specific sysroot and relocatable SDK
5# toolchain. This patch now enables c++ include paths under sysroot.
6# This way it's enough as long as "--sysroot" is correctly enabled
7# in the new environment.
8#
9# Signed-off-by Kevin Tian <kevin.tian@intel.com>, 2010-12-30
10
11diff --git a/gcc/cppdefault.c b/gcc/cppdefault.c
12index 5024f48..9b47d1c 100644
13--- a/gcc/cppdefault.c
14+++ b/gcc/cppdefault.c
15@@ -48,15 +48,15 @@ const struct default_include cpp_include_defaults[]
16 = {
17 #ifdef GPLUSPLUS_INCLUDE_DIR
18 /* Pick up GNU C++ generic include files. */
19- { GPLUSPLUS_INCLUDE_DIR, "G++", 1, 1, 0, 0 },
20+ { GPLUSPLUS_INCLUDE_DIR, "G++", 1, 1, 1, 0 },
21 #endif
22 #ifdef GPLUSPLUS_TOOL_INCLUDE_DIR
23 /* Pick up GNU C++ target-dependent include files. */
24- { GPLUSPLUS_TOOL_INCLUDE_DIR, "G++", 1, 1, 0, 1 },
25+ { GPLUSPLUS_TOOL_INCLUDE_DIR, "G++", 1, 1, 1, 1 },
26 #endif
27 #ifdef GPLUSPLUS_BACKWARD_INCLUDE_DIR
28 /* Pick up GNU C++ backward and deprecated include files. */
29- { GPLUSPLUS_BACKWARD_INCLUDE_DIR, "G++", 1, 1, 0, 0 },
30+ { GPLUSPLUS_BACKWARD_INCLUDE_DIR, "G++", 1, 1, 1, 0 },
31 #endif
32 #ifdef LOCAL_INCLUDE_DIR
33 /* /usr/local/include comes before the fixincluded header files. */
diff --git a/recipes-devtools/gcc/gcc-configure-cross.inc b/recipes-devtools/gcc/gcc-configure-cross.inc
index 3da92e24a..04a868535 100644
--- a/recipes-devtools/gcc/gcc-configure-cross.inc
+++ b/recipes-devtools/gcc/gcc-configure-cross.inc
@@ -5,7 +5,7 @@ USE_NLS = '${@base_conditional( "TARGET_OS", "linux-uclibc", "no", "", d )}'
5EXTRA_OECONF += " --enable-poison-system-directories " 5EXTRA_OECONF += " --enable-poison-system-directories "
6 6
7EXTRA_OECONF_PATHS = "--with-local-prefix=${STAGING_DIR_TARGET}${target_exec_prefix} \ 7EXTRA_OECONF_PATHS = "--with-local-prefix=${STAGING_DIR_TARGET}${target_exec_prefix} \
8 --with-gxx-include-dir=${STAGING_DIR_TARGET}/${target_includedir}/c++ \ 8 --with-gxx-include-dir=${target_includedir}/c++ \
9 --with-sysroot=${STAGING_DIR_TARGET} \ 9 --with-sysroot=${STAGING_DIR_TARGET} \
10 --with-build-sysroot=${STAGING_DIR_TARGET}" 10 --with-build-sysroot=${STAGING_DIR_TARGET}"
11 11
diff --git a/recipes-devtools/gcc/gcc-configure-sdk.inc b/recipes-devtools/gcc/gcc-configure-sdk.inc
index 0eb33adda..756e74e48 100644
--- a/recipes-devtools/gcc/gcc-configure-sdk.inc
+++ b/recipes-devtools/gcc/gcc-configure-sdk.inc
@@ -5,7 +5,7 @@ USE_NLS = '${@base_conditional( "TARGET_OS", "linux-uclibc", "no", "", d )}'
5USE_NLS = '${@base_conditional( "TARGET_OS", "linux-uclibcgnueabi", "no", "", d )}' 5USE_NLS = '${@base_conditional( "TARGET_OS", "linux-uclibcgnueabi", "no", "", d )}'
6 6
7EXTRA_OECONF_PATHS = "--with-local-prefix=${SDKPATH}/sysroots/${TARGET_SYS}${target_exec_prefix} \ 7EXTRA_OECONF_PATHS = "--with-local-prefix=${SDKPATH}/sysroots/${TARGET_SYS}${target_exec_prefix} \
8 --with-gxx-include-dir=${SDKPATH}/sysroots/${TARGET_SYS}${target_includedir}/c++ \ 8 --with-gxx-include-dir=${target_includedir}/c++ \
9 --with-build-time-tools=${STAGING_DIR_NATIVE}${prefix_native}/${TARGET_SYS}/bin \ 9 --with-build-time-tools=${STAGING_DIR_NATIVE}${prefix_native}/${TARGET_SYS}/bin \
10 --with-sysroot=${SDKPATH}/sysroots/${TARGET_SYS} \ 10 --with-sysroot=${SDKPATH}/sysroots/${TARGET_SYS} \
11 --with-build-sysroot=${STAGING_DIR_TARGET}" 11 --with-build-sysroot=${STAGING_DIR_TARGET}"
diff --git a/recipes-devtools/gcc/gcc-cross-canadian_4.5.bb b/recipes-devtools/gcc/gcc-cross-canadian_4.5.bb
index 4c48b8345..6a4cc5e98 100644
--- a/recipes-devtools/gcc/gcc-cross-canadian_4.5.bb
+++ b/recipes-devtools/gcc/gcc-cross-canadian_4.5.bb
@@ -5,14 +5,14 @@ require gcc-cross-canadian.inc
5require gcc-configure-sdk.inc 5require gcc-configure-sdk.inc
6require gcc-package-sdk.inc 6require gcc-package-sdk.inc
7 7
8PR = "r10" 8PR = "${INC_PR}.0"
9 9
10DEPENDS += "gmp-nativesdk mpfr-nativesdk libmpc-nativesdk elfutils-nativesdk" 10DEPENDS += "gmp-nativesdk mpfr-nativesdk libmpc-nativesdk elfutils-nativesdk"
11RDEPENDS_${PN} += "mpfr-nativesdk libmpc-nativesdk elfutils-nativesdk" 11RDEPENDS_${PN} += "mpfr-nativesdk libmpc-nativesdk elfutils-nativesdk"
12 12
13SYSTEMHEADERS = "/usr/include" 13SYSTEMHEADERS = "/usr/include"
14SYSTEMLIBS = "/lib/" 14SYSTEMLIBS = "/lib/"
15SYSTEMLIBS1 = "/usr/lib/" 15SYSTEMLIB. = "/usr/lib/"
16 16
17EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \ 17EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \
18 --disable-libgomp --disable-libmudflap \ 18 --disable-libgomp --disable-libmudflap \
diff --git a/recipes-devtools/gcc/gcc-cross-initial_4.5.bb b/recipes-devtools/gcc/gcc-cross-initial_4.5.bb
index 3ce5ca0a2..5ca9cd7a6 100644
--- a/recipes-devtools/gcc/gcc-cross-initial_4.5.bb
+++ b/recipes-devtools/gcc/gcc-cross-initial_4.5.bb
@@ -1,5 +1,5 @@
1require gcc-cross_${PV}.bb 1require gcc-cross_${PV}.bb
2require gcc-cross-initial.inc 2require gcc-cross-initial.inc
3 3
4PR = "r10" 4PR = "${INC_PR}.0"
5 5
diff --git a/recipes-devtools/gcc/gcc-cross-intermediate_4.5.bb b/recipes-devtools/gcc/gcc-cross-intermediate_4.5.bb
index 0fc54e2cc..aa7d148e8 100644
--- a/recipes-devtools/gcc/gcc-cross-intermediate_4.5.bb
+++ b/recipes-devtools/gcc/gcc-cross-intermediate_4.5.bb
@@ -1,4 +1,4 @@
1require gcc-cross_${PV}.bb 1require gcc-cross_${PV}.bb
2require gcc-cross-intermediate.inc 2require gcc-cross-intermediate.inc
3PR = "r10" 3PR = "${INC_PR}.0"
4 4
diff --git a/recipes-devtools/gcc/gcc-cross_4.5.bb b/recipes-devtools/gcc/gcc-cross_4.5.bb
index d56045446..2b7e72771 100644
--- a/recipes-devtools/gcc/gcc-cross_4.5.bb
+++ b/recipes-devtools/gcc/gcc-cross_4.5.bb
@@ -1,4 +1,4 @@
1PR = "r12" 1PR = "${INC_PR}.2"
2 2
3require gcc-${PV}.inc 3require gcc-${PV}.inc
4require gcc-cross4.inc 4require gcc-cross4.inc
diff --git a/recipes-devtools/gcc/gcc-crosssdk-initial_4.5.bb b/recipes-devtools/gcc/gcc-crosssdk-initial_4.5.bb
index 69afbae2f..8853e48bf 100644
--- a/recipes-devtools/gcc/gcc-crosssdk-initial_4.5.bb
+++ b/recipes-devtools/gcc/gcc-crosssdk-initial_4.5.bb
@@ -1,4 +1,4 @@
1require gcc-cross-initial_${PV}.bb 1require gcc-cross-initial_${PV}.bb
2require gcc-crosssdk-initial.inc 2require gcc-crosssdk-initial.inc
3 3
4PR = "r10" 4PR = "${INC_PR}.0"
diff --git a/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.5.bb b/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.5.bb
index 934ae644a..547c9570f 100644
--- a/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.5.bb
+++ b/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.5.bb
@@ -1,4 +1,4 @@
1require gcc-cross-intermediate_${PV}.bb 1require gcc-cross-intermediate_${PV}.bb
2require gcc-crosssdk-intermediate.inc 2require gcc-crosssdk-intermediate.inc
3 3
4PR = "r10" 4PR = "${INC_PR}.0"
diff --git a/recipes-devtools/gcc/gcc-crosssdk_4.5.bb b/recipes-devtools/gcc/gcc-crosssdk_4.5.bb
index 48a68bed1..25c000aa7 100644
--- a/recipes-devtools/gcc/gcc-crosssdk_4.5.bb
+++ b/recipes-devtools/gcc/gcc-crosssdk_4.5.bb
@@ -1,4 +1,4 @@
1require gcc-cross_${PV}.bb 1require gcc-cross_${PV}.bb
2require gcc-crosssdk.inc 2require gcc-crosssdk.inc
3 3
4PR = "r10" 4PR = "${INC_PR}.0"
diff --git a/recipes-devtools/gcc/gcc-runtime_4.5.bb b/recipes-devtools/gcc/gcc-runtime_4.5.bb
index fc3ab0711..36df1d002 100644
--- a/recipes-devtools/gcc/gcc-runtime_4.5.bb
+++ b/recipes-devtools/gcc/gcc-runtime_4.5.bb
@@ -1,4 +1,4 @@
1PR = "r10" 1PR = "${INC_PR}.0"
2 2
3require gcc-${PV}.inc 3require gcc-${PV}.inc
4require gcc-configure-runtime.inc 4require gcc-configure-runtime.inc
diff --git a/recipes-devtools/gcc/gcc_4.5.bb b/recipes-devtools/gcc/gcc_4.5.bb
index f54c3c6f5..442c273ff 100644
--- a/recipes-devtools/gcc/gcc_4.5.bb
+++ b/recipes-devtools/gcc/gcc_4.5.bb
@@ -1,4 +1,4 @@
1PR = "r11" 1PR = "${INC_PR}.1"
2 2
3require gcc-${PV}.inc 3require gcc-${PV}.inc
4require gcc-configure-target.inc 4require gcc-configure-target.inc