summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>2020-04-04 14:38:37 +0000
committerKhem Raj <raj.khem@gmail.com>2020-04-04 12:51:09 -0700
commit40ddc2cbf03c1b2b9b3e66d4b39896924d8963ca (patch)
treeade8d0d449cd7f1828096638bc14eb38f6e4b69a /recipes-devtools
parent248316fd60de06f2cae38ce6092dbd1b112d7f4b (diff)
downloadmeta-openembedded-40ddc2cbf03c1b2b9b3e66d4b39896924d8963ca.tar.gz
python3-pyscaffold: add pyscaffold recipe
Add recipe which handles pyscaffold package to the layer. Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python3-pyscaffold_3.2.3.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-pyscaffold_3.2.3.bb b/recipes-devtools/python/python3-pyscaffold_3.2.3.bb
new file mode 100644
index 000000000..dbd222f54
--- /dev/null
+++ b/recipes-devtools/python/python3-pyscaffold_3.2.3.bb
@@ -0,0 +1,18 @@
1SUMMARY = "Python project template generator with batteries included"
2DESCRIPTION = "PyScaffold package helps to setup a new Python project. \
3After installation, it provides a new command [putup], which could be \
4used to create template Projects."
5
6HOMEPAGE = "https://github.com/pyscaffold/pyscaffold"
7SECTION = "devel/python"
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=8227180126797a0148f94f483f3e1489"
10
11inherit pypi setuptools3
12
13PYPI_PACKAGE = "PyScaffold"
14
15SRC_URI[md5sum] = "6769d2a26a9d1f3038944b8fbfe728ff"
16SRC_URI[sha256sum] = "96c3e7f5529df0b5b351e879a141e1e5c9f26211f30d493c23d8c09d9d610a6f"
17
18BBCLASSEXTEND = "native nativesdk"