summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-01-13 20:51:12 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-01-13 20:51:12 +0100
commit3e2ce6c26a6e58b6a0d0079ede3922ea35d2d6ba (patch)
treeb42398d1f8fa54dfbe36a190ff742d44423f5f8f /recipes-devtools
parent94237e310fd27f9f66699c07311ff0ae17f8ee20 (diff)
downloadmeta-openembedded-3e2ce6c26a6e58b6a0d0079ede3922ea35d2d6ba.tar.gz
python-setuptools: import from OE
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-setuptools_0.6c11.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-setuptools_0.6c11.bb b/recipes-devtools/python/python-setuptools_0.6c11.bb
new file mode 100644
index 000000000..6b17a41f7
--- /dev/null
+++ b/recipes-devtools/python/python-setuptools_0.6c11.bb
@@ -0,0 +1,34 @@
1DESCRIPTION = "Download, build, install, upgrade, and uninstall Python packages"
2HOMEPAGE = "http://cheeseshop.python.org/pypi/setuptools"
3SECTION = "devel/python"
4PRIORITY = "optional"
5LICENSE = "PSF"
6LIC_FILES_CHKSUM = "file://setup.py;beginline=23;endline=23;md5=8a314270dd7a8dbca741775415f1716e"
7
8SRCNAME = "setuptools"
9PR = "ml2"
10DEPENDS += "python"
11DEPENDS_virtclass-native += "python-native"
12
13SRC_URI = "\
14 http://cheeseshop.python.org/packages/source/s/setuptools/${SRCNAME}-${PV}.tar.gz\
15"
16S = "${WORKDIR}/${SRCNAME}-${PV}"
17
18inherit distutils
19
20do_install_prepend() {
21 install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
22}
23
24RDEPENDS_${PN} = "\
25 python-distutils \
26 python-compression \
27"
28
29SRC_URI[md5sum] = "7df2a529a074f613b509fb44feefe74e"
30SRC_URI[sha256sum] = "630fea9b726320b73ee3ca6ff61732cb32675b0389be658080fe46383b87a1d3"
31
32BBCLASSEXTEND = "native"
33
34NATIVE_INSTALL_WORKS = "1"