summaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2019-06-28 23:22:56 +0800
committerKhem Raj <raj.khem@gmail.com>2019-07-10 09:24:32 -0700
commit19c7cbc51a35df478089b315c9a9977389a0717c (patch)
tree939dd009cc0fffd2ccacd5a40a390edb8239e758 /meta-xfce
parent310df900fb0cc9acd939a04501941c38a45114aa (diff)
downloadmeta-openembedded-19c7cbc51a35df478089b315c9a9977389a0717c.tar.gz
xfce4-panel: use lxdm to replace dm-tool
OE does not support lightdm but lxdm, so use lxdm to replace dm-tool Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-xfce/xfce4-panel/files/0001-use-lxdm-to-replace-dm-tool.patch49
-rw-r--r--meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.13.5.bb1
2 files changed, 50 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/files/0001-use-lxdm-to-replace-dm-tool.patch b/meta-xfce/recipes-xfce/xfce4-panel/files/0001-use-lxdm-to-replace-dm-tool.patch
new file mode 100644
index 000000000..b06e26e91
--- /dev/null
+++ b/meta-xfce/recipes-xfce/xfce4-panel/files/0001-use-lxdm-to-replace-dm-tool.patch
@@ -0,0 +1,49 @@
1From b80108f01b1425427f98341168ea44c4b1a5a2cf Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Fri, 28 Jun 2019 16:02:13 +0800
4Subject: [PATCH] use lxdm to replace dm-tool
5
6OE does not support lightdm but lxdm,
7so use lxdm to replace dm-tool
8
9Upstream-Status: Inappropriate [oe specific]
10
11Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
12---
13 plugins/actions/actions.c | 8 ++++----
14 1 file changed, 4 insertions(+), 4 deletions(-)
15
16diff --git a/plugins/actions/actions.c b/plugins/actions/actions.c
17index 474798e..63eb41d 100644
18--- a/plugins/actions/actions.c
19+++ b/plugins/actions/actions.c
20@@ -905,12 +905,12 @@ actions_plugin_actions_allowed (void)
21 GError *error = NULL;
22
23 /* check for commands we use */
24- path = g_find_program_in_path ("dm-tool");
25+ path = g_find_program_in_path ("lxdm");
26 if (path != NULL)
27 PANEL_SET_FLAG (allow_mask, ACTION_TYPE_SWITCH_USER);
28 else
29 {
30- /* check for gdmflexiserver if dm-tool is not present */
31+ /* check for gdmflexiserver if lxdm is not present */
32 g_free (path);
33 path = g_find_program_in_path ("gdmflexiserver");
34 if (path != NULL)
35@@ -1027,9 +1027,9 @@ actions_plugin_action_activate (GtkWidget *widget,
36 break;
37
38 case ACTION_TYPE_SWITCH_USER:
39- path = g_find_program_in_path ("dm-tool");
40+ path = g_find_program_in_path ("lxdm");
41 if (path != NULL)
42- succeed = g_spawn_command_line_async ("dm-tool switch-to-greeter", &error);
43+ succeed = g_spawn_command_line_async ("lxdm -c USER_SWITCH", &error);
44 else
45 succeed = g_spawn_command_line_async ("gdmflexiserver", &error);
46 g_free (path);
47--
482.8.1
49
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.13.5.bb b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.13.5.bb
index a4b200a7e..cebddf6f9 100644
--- a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.13.5.bb
+++ b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.13.5.bb
@@ -12,6 +12,7 @@ SRC_URI[md5sum] = "376e360fb87095edaea7df8ca34fe6a7"
12SRC_URI[sha256sum] = "0d05b6dd8c91c154a364a3e31583c5f423c33e26d44d43cc409165f7d578ca15" 12SRC_URI[sha256sum] = "0d05b6dd8c91c154a364a3e31583c5f423c33e26d44d43cc409165f7d578ca15"
13SRC_URI += " \ 13SRC_URI += " \
14 file://0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch \ 14 file://0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch \
15 file://0001-use-lxdm-to-replace-dm-tool.patch \
15" 16"
16 17
17python populate_packages_prepend() { 18python populate_packages_prepend() {