diff options
author | Andreas Müller <schnitzeltony@gmx.de> | 2011-10-30 11:47:21 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-10-31 11:26:00 +0100 |
commit | 192030c5282c14c0cdfb9c05bd806f021edd7e2d (patch) | |
tree | f68e1c2daf1f230e05a7645660945ccc16830661 /meta-xfce | |
parent | d2b1fea3990d123f7c2739535b945523eea7aedc (diff) | |
download | meta-openembedded-192030c5282c14c0cdfb9c05bd806f021edd7e2d.tar.gz |
xfce4-eyes-plugin: initial add 4.4.1
* port-to-libxfce4ui.patch was send to xfce-buglist [1]
* run tested on overo
[1] https://bugzilla.xfce.org/show_bug.cgi?id=8074
Signed-off-by: Andreas Müller <schnitzeltony@gmx.de>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-xfce')
-rw-r--r-- | meta-xfce/recipes-panel-plugins/eyes/files/port-to-libxfce4ui.patch | 68 | ||||
-rw-r--r-- | meta-xfce/recipes-panel-plugins/eyes/xfce4-eyes-plugin_4.4.1.bb | 13 |
2 files changed, 81 insertions, 0 deletions
diff --git a/meta-xfce/recipes-panel-plugins/eyes/files/port-to-libxfce4ui.patch b/meta-xfce/recipes-panel-plugins/eyes/files/port-to-libxfce4ui.patch new file mode 100644 index 000000000..2fa96f7b6 --- /dev/null +++ b/meta-xfce/recipes-panel-plugins/eyes/files/port-to-libxfce4ui.patch | |||
@@ -0,0 +1,68 @@ | |||
1 | From aef48031ed443be04bfd16ae755766ff75d624b6 Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmx.de> | ||
3 | Date: Wed, 26 Oct 2011 00:40:09 +0200 | ||
4 | Subject: [PATCH] port to libxfce4ui | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | |||
10 | Signed-off-by: Andreas Müller <schnitzeltony@gmx.de> | ||
11 | --- | ||
12 | configure.ac | 6 +++--- | ||
13 | panel-plugin/Makefile.am | 4 ++-- | ||
14 | panel-plugin/eyes.c | 2 +- | ||
15 | 3 files changed, 6 insertions(+), 6 deletions(-) | ||
16 | |||
17 | diff --git a/configure.ac b/configure.ac | ||
18 | index 5ff1397..67e2288 100644 | ||
19 | --- a/configure.ac | ||
20 | +++ b/configure.ac | ||
21 | @@ -56,9 +56,9 @@ dnl *** Check for required packages *** | ||
22 | dnl *********************************** | ||
23 | XDT_CHECK_PACKAGE([GTHREAD], [gthread-2.0], [2.6.0]) | ||
24 | XDT_CHECK_PACKAGE([GTK], [gtk+-2.0], [2.6.0]) | ||
25 | -XDT_CHECK_PACKAGE([LIBXFCEGUI4], [libxfcegui4-1.0], [4.3.90.2]) | ||
26 | -XDT_CHECK_PACKAGE([LIBXFCE4UTIL], [libxfce4util-1.0], [4.3.90.2]) | ||
27 | -XDT_CHECK_PACKAGE([LIBXFCE4PANEL], [libxfce4panel-1.0], [4.3.99.1]) | ||
28 | +XDT_CHECK_PACKAGE([LIBXFCE4UI], [libxfce4ui-1], [4.8.0]) | ||
29 | +XDT_CHECK_PACKAGE([LIBXFCE4UTIL], [libxfce4util-1.0], [4.8.0]) | ||
30 | +XDT_CHECK_PACKAGE([LIBXFCE4PANEL], [libxfce4panel-1.0], [4.8.0]) | ||
31 | |||
32 | dnl *********************************** | ||
33 | dnl *** Check for debugging support *** | ||
34 | diff --git a/panel-plugin/Makefile.am b/panel-plugin/Makefile.am | ||
35 | index 1ee4d28..249303c 100644 | ||
36 | --- a/panel-plugin/Makefile.am | ||
37 | +++ b/panel-plugin/Makefile.am | ||
38 | @@ -13,12 +13,12 @@ xfce4_eyes_plugin_SOURCES = \ | ||
39 | themes.c | ||
40 | |||
41 | xfce4_eyes_plugin_CFLAGS = \ | ||
42 | - $(LIBXFCEGUI4_CFLAGS) \ | ||
43 | + $(LIBXFCE4UI_CFLAGS) \ | ||
44 | $(LIBXFCE4PANEL_CFLAGS) | ||
45 | |||
46 | xfce4_eyes_plugin_LDADD = \ | ||
47 | $(LIBXFCE4PANEL_LIBS) \ | ||
48 | - $(LIBXFCEGUI4_LIBS) | ||
49 | + $(LIBXFCE4UI_LIBS) | ||
50 | |||
51 | desktopdir = $(datadir)/xfce4/panel-plugins | ||
52 | desktop_in_in_files = eyes.desktop.in.in | ||
53 | diff --git a/panel-plugin/eyes.c b/panel-plugin/eyes.c | ||
54 | index 6c71938..f3cd195 100644 | ||
55 | --- a/panel-plugin/eyes.c | ||
56 | +++ b/panel-plugin/eyes.c | ||
57 | @@ -33,7 +33,7 @@ | ||
58 | #include <stdlib.h> | ||
59 | |||
60 | #include <libxfce4util/libxfce4util.h> | ||
61 | -#include <libxfcegui4/libxfcegui4.h> | ||
62 | +#include <libxfce4ui/libxfce4ui.h> | ||
63 | |||
64 | #include "eyes.h" | ||
65 | #include "themes.h" | ||
66 | -- | ||
67 | 1.7.4.4 | ||
68 | |||
diff --git a/meta-xfce/recipes-panel-plugins/eyes/xfce4-eyes-plugin_4.4.1.bb b/meta-xfce/recipes-panel-plugins/eyes/xfce4-eyes-plugin_4.4.1.bb new file mode 100644 index 000000000..6ca49c772 --- /dev/null +++ b/meta-xfce/recipes-panel-plugins/eyes/xfce4-eyes-plugin_4.4.1.bb | |||
@@ -0,0 +1,13 @@ | |||
1 | DESCRIPTION = "Panel plugin with graphical representation of the cpu frequency" | ||
2 | HOMEPAGE = "http://goodies.xfce.org/projects/panel-plugins/xfce4-eyes-plugin" | ||
3 | LICENSE = "GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | ||
5 | |||
6 | inherit xfce-panel-plugin | ||
7 | |||
8 | # SRC_URI must follow inherited one | ||
9 | SRC_URI += "file://port-to-libxfce4ui.patch" | ||
10 | SRC_URI[md5sum] = "dcbf6ea9035d379d168b479be0d09f14" | ||
11 | SRC_URI[sha256sum] = "eaae5d230b5c2fe6a8b448b59cfe959bf126796911c166a7343a51dc440fbbb2" | ||
12 | |||
13 | FILES_${PN} += "${datadir}/xfce4/eyes" | ||