summaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2018-10-26 12:48:54 +0200
committerKhem Raj <raj.khem@gmail.com>2018-10-26 21:08:44 -0700
commitb96a6eabb0bf1310dd3a72f146c359af5376fed8 (patch)
tree4777d0989b6fa75d9015cbbb7c331766e49c38dd /meta-xfce
parenta602c884a6688ee12392097cb92fab94b7cb0598 (diff)
downloadmeta-openembedded-b96a6eabb0bf1310dd3a72f146c359af5376fed8.tar.gz
xfce4-panel-profiles: initial add 1.0.8
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-apps/xfce4-panel-profiles/xfce4-panel-profiles_1.0.8.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-xfce/recipes-apps/xfce4-panel-profiles/xfce4-panel-profiles_1.0.8.bb b/meta-xfce/recipes-apps/xfce4-panel-profiles/xfce4-panel-profiles_1.0.8.bb
new file mode 100644
index 000000000..5fa2a7bce
--- /dev/null
+++ b/meta-xfce/recipes-apps/xfce4-panel-profiles/xfce4-panel-profiles_1.0.8.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Backup, restore, import, and export panel layouts"
2SECTION = "x11/application"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
5
6inherit python3native gettext distro_features_check
7
8REQUIRED_DISTRO_FEATURES = "x11"
9
10DEPENDS += "intltool-native"
11
12SRC_URI = "http://archive.xfce.org/src/apps/${BPN}/1.0/${BPN}-${PV}.tar.bz2"
13SRC_URI[md5sum] = "bc75a143423fba3a82f114f47e86580c"
14SRC_URI[sha256sum] = "a69e20f5e637319e14898b5c13ff7ba31d001a6e38e7516d70dbfd7600ad72db"
15
16do_configure() {
17 # special configure - no autotools...
18 ./configure --prefix=${prefix}
19}
20
21do_install() {
22 oe_runmake 'DESTDIR=${D}' install
23 sed -i 's:${PYTHON}:python3:g' ${D}${bindir}/xfce4-panel-profiles
24}
25
26FILES_${PN} += "${datadir}/metainfo"
27
28RDEPENDS_${PN} += "python3-pygobject python3-pexpect"