diff options
author | Andreas Müller <schnitzeltony@googlemail.com> | 2016-10-31 23:10:49 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-11-22 13:59:42 +0100 |
commit | 7c55dd1e295d7b7b2125bc7e7e4740aaff3caef4 (patch) | |
tree | 0cc25098c6411f4f76cf708ca59dcfa8382d620b /meta-xfce | |
parent | 794acac89d12aceb181d17d7e3ede9b5e7bab6c8 (diff) | |
download | meta-openembedded-7c55dd1e295d7b7b2125bc7e7e4740aaff3caef4.tar.gz |
xfce4-panel: update to 4.12.1
* 0001-Fix-compiler-warning-in-clock-plugin-about-shadowed-.patch was a
backport and is now included upstream
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r-- | meta-xfce/recipes-xfce/xfce4-panel/files/0001-Fix-compiler-warning-in-clock-plugin-about-shadowed-.patch | 606 | ||||
-rw-r--r-- | meta-xfce/recipes-xfce/xfce4-panel/files/0001-clock-time-make-change-of-system-s-timezone-change-t.patch (renamed from meta-xfce/recipes-xfce/xfce4-panel/files/0002-clock-time-make-change-of-system-s-timezone-change-t.patch) | 0 | ||||
-rw-r--r-- | meta-xfce/recipes-xfce/xfce4-panel/files/0002-windowmenu-do-not-display-desktop-icon-when-no-windo.patch (renamed from meta-xfce/recipes-xfce/xfce4-panel/files/0003-windowmenu-do-not-display-desktop-icon-when-no-windo.patch) | 0 | ||||
-rw-r--r-- | meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.12.1.bb (renamed from meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.12.0.bb) | 9 |
4 files changed, 4 insertions, 611 deletions
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/files/0001-Fix-compiler-warning-in-clock-plugin-about-shadowed-.patch b/meta-xfce/recipes-xfce/xfce4-panel/files/0001-Fix-compiler-warning-in-clock-plugin-about-shadowed-.patch deleted file mode 100644 index d971fca05..000000000 --- a/meta-xfce/recipes-xfce/xfce4-panel/files/0001-Fix-compiler-warning-in-clock-plugin-about-shadowed-.patch +++ /dev/null | |||
@@ -1,606 +0,0 @@ | |||
1 | From 5a9e94ab7bd628f5bf6b46ea7ea91cf40b4aee98 Mon Sep 17 00:00:00 2001 | ||
2 | From: Matt Thirtytwo <matt.59491@gmail.com> | ||
3 | Date: Mon, 2 Mar 2015 21:18:41 +0100 | ||
4 | Subject: [PATCH] Fix compiler warning in clock plugin about shadowed 'time' | ||
5 | variable | ||
6 | |||
7 | Upstream-Status: Backport [1] | ||
8 | |||
9 | [1] http://git.xfce.org/xfce/xfce4-panel/commit/?id=5a9e94ab7bd628f5bf6b46ea7ea91cf40b4aee98 | ||
10 | |||
11 | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> | ||
12 | |||
13 | --- | ||
14 | plugins/clock/clock-analog.c | 20 ++++++------- | ||
15 | plugins/clock/clock-binary.c | 28 +++++++++--------- | ||
16 | plugins/clock/clock-digital.c | 8 ++--- | ||
17 | plugins/clock/clock-fuzzy.c | 6 ++-- | ||
18 | plugins/clock/clock-lcd.c | 34 +++++++++++----------- | ||
19 | plugins/clock/clock-time.c | 68 +++++++++++++++++++++---------------------- | ||
20 | plugins/clock/clock.c | 12 ++++---- | ||
21 | 7 files changed, 88 insertions(+), 88 deletions(-) | ||
22 | |||
23 | diff --git a/plugins/clock/clock-analog.c b/plugins/clock/clock-analog.c | ||
24 | index 2e96a09..910450d 100644 | ||
25 | --- a/plugins/clock/clock-analog.c | ||
26 | +++ b/plugins/clock/clock-analog.c | ||
27 | @@ -216,7 +216,7 @@ xfce_clock_analog_expose_event (GtkWidget *widget, | ||
28 | gdouble xc, yc; | ||
29 | gdouble angle, radius; | ||
30 | cairo_t *cr; | ||
31 | - GDateTime *time; | ||
32 | + GDateTime *date_time; | ||
33 | |||
34 | panel_return_val_if_fail (XFCE_CLOCK_IS_ANALOG (analog), FALSE); | ||
35 | |||
36 | @@ -239,7 +239,7 @@ xfce_clock_analog_expose_event (GtkWidget *widget, | ||
37 | cairo_clip (cr); | ||
38 | |||
39 | /* get the local time */ | ||
40 | - time = clock_time_get_time (analog->time); | ||
41 | + date_time = clock_time_get_time (analog->time); | ||
42 | |||
43 | /* set the line properties */ | ||
44 | cairo_set_line_width (cr, 1); | ||
45 | @@ -251,20 +251,20 @@ xfce_clock_analog_expose_event (GtkWidget *widget, | ||
46 | if (analog->show_seconds) | ||
47 | { | ||
48 | /* second pointer */ | ||
49 | - angle = TICKS_TO_RADIANS (g_date_time_get_second (time)); | ||
50 | + angle = TICKS_TO_RADIANS (g_date_time_get_second (date_time)); | ||
51 | xfce_clock_analog_draw_pointer (cr, xc, yc, radius, angle, 0.7, TRUE); | ||
52 | } | ||
53 | |||
54 | /* minute pointer */ | ||
55 | - angle = TICKS_TO_RADIANS (g_date_time_get_minute (time)); | ||
56 | + angle = TICKS_TO_RADIANS (g_date_time_get_minute (date_time)); | ||
57 | xfce_clock_analog_draw_pointer (cr, xc, yc, radius, angle, 0.8, FALSE); | ||
58 | |||
59 | /* hour pointer */ | ||
60 | - angle = HOURS_TO_RADIANS (g_date_time_get_hour (time), g_date_time_get_minute (time)); | ||
61 | + angle = HOURS_TO_RADIANS (g_date_time_get_hour (date_time), g_date_time_get_minute (date_time)); | ||
62 | xfce_clock_analog_draw_pointer (cr, xc, yc, radius, angle, 0.5, FALSE); | ||
63 | |||
64 | /* cleanup */ | ||
65 | - g_date_time_unref (time); | ||
66 | + g_date_time_unref (date_time); | ||
67 | cairo_destroy (cr); | ||
68 | } | ||
69 | |||
70 | @@ -347,12 +347,12 @@ xfce_clock_analog_draw_pointer (cairo_t *cr, | ||
71 | |||
72 | static gboolean | ||
73 | xfce_clock_analog_update (XfceClockAnalog *analog, | ||
74 | - ClockTime *time) | ||
75 | + ClockTime *clock_time) | ||
76 | { | ||
77 | GtkWidget *widget = GTK_WIDGET (analog); | ||
78 | |||
79 | panel_return_val_if_fail (XFCE_CLOCK_IS_ANALOG (analog), FALSE); | ||
80 | - panel_return_val_if_fail (XFCE_IS_CLOCK_TIME (time), FALSE); | ||
81 | + panel_return_val_if_fail (XFCE_IS_CLOCK_TIME (clock_time), FALSE); | ||
82 | |||
83 | /* update if the widget if visible */ | ||
84 | if (G_LIKELY (GTK_WIDGET_VISIBLE (widget))) | ||
85 | @@ -364,11 +364,11 @@ xfce_clock_analog_update (XfceClockAnalog *analog, | ||
86 | |||
87 | |||
88 | GtkWidget * | ||
89 | -xfce_clock_analog_new (ClockTime *time) | ||
90 | +xfce_clock_analog_new (ClockTime *clock_time) | ||
91 | { | ||
92 | XfceClockAnalog *analog = g_object_new (XFCE_CLOCK_TYPE_ANALOG, NULL); | ||
93 | |||
94 | - analog->time = time; | ||
95 | + analog->time = clock_time; | ||
96 | analog->timeout = clock_time_timeout_new (CLOCK_INTERVAL_MINUTE, | ||
97 | analog->time, | ||
98 | G_CALLBACK (xfce_clock_analog_update), analog); | ||
99 | diff --git a/plugins/clock/clock-binary.c b/plugins/clock/clock-binary.c | ||
100 | index 4751c51..46b852c 100644 | ||
101 | --- a/plugins/clock/clock-binary.c | ||
102 | +++ b/plugins/clock/clock-binary.c | ||
103 | @@ -262,7 +262,7 @@ xfce_clock_binary_expose_event_true_binary (XfceClockBinary *binary, | ||
104 | GtkAllocation *alloc) | ||
105 | { | ||
106 | GdkColor *active, *inactive; | ||
107 | - GDateTime *time; | ||
108 | + GDateTime *date_time; | ||
109 | gint row, rows; | ||
110 | static gint binary_table[] = { 32, 16, 8, 4, 2, 1 }; | ||
111 | gint col, cols = G_N_ELEMENTS (binary_table); | ||
112 | @@ -282,7 +282,7 @@ xfce_clock_binary_expose_event_true_binary (XfceClockBinary *binary, | ||
113 | active = &(GTK_WIDGET (binary)->style->dark[GTK_STATE_SELECTED]); | ||
114 | } | ||
115 | |||
116 | - time = clock_time_get_time (binary->time); | ||
117 | + date_time = clock_time_get_time (binary->time); | ||
118 | |||
119 | /* init sizes */ | ||
120 | remain_h = alloc->height; | ||
121 | @@ -293,11 +293,11 @@ xfce_clock_binary_expose_event_true_binary (XfceClockBinary *binary, | ||
122 | { | ||
123 | /* get the time this row represents */ | ||
124 | if (row == 0) | ||
125 | - ticks = g_date_time_get_hour (time); | ||
126 | + ticks = g_date_time_get_hour (date_time); | ||
127 | else if (row == 1) | ||
128 | - ticks = g_date_time_get_minute (time); | ||
129 | + ticks = g_date_time_get_minute (date_time); | ||
130 | else | ||
131 | - ticks = g_date_time_get_second (time); | ||
132 | + ticks = g_date_time_get_second (date_time); | ||
133 | |||
134 | /* reset sizes */ | ||
135 | remain_w = alloc->width; | ||
136 | @@ -336,7 +336,7 @@ xfce_clock_binary_expose_event_true_binary (XfceClockBinary *binary, | ||
137 | offset_y += h; | ||
138 | } | ||
139 | |||
140 | - g_date_time_unref (time); | ||
141 | + g_date_time_unref (date_time); | ||
142 | } | ||
143 | |||
144 | |||
145 | @@ -348,7 +348,7 @@ xfce_clock_binary_expose_event_binary (XfceClockBinary *binary, | ||
146 | { | ||
147 | GdkColor *active, *inactive; | ||
148 | static gint binary_table[] = { 80, 40, 20, 10, 8, 4, 2, 1 }; | ||
149 | - GDateTime *time; | ||
150 | + GDateTime *date_time; | ||
151 | gint row, rows = G_N_ELEMENTS (binary_table) / 2; | ||
152 | gint col, cols; | ||
153 | gint digit; | ||
154 | @@ -368,7 +368,7 @@ xfce_clock_binary_expose_event_binary (XfceClockBinary *binary, | ||
155 | active = &(GTK_WIDGET (binary)->style->dark[GTK_STATE_SELECTED]); | ||
156 | } | ||
157 | |||
158 | - time = clock_time_get_time (binary->time); | ||
159 | + date_time = clock_time_get_time (binary->time); | ||
160 | |||
161 | remain_w = alloc->width; | ||
162 | offset_x = alloc->x; | ||
163 | @@ -379,11 +379,11 @@ xfce_clock_binary_expose_event_binary (XfceClockBinary *binary, | ||
164 | { | ||
165 | /* get the time this row represents */ | ||
166 | if (col == 0) | ||
167 | - ticks = g_date_time_get_hour (time); | ||
168 | + ticks = g_date_time_get_hour (date_time); | ||
169 | else if (col == 2) | ||
170 | - ticks = g_date_time_get_minute (time); | ||
171 | + ticks = g_date_time_get_minute (date_time); | ||
172 | else if (col == 4) | ||
173 | - ticks = g_date_time_get_second (time); | ||
174 | + ticks = g_date_time_get_second (date_time); | ||
175 | |||
176 | /* reset sizes */ | ||
177 | remain_h = alloc->height; | ||
178 | @@ -520,7 +520,7 @@ xfce_clock_binary_expose_event (GtkWidget *widget, | ||
179 | |||
180 | static gboolean | ||
181 | xfce_clock_binary_update (XfceClockBinary *binary, | ||
182 | - ClockTime *time) | ||
183 | + ClockTime *clock_time) | ||
184 | { | ||
185 | GtkWidget *widget = GTK_WIDGET (binary); | ||
186 | |||
187 | @@ -536,11 +536,11 @@ xfce_clock_binary_update (XfceClockBinary *binary, | ||
188 | |||
189 | |||
190 | GtkWidget * | ||
191 | -xfce_clock_binary_new (ClockTime *time) | ||
192 | +xfce_clock_binary_new (ClockTime *clock_time) | ||
193 | { | ||
194 | XfceClockBinary *binary = g_object_new (XFCE_CLOCK_TYPE_BINARY, NULL); | ||
195 | |||
196 | - binary->time = time; | ||
197 | + binary->time = clock_time; | ||
198 | binary->timeout = clock_time_timeout_new (CLOCK_INTERVAL_MINUTE, | ||
199 | binary->time, | ||
200 | G_CALLBACK (xfce_clock_binary_update), binary); | ||
201 | diff --git a/plugins/clock/clock-digital.c b/plugins/clock/clock-digital.c | ||
202 | index c293ed2..34e7019 100644 | ||
203 | --- a/plugins/clock/clock-digital.c | ||
204 | +++ b/plugins/clock/clock-digital.c | ||
205 | @@ -194,12 +194,12 @@ xfce_clock_digital_finalize (GObject *object) | ||
206 | |||
207 | static gboolean | ||
208 | xfce_clock_digital_update (XfceClockDigital *digital, | ||
209 | - ClockTime *time) | ||
210 | + ClockTime *clock_time) | ||
211 | { | ||
212 | gchar *string; | ||
213 | |||
214 | panel_return_val_if_fail (XFCE_CLOCK_IS_DIGITAL (digital), FALSE); | ||
215 | - panel_return_val_if_fail (XFCE_IS_CLOCK_TIME (time), FALSE); | ||
216 | + panel_return_val_if_fail (XFCE_IS_CLOCK_TIME (clock_time), FALSE); | ||
217 | |||
218 | /* set time string */ | ||
219 | string = clock_time_strdup_strftime (digital->time, digital->format); | ||
220 | @@ -212,11 +212,11 @@ xfce_clock_digital_update (XfceClockDigital *digital, | ||
221 | |||
222 | |||
223 | GtkWidget * | ||
224 | -xfce_clock_digital_new (ClockTime *time) | ||
225 | +xfce_clock_digital_new (ClockTime *clock_time) | ||
226 | { | ||
227 | XfceClockDigital *digital = g_object_new (XFCE_CLOCK_TYPE_DIGITAL, NULL); | ||
228 | |||
229 | - digital->time = time; | ||
230 | + digital->time = clock_time; | ||
231 | digital->timeout = clock_time_timeout_new (clock_time_interval_from_format (digital->format), | ||
232 | digital->time, | ||
233 | G_CALLBACK (xfce_clock_digital_update), digital); | ||
234 | diff --git a/plugins/clock/clock-fuzzy.c b/plugins/clock/clock-fuzzy.c | ||
235 | index 7b0aa41..4b361dd 100644 | ||
236 | --- a/plugins/clock/clock-fuzzy.c | ||
237 | +++ b/plugins/clock/clock-fuzzy.c | ||
238 | @@ -275,7 +275,7 @@ xfce_clock_fuzzy_finalize (GObject *object) | ||
239 | |||
240 | static gboolean | ||
241 | xfce_clock_fuzzy_update (XfceClockFuzzy *fuzzy, | ||
242 | - ClockTime *time) | ||
243 | + ClockTime *clock_time) | ||
244 | { | ||
245 | GDateTime *date_time; | ||
246 | gint sector; | ||
247 | @@ -353,11 +353,11 @@ xfce_clock_fuzzy_update (XfceClockFuzzy *fuzzy, | ||
248 | |||
249 | |||
250 | GtkWidget * | ||
251 | -xfce_clock_fuzzy_new (ClockTime *time) | ||
252 | +xfce_clock_fuzzy_new (ClockTime *clock_time) | ||
253 | { | ||
254 | XfceClockFuzzy *fuzzy = g_object_new (XFCE_CLOCK_TYPE_FUZZY, NULL); | ||
255 | |||
256 | - fuzzy->time = time; | ||
257 | + fuzzy->time = clock_time; | ||
258 | fuzzy->timeout = clock_time_timeout_new (CLOCK_INTERVAL_MINUTE, | ||
259 | fuzzy->time, | ||
260 | G_CALLBACK (xfce_clock_fuzzy_update), fuzzy); | ||
261 | diff --git a/plugins/clock/clock-lcd.c b/plugins/clock/clock-lcd.c | ||
262 | index 84e74e6..b180d30 100644 | ||
263 | --- a/plugins/clock/clock-lcd.c | ||
264 | +++ b/plugins/clock/clock-lcd.c | ||
265 | @@ -285,7 +285,7 @@ xfce_clock_lcd_expose_event (GtkWidget *widget, | ||
266 | gint ticks, i; | ||
267 | gdouble size; | ||
268 | gdouble ratio; | ||
269 | - GDateTime *time; | ||
270 | + GDateTime *date_time; | ||
271 | |||
272 | panel_return_val_if_fail (XFCE_CLOCK_IS_LCD (lcd), FALSE); | ||
273 | |||
274 | @@ -317,10 +317,10 @@ xfce_clock_lcd_expose_event (GtkWidget *widget, | ||
275 | cairo_set_line_width (cr, MAX (size * 0.05, 1.5)); | ||
276 | |||
277 | /* get the local time */ | ||
278 | - time = clock_time_get_time (lcd->time); | ||
279 | + date_time = clock_time_get_time (lcd->time); | ||
280 | |||
281 | /* draw the hours */ | ||
282 | - ticks = g_date_time_get_hour (time); | ||
283 | + ticks = g_date_time_get_hour (date_time); | ||
284 | |||
285 | /* convert 24h clock to 12h clock */ | ||
286 | if (!lcd->show_military && ticks > 12) | ||
287 | @@ -333,8 +333,8 @@ xfce_clock_lcd_expose_event (GtkWidget *widget, | ||
288 | * because we might miss the exact second (due to slightly delayed | ||
289 | * timeout) we queue a resize the first 3 seconds or anything in | ||
290 | * the first minute */ | ||
291 | - if ((ticks == 10 || ticks == 0) && g_date_time_get_minute (time) == 0 | ||
292 | - && (!lcd->show_seconds || g_date_time_get_second (time) < 3)) | ||
293 | + if ((ticks == 10 || ticks == 0) && g_date_time_get_minute (date_time) == 0 | ||
294 | + && (!lcd->show_seconds || g_date_time_get_second (date_time) < 3)) | ||
295 | g_object_notify (G_OBJECT (lcd), "size-ratio"); | ||
296 | |||
297 | if (ticks >= 10) | ||
298 | @@ -352,7 +352,7 @@ xfce_clock_lcd_expose_event (GtkWidget *widget, | ||
299 | if (i == 0) | ||
300 | { | ||
301 | /* get the minutes */ | ||
302 | - ticks = g_date_time_get_minute (time); | ||
303 | + ticks = g_date_time_get_minute (date_time); | ||
304 | } | ||
305 | else | ||
306 | { | ||
307 | @@ -361,11 +361,11 @@ xfce_clock_lcd_expose_event (GtkWidget *widget, | ||
308 | break; | ||
309 | |||
310 | /* get the seconds */ | ||
311 | - ticks = g_date_time_get_second (time); | ||
312 | + ticks = g_date_time_get_second (date_time); | ||
313 | } | ||
314 | |||
315 | /* draw the dots */ | ||
316 | - if (lcd->flash_separators && (g_date_time_get_second (time) % 2) == 1) | ||
317 | + if (lcd->flash_separators && (g_date_time_get_second (date_time) % 2) == 1) | ||
318 | offset_x += size * RELATIVE_SPACE * 2; | ||
319 | else | ||
320 | offset_x = xfce_clock_lcd_draw_dots (cr, size, offset_x, offset_y); | ||
321 | @@ -380,14 +380,14 @@ xfce_clock_lcd_expose_event (GtkWidget *widget, | ||
322 | if (lcd->show_meridiem) | ||
323 | { | ||
324 | /* am or pm? */ | ||
325 | - ticks = g_date_time_get_hour (time) >= 12 ? 11 : 10; | ||
326 | + ticks = g_date_time_get_hour (date_time) >= 12 ? 11 : 10; | ||
327 | |||
328 | /* draw the digit */ | ||
329 | offset_x = xfce_clock_lcd_draw_digit (cr, ticks, size, offset_x, offset_y); | ||
330 | } | ||
331 | |||
332 | /* drop the pushed group */ | ||
333 | - g_date_time_unref (time); | ||
334 | + g_date_time_unref (date_time); | ||
335 | cairo_pop_group_to_source (cr); | ||
336 | cairo_paint (cr); | ||
337 | cairo_destroy (cr); | ||
338 | @@ -403,16 +403,16 @@ xfce_clock_lcd_get_ratio (XfceClockLcd *lcd) | ||
339 | { | ||
340 | gdouble ratio; | ||
341 | gint ticks; | ||
342 | - GDateTime *time; | ||
343 | + GDateTime *date_time; | ||
344 | |||
345 | /* get the local time */ | ||
346 | - time = clock_time_get_time (lcd->time); | ||
347 | + date_time = clock_time_get_time (lcd->time); | ||
348 | |||
349 | /* 8:8(space)8 */ | ||
350 | ratio = (3 * RELATIVE_DIGIT) + RELATIVE_DOTS + RELATIVE_SPACE; | ||
351 | |||
352 | - ticks = g_date_time_get_hour (time); | ||
353 | - g_date_time_unref (time); | ||
354 | + ticks = g_date_time_get_hour (date_time); | ||
355 | + g_date_time_unref (date_time); | ||
356 | |||
357 | if (!lcd->show_military && ticks > 12) | ||
358 | ticks -= 12; | ||
359 | @@ -584,7 +584,7 @@ xfce_clock_lcd_draw_digit (cairo_t *cr, | ||
360 | |||
361 | static gboolean | ||
362 | xfce_clock_lcd_update (XfceClockLcd *lcd, | ||
363 | - ClockTime *time) | ||
364 | + ClockTime *clock_time) | ||
365 | { | ||
366 | GtkWidget *widget = GTK_WIDGET (lcd); | ||
367 | |||
368 | @@ -600,11 +600,11 @@ xfce_clock_lcd_update (XfceClockLcd *lcd, | ||
369 | |||
370 | |||
371 | GtkWidget * | ||
372 | -xfce_clock_lcd_new (ClockTime *time) | ||
373 | +xfce_clock_lcd_new (ClockTime *clock_time) | ||
374 | { | ||
375 | XfceClockLcd *lcd = g_object_new (XFCE_CLOCK_TYPE_LCD, NULL); | ||
376 | |||
377 | - lcd->time = time; | ||
378 | + lcd->time = clock_time; | ||
379 | lcd->timeout = clock_time_timeout_new (CLOCK_INTERVAL_MINUTE, | ||
380 | lcd->time, | ||
381 | G_CALLBACK (xfce_clock_lcd_update), lcd); | ||
382 | diff --git a/plugins/clock/clock-time.c b/plugins/clock/clock-time.c | ||
383 | index 16b0f89..b015b13 100644 | ||
384 | --- a/plugins/clock/clock-time.c | ||
385 | +++ b/plugins/clock/clock-time.c | ||
386 | @@ -107,10 +107,10 @@ clock_time_class_init (ClockTimeClass *klass) | ||
387 | |||
388 | |||
389 | static void | ||
390 | -clock_time_init (ClockTime *time) | ||
391 | +clock_time_init (ClockTime *clock_time) | ||
392 | { | ||
393 | - time->timezone_name = g_strdup (DEFAULT_TIMEZONE); | ||
394 | - time->timezone = g_time_zone_new_local (); | ||
395 | + clock_time->timezone_name = g_strdup (DEFAULT_TIMEZONE); | ||
396 | + clock_time->timezone = g_time_zone_new_local (); | ||
397 | } | ||
398 | |||
399 | |||
400 | @@ -118,11 +118,11 @@ clock_time_init (ClockTime *time) | ||
401 | static void | ||
402 | clock_time_finalize (GObject *object) | ||
403 | { | ||
404 | - ClockTime *time = XFCE_CLOCK_TIME (object); | ||
405 | + ClockTime *clock_time = XFCE_CLOCK_TIME (object); | ||
406 | |||
407 | - g_free (time->timezone_name); | ||
408 | + g_free (clock_time->timezone_name); | ||
409 | |||
410 | - g_time_zone_unref (time->timezone); | ||
411 | + g_time_zone_unref (clock_time->timezone); | ||
412 | |||
413 | G_OBJECT_CLASS (clock_time_parent_class)->finalize (object); | ||
414 | } | ||
415 | @@ -135,12 +135,12 @@ clock_time_get_property (GObject *object, | ||
416 | GValue *value, | ||
417 | GParamSpec *pspec) | ||
418 | { | ||
419 | - ClockTime *time = XFCE_CLOCK_TIME (object); | ||
420 | + ClockTime *clock_time = XFCE_CLOCK_TIME (object); | ||
421 | |||
422 | switch (prop_id) | ||
423 | { | ||
424 | case PROP_TIMEZONE: | ||
425 | - g_value_set_string (value, time->timezone_name); | ||
426 | + g_value_set_string (value, clock_time->timezone_name); | ||
427 | break; | ||
428 | |||
429 | default: | ||
430 | @@ -157,29 +157,29 @@ clock_time_set_property (GObject *object, | ||
431 | const GValue *value, | ||
432 | GParamSpec *pspec) | ||
433 | { | ||
434 | - ClockTime *time = XFCE_CLOCK_TIME (object); | ||
435 | + ClockTime *clock_time = XFCE_CLOCK_TIME (object); | ||
436 | const gchar *str_value; | ||
437 | |||
438 | switch (prop_id) | ||
439 | { | ||
440 | case PROP_TIMEZONE: | ||
441 | str_value = g_value_get_string (value); | ||
442 | - if (g_strcmp0 (time->timezone_name, str_value) != 0) | ||
443 | + if (g_strcmp0 (clock_time->timezone_name, str_value) != 0) | ||
444 | { | ||
445 | - g_free (time->timezone_name); | ||
446 | - g_time_zone_unref (time->timezone); | ||
447 | + g_free (clock_time->timezone_name); | ||
448 | + g_time_zone_unref (clock_time->timezone); | ||
449 | if (str_value == NULL || g_strcmp0 (str_value, "") == 0) | ||
450 | { | ||
451 | - time->timezone_name = g_strdup (DEFAULT_TIMEZONE); | ||
452 | - time->timezone = g_time_zone_new_local (); | ||
453 | + clock_time->timezone_name = g_strdup (DEFAULT_TIMEZONE); | ||
454 | + clock_time->timezone = g_time_zone_new_local (); | ||
455 | } | ||
456 | else | ||
457 | { | ||
458 | - time->timezone_name = g_strdup (str_value); | ||
459 | - time->timezone = g_time_zone_new (str_value); | ||
460 | + clock_time->timezone_name = g_strdup (str_value); | ||
461 | + clock_time->timezone = g_time_zone_new (str_value); | ||
462 | } | ||
463 | |||
464 | - g_signal_emit (G_OBJECT (time), clock_time_signals[TIME_CHANGED], 0); | ||
465 | + g_signal_emit (G_OBJECT (clock_time), clock_time_signals[TIME_CHANGED], 0); | ||
466 | } | ||
467 | break; | ||
468 | |||
469 | @@ -192,14 +192,14 @@ clock_time_set_property (GObject *object, | ||
470 | |||
471 | |||
472 | GDateTime * | ||
473 | -clock_time_get_time (ClockTime *time) | ||
474 | +clock_time_get_time (ClockTime *clock_time) | ||
475 | { | ||
476 | GDateTime *date_time; | ||
477 | |||
478 | - panel_return_val_if_fail (XFCE_IS_CLOCK_TIME (time), NULL); | ||
479 | + panel_return_val_if_fail (XFCE_IS_CLOCK_TIME (clock_time), NULL); | ||
480 | |||
481 | - if (time->timezone != NULL) | ||
482 | - date_time = g_date_time_new_now (time->timezone); | ||
483 | + if (clock_time->timezone != NULL) | ||
484 | + date_time = g_date_time_new_now (clock_time->timezone); | ||
485 | else | ||
486 | date_time = g_date_time_new_now_local (); | ||
487 | |||
488 | @@ -209,15 +209,15 @@ clock_time_get_time (ClockTime *time) | ||
489 | |||
490 | |||
491 | gchar * | ||
492 | -clock_time_strdup_strftime (ClockTime *time, | ||
493 | +clock_time_strdup_strftime (ClockTime *clock_time, | ||
494 | const gchar *format) | ||
495 | { | ||
496 | GDateTime *date_time; | ||
497 | gchar *str; | ||
498 | |||
499 | - panel_return_val_if_fail (XFCE_IS_CLOCK_TIME (time), NULL); | ||
500 | + panel_return_val_if_fail (XFCE_IS_CLOCK_TIME (clock_time), NULL); | ||
501 | |||
502 | - date_time = clock_time_get_time (time); | ||
503 | + date_time = clock_time_get_time (clock_time); | ||
504 | str = g_date_time_format (date_time, format); | ||
505 | |||
506 | g_date_time_unref (date_time); | ||
507 | @@ -262,7 +262,7 @@ static gboolean | ||
508 | clock_time_timeout_running (gpointer user_data) | ||
509 | { | ||
510 | ClockTimeTimeout *timeout = user_data; | ||
511 | - GDateTime *time; | ||
512 | + GDateTime *date_time; | ||
513 | |||
514 | g_signal_emit (G_OBJECT (timeout->time), clock_time_signals[TIME_CHANGED], 0); | ||
515 | |||
516 | @@ -270,8 +270,8 @@ clock_time_timeout_running (gpointer user_data) | ||
517 | if (timeout->interval == CLOCK_INTERVAL_MINUTE) | ||
518 | { | ||
519 | /* sync again when we don't run on time */ | ||
520 | - time = clock_time_get_time (timeout->time); | ||
521 | - timeout->restart = (g_date_time_get_second (time) != 0); | ||
522 | + date_time = clock_time_get_time (timeout->time); | ||
523 | + timeout->restart = (g_date_time_get_second (date_time) != 0); | ||
524 | } | ||
525 | |||
526 | return !timeout->restart; | ||
527 | @@ -312,13 +312,13 @@ clock_time_timeout_sync (gpointer user_data) | ||
528 | |||
529 | ClockTimeTimeout * | ||
530 | clock_time_timeout_new (guint interval, | ||
531 | - ClockTime *time, | ||
532 | + ClockTime *clock_time, | ||
533 | GCallback c_handler, | ||
534 | gpointer gobject) | ||
535 | { | ||
536 | ClockTimeTimeout *timeout; | ||
537 | |||
538 | - panel_return_val_if_fail (XFCE_IS_CLOCK_TIME (time), NULL); | ||
539 | + panel_return_val_if_fail (XFCE_IS_CLOCK_TIME (clock_time), NULL); | ||
540 | |||
541 | panel_return_val_if_fail (interval > 0, NULL); | ||
542 | |||
543 | @@ -326,10 +326,10 @@ clock_time_timeout_new (guint interval, | ||
544 | timeout->interval = 0; | ||
545 | timeout->timeout_id = 0; | ||
546 | timeout->restart = FALSE; | ||
547 | - timeout->time = time; | ||
548 | + timeout->time = clock_time; | ||
549 | |||
550 | timeout->time_changed_id = | ||
551 | - g_signal_connect_swapped (G_OBJECT (time), "time-changed", | ||
552 | + g_signal_connect_swapped (G_OBJECT (clock_time), "time-changed", | ||
553 | c_handler, gobject); | ||
554 | |||
555 | g_object_ref (G_OBJECT (timeout->time)); | ||
556 | @@ -345,7 +345,7 @@ void | ||
557 | clock_time_timeout_set_interval (ClockTimeTimeout *timeout, | ||
558 | guint interval) | ||
559 | { | ||
560 | - GDateTime *time; | ||
561 | + GDateTime *date_time; | ||
562 | guint next_interval; | ||
563 | gboolean restart; | ||
564 | |||
565 | @@ -372,8 +372,8 @@ clock_time_timeout_set_interval (ClockTimeTimeout *timeout, | ||
566 | /* get the seconds to the next internal */ | ||
567 | if (interval == CLOCK_INTERVAL_MINUTE) | ||
568 | { | ||
569 | - time = clock_time_get_time (timeout->time); | ||
570 | - next_interval = 60 - g_date_time_get_second (time); | ||
571 | + date_time = clock_time_get_time (timeout->time); | ||
572 | + next_interval = 60 - g_date_time_get_second (date_time); | ||
573 | } | ||
574 | else | ||
575 | { | ||
576 | diff --git a/plugins/clock/clock.c b/plugins/clock/clock.c | ||
577 | index 6c80978..e07c17b 100644 | ||
578 | --- a/plugins/clock/clock.c | ||
579 | +++ b/plugins/clock/clock.c | ||
580 | @@ -1113,17 +1113,17 @@ static void | ||
581 | clock_plugin_calendar_show_event (GtkWidget *calendar_window, | ||
582 | ClockPlugin *plugin) | ||
583 | { | ||
584 | - GDateTime *time; | ||
585 | + GDateTime *date_time; | ||
586 | |||
587 | panel_return_if_fail (XFCE_IS_PANEL_PLUGIN (plugin)); | ||
588 | |||
589 | clock_plugin_reposition_calendar (plugin); | ||
590 | |||
591 | - time = clock_time_get_time (plugin->time); | ||
592 | - gtk_calendar_select_month (GTK_CALENDAR (plugin->calendar), g_date_time_get_month (time) - 1, | ||
593 | - g_date_time_get_year (time)); | ||
594 | - gtk_calendar_select_day (GTK_CALENDAR (plugin->calendar), g_date_time_get_day_of_month (time)); | ||
595 | - g_date_time_unref (time); | ||
596 | + date_time = clock_time_get_time (plugin->time); | ||
597 | + gtk_calendar_select_month (GTK_CALENDAR (plugin->calendar), g_date_time_get_month (date_time) - 1, | ||
598 | + g_date_time_get_year (date_time)); | ||
599 | + gtk_calendar_select_day (GTK_CALENDAR (plugin->calendar), g_date_time_get_day_of_month (date_time)); | ||
600 | + g_date_time_unref (date_time); | ||
601 | } | ||
602 | |||
603 | |||
604 | -- | ||
605 | 2.5.0 | ||
606 | |||
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/files/0002-clock-time-make-change-of-system-s-timezone-change-t.patch b/meta-xfce/recipes-xfce/xfce4-panel/files/0001-clock-time-make-change-of-system-s-timezone-change-t.patch index 9dca3ba57..9dca3ba57 100644 --- a/meta-xfce/recipes-xfce/xfce4-panel/files/0002-clock-time-make-change-of-system-s-timezone-change-t.patch +++ b/meta-xfce/recipes-xfce/xfce4-panel/files/0001-clock-time-make-change-of-system-s-timezone-change-t.patch | |||
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/files/0003-windowmenu-do-not-display-desktop-icon-when-no-windo.patch b/meta-xfce/recipes-xfce/xfce4-panel/files/0002-windowmenu-do-not-display-desktop-icon-when-no-windo.patch index b2d960c00..b2d960c00 100644 --- a/meta-xfce/recipes-xfce/xfce4-panel/files/0003-windowmenu-do-not-display-desktop-icon-when-no-windo.patch +++ b/meta-xfce/recipes-xfce/xfce4-panel/files/0002-windowmenu-do-not-display-desktop-icon-when-no-windo.patch | |||
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.12.0.bb b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.12.1.bb index 4148d9af4..8cbd76b6f 100644 --- a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.12.0.bb +++ b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.12.1.bb | |||
@@ -6,12 +6,11 @@ DEPENDS = "libxfce4util garcon libxfce4ui xfconf exo gtk+ gtk+3 dbus cairo virtu | |||
6 | 6 | ||
7 | inherit xfce gtk-doc | 7 | inherit xfce gtk-doc |
8 | 8 | ||
9 | SRC_URI[md5sum] = "5a333af704e386c90ad829b6baf1a758" | 9 | SRC_URI[md5sum] = "0b943f2e72a3693dddb1af559826cb62" |
10 | SRC_URI[sha256sum] = "30920fc2e2fc26279a82b5261a155c2cc15ab2aa1ced2275684a6ff8261b97b0" | 10 | SRC_URI[sha256sum] = "93d58b80cca9c9eb58adb281bc75404df7cf6cae89f7f98bb9f38690009aa2e8" |
11 | SRC_URI += " \ | 11 | SRC_URI += " \ |
12 | file://0001-Fix-compiler-warning-in-clock-plugin-about-shadowed-.patch \ | 12 | file://0001-clock-time-make-change-of-system-s-timezone-change-t.patch \ |
13 | file://0002-clock-time-make-change-of-system-s-timezone-change-t.patch \ | 13 | file://0002-windowmenu-do-not-display-desktop-icon-when-no-windo.patch \ |
14 | file://0003-windowmenu-do-not-display-desktop-icon-when-no-windo.patch \ | ||
15 | " | 14 | " |
16 | 15 | ||
17 | EXTRA_OECONF += "--enable-gtk3" | 16 | EXTRA_OECONF += "--enable-gtk3" |