diff options
author | Khem Raj <raj.khem@gmail.com> | 2016-08-14 22:04:34 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-08-22 15:49:23 +0200 |
commit | 9e78e4b521460cd80a1dea4f0d14865a8e06eecd (patch) | |
tree | 2683a28325786c1887f91577003877eb0a1b7e9b /meta-xfce | |
parent | b415e2a372b555a3264359345e6aa52c10c9e1d7 (diff) | |
download | meta-openembedded-9e78e4b521460cd80a1dea4f0d14865a8e06eecd.tar.gz |
thunar-volman: Fix build with clang
clang poins a void return for a boolean function
| ../../thunar-volman-0.8.1/thunar-volman/tvm-block-device.c:717:3: error: non-void function 'tvm_block_device_mount' should return a value [-Wreturn-type]
| g_return_if_fail (context != NULL);
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r-- | meta-xfce/recipes-xfce/thunar-volman/thunar-volman/0001-Fix-return-with-no-value-in-function-returning-non-v.patch | 26 | ||||
-rw-r--r-- | meta-xfce/recipes-xfce/thunar-volman/thunar-volman_0.8.1.bb | 1 |
2 files changed, 27 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/thunar-volman/thunar-volman/0001-Fix-return-with-no-value-in-function-returning-non-v.patch b/meta-xfce/recipes-xfce/thunar-volman/thunar-volman/0001-Fix-return-with-no-value-in-function-returning-non-v.patch new file mode 100644 index 000000000..7233ea7ba --- /dev/null +++ b/meta-xfce/recipes-xfce/thunar-volman/thunar-volman/0001-Fix-return-with-no-value-in-function-returning-non-v.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | From 2e295e9ce8f7f60a271adf004588b0d8db88db09 Mon Sep 17 00:00:00 2001 | ||
2 | From: Matt Thirtytwo <matt.59491@gmail.com> | ||
3 | Date: Sat, 7 Mar 2015 22:50:32 +0100 | ||
4 | Subject: [PATCH] Fix return with no value in function returning non-void (bug | ||
5 | #11656) | ||
6 | |||
7 | --- | ||
8 | thunar-volman/tvm-block-device.c | 2 +- | ||
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/thunar-volman/tvm-block-device.c b/thunar-volman/tvm-block-device.c | ||
12 | index da31efa..edb6cad 100644 | ||
13 | --- a/thunar-volman/tvm-block-device.c | ||
14 | +++ b/thunar-volman/tvm-block-device.c | ||
15 | @@ -714,7 +714,7 @@ tvm_block_device_mount (TvmContext *context) | ||
16 | GMountOperation *mount_operation; | ||
17 | GVolume *volume; | ||
18 | |||
19 | - g_return_if_fail (context != NULL); | ||
20 | + g_return_val_if_fail ((context != NULL), FALSE); | ||
21 | |||
22 | /* determine the GVolume corresponding to the udev device */ | ||
23 | volume = | ||
24 | -- | ||
25 | 1.9.0 | ||
26 | |||
diff --git a/meta-xfce/recipes-xfce/thunar-volman/thunar-volman_0.8.1.bb b/meta-xfce/recipes-xfce/thunar-volman/thunar-volman_0.8.1.bb index 08e6f5be2..44e3777fa 100644 --- a/meta-xfce/recipes-xfce/thunar-volman/thunar-volman_0.8.1.bb +++ b/meta-xfce/recipes-xfce/thunar-volman/thunar-volman_0.8.1.bb | |||
@@ -6,6 +6,7 @@ DEPENDS = "exo glib-2.0 gtk+ libxfce4ui libxfce4util xfconf libnotify libgudev" | |||
6 | 6 | ||
7 | inherit xfce | 7 | inherit xfce |
8 | 8 | ||
9 | SRC_URI += "file://0001-Fix-return-with-no-value-in-function-returning-non-v.patch" | ||
9 | SRC_URI[md5sum] = "65ab6e05b2e808d1dcc8d36683a59b7e" | 10 | SRC_URI[md5sum] = "65ab6e05b2e808d1dcc8d36683a59b7e" |
10 | SRC_URI[sha256sum] = "5a08bb5ce32c296a64dfbdb2406d4e45a208b2c91e4efa831dc28f1d6c2ac2bd" | 11 | SRC_URI[sha256sum] = "5a08bb5ce32c296a64dfbdb2406d4e45a208b2c91e4efa831dc28f1d6c2ac2bd" |
11 | 12 | ||