diff options
author | Andreas Müller <schnitzeltony@googlemail.com> | 2013-04-02 22:00:16 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-04 08:14:22 +0200 |
commit | 3c1619bc5a6dc42acca4a89db9f162b5505cedb8 (patch) | |
tree | b7096ec7c262629a69e25c36357d17974e54facb /meta-xfce | |
parent | 7ea47c2cfac97a4e2df7631b4517af33557980e8 (diff) | |
download | meta-openembedded-3c1619bc5a6dc42acca4a89db9f162b5505cedb8.tar.gz |
exo: add native build
The native build creates exo-csource only. exo-csource converts glade-files
into c-header files. When building xfce projects from git repo, exo-csource is
required (tarballs have the glade-headers included).
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r-- | meta-xfce/recipes-xfce/exo/exo/reduce-build-to-exo-csource-only.patch | 80 | ||||
-rw-r--r-- | meta-xfce/recipes-xfce/exo/exo_0.10.2.bb | 9 |
2 files changed, 88 insertions, 1 deletions
diff --git a/meta-xfce/recipes-xfce/exo/exo/reduce-build-to-exo-csource-only.patch b/meta-xfce/recipes-xfce/exo/exo/reduce-build-to-exo-csource-only.patch new file mode 100644 index 000000000..84b237096 --- /dev/null +++ b/meta-xfce/recipes-xfce/exo/exo/reduce-build-to-exo-csource-only.patch | |||
@@ -0,0 +1,80 @@ | |||
1 | From e710d8d4a3e3480416826c70d56ea3d2598a77e4 Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com> | ||
3 | Date: Thu, 28 Mar 2013 23:41:03 +0100 | ||
4 | Subject: [PATCH] reduce build to exo-csource only | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | exo-csource creates c-header files from glade resource output files. When | ||
10 | building xfce-packages from git instead of tarball this exo-csource-native is | ||
11 | required. | ||
12 | |||
13 | Upstream-Status: Inappropriate [configuration] | ||
14 | |||
15 | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> | ||
16 | --- | ||
17 | Makefile.am | 10 +--------- | ||
18 | configure.ac | 20 -------------------- | ||
19 | 2 files changed, 1 insertions(+), 29 deletions(-) | ||
20 | |||
21 | diff --git a/Makefile.am b/Makefile.am | ||
22 | index c2e3fff..79b0931 100644 | ||
23 | --- a/Makefile.am | ||
24 | +++ b/Makefile.am | ||
25 | @@ -1,13 +1,5 @@ | ||
26 | SUBDIRS = \ | ||
27 | - exo \ | ||
28 | - exo-csource \ | ||
29 | - exo-desktop-item-edit \ | ||
30 | - exo-helper \ | ||
31 | - exo-open \ | ||
32 | - docs \ | ||
33 | - icons \ | ||
34 | - pixmaps \ | ||
35 | - po | ||
36 | + exo-csource | ||
37 | |||
38 | AUTOMAKE_OPTIONS = \ | ||
39 | 1.9 \ | ||
40 | diff --git a/configure.ac b/configure.ac | ||
41 | index efcd62e..aac2495 100644 | ||
42 | --- a/configure.ac | ||
43 | +++ b/configure.ac | ||
44 | @@ -110,15 +110,6 @@ AC_PROG_CC() | ||
45 | AM_PROG_CC_C_O() | ||
46 | AC_PROG_INSTALL() | ||
47 | AC_PROG_INTLTOOL([0.31], [no-xml]) | ||
48 | -AC_CHECK_PROGS([PERL], [perl5 perl]) | ||
49 | - | ||
50 | -dnl *************************************** | ||
51 | -dnl *** Check for required Perl modules *** | ||
52 | -dnl *************************************** | ||
53 | -AC_PROG_PERL_MODULES([URI::Escape URI::file URI::URL], [], | ||
54 | -[ | ||
55 | - AC_MSG_ERROR([Atleast one of the required Perl modules (URI::Escape, URI::file and URI::URL) was not found on your system]) | ||
56 | -]) | ||
57 | |||
58 | dnl *************************************** | ||
59 | dnl *** Check for standard header files *** | ||
60 | @@ -165,17 +156,6 @@ dnl *********************************** | ||
61 | dnl *** Check for required packages *** | ||
62 | dnl *********************************** | ||
63 | XDT_CHECK_PACKAGE([GLIB], [glib-2.0], [2.30.0]) | ||
64 | -XDT_CHECK_PACKAGE([GIO], [gio-2.0], [2.30.0]) | ||
65 | -XDT_CHECK_PACKAGE([GTK], [gtk+-2.0], [2.24.0]) | ||
66 | -XDT_CHECK_PACKAGE([GTHREAD], [gthread-2.0], [2.30.0]) | ||
67 | -XDT_CHECK_PACKAGE([LIBXFCE4UTIL], [libxfce4util-1.0], [4.10.0]) | ||
68 | -XDT_CHECK_PACKAGE([LIBXFCE4UI], [libxfce4ui-1], [4.10.0]) | ||
69 | -XDT_CHECK_OPTIONAL_PACKAGE([GIO_UNIX], [gio-unix-2.0], [2.30.0], [gio-unix], [GIO-Unix features]) | ||
70 | - | ||
71 | -dnl ********************* | ||
72 | -dnl *** Check for X11 *** | ||
73 | -dnl ********************* | ||
74 | -XDT_CHECK_LIBX11_REQUIRE() | ||
75 | |||
76 | dnl ************************* | ||
77 | dnl *** Check for gtk-doc *** | ||
78 | -- | ||
79 | 1.7.4.4 | ||
80 | |||
diff --git a/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb b/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb index 6aa105649..f16d5444c 100644 --- a/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb +++ b/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb | |||
@@ -3,7 +3,8 @@ SECTION = "x11" | |||
3 | LICENSE = "GPLv2" | 3 | LICENSE = "GPLv2" |
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
5 | DEPENDS = "gtk+ libxfce4util libxfce4ui virtual/libx11 liburi-perl-native cairo" | 5 | DEPENDS = "gtk+ libxfce4util libxfce4ui virtual/libx11 liburi-perl-native cairo" |
6 | PR = "r1" | 6 | DEPENDS_class-native = "glib-2.0-native xfce4-dev-tools-native" |
7 | PR = "r2" | ||
7 | 8 | ||
8 | inherit xfce pythonnative perlnative | 9 | inherit xfce pythonnative perlnative |
9 | 10 | ||
@@ -14,6 +15,10 @@ SRC_URI += " \ | |||
14 | file://gnome-mount \ | 15 | file://gnome-mount \ |
15 | " | 16 | " |
16 | 17 | ||
18 | SRC_URI_append_class-native = " \ | ||
19 | file://reduce-build-to-exo-csource-only.patch \ | ||
20 | " | ||
21 | |||
17 | SRC_URI[md5sum] = "c70f2a217811bfba2e62f938d4b8f748" | 22 | SRC_URI[md5sum] = "c70f2a217811bfba2e62f938d4b8f748" |
18 | SRC_URI[sha256sum] = "b385828bf8a38204da3254b57fdfa25a72694495aa189fabd5040f707eec76ce" | 23 | SRC_URI[sha256sum] = "b385828bf8a38204da3254b57fdfa25a72694495aa189fabd5040f707eec76ce" |
19 | 24 | ||
@@ -31,3 +36,5 @@ FILES_${PN} += "${datadir}/xfce4/ \ | |||
31 | 36 | ||
32 | FILES_${PN}-dbg += "${libdir}/gio/modules/.debug \ | 37 | FILES_${PN}-dbg += "${libdir}/gio/modules/.debug \ |
33 | " | 38 | " |
39 | |||
40 | BBCLASSEXTEND = "native" | ||