summaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorHuang Qiyu <huangqy.fnst@cn.fujitsu.com>2018-02-09 13:11:07 +0800
committerArmin Kuster <akuster808@gmail.com>2018-02-23 20:26:00 -0800
commit1983042322dec3d360165912896a98e3472b3d43 (patch)
treea564729a21b1d9f290934977179e93d94ac55c4d /meta-xfce
parent6dac7ec530281521e9047d3bf0b202a876f42b55 (diff)
downloadmeta-openembedded-1983042322dec3d360165912896a98e3472b3d43.tar.gz
imsettings: 1.7.2 -> 1.7.3
1.Upgrade imsettings from 1.7.2 to 1.7.3. 2.Delete 0001-Rename-use-of-stdout-and-stderr.patch, gtk-is-required-by-notify.patch, multi-line-ACLOCAL_AMFLAGS-isnot-supported-by-autoreconf.patch, since it is integrated upstream. Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-extended/imsettings/imsettings/0001-Rename-use-of-stdout-and-stderr.patch72
-rw-r--r--meta-xfce/recipes-extended/imsettings/imsettings/gtk-is-required-by-notify.patch18
-rw-r--r--meta-xfce/recipes-extended/imsettings/imsettings/multi-line-ACLOCAL_AMFLAGS-isnot-supported-by-autoreconf.patch19
-rw-r--r--meta-xfce/recipes-extended/imsettings/imsettings_1.7.3.bb (renamed from meta-xfce/recipes-extended/imsettings/imsettings_1.7.2.bb)7
4 files changed, 2 insertions, 114 deletions
diff --git a/meta-xfce/recipes-extended/imsettings/imsettings/0001-Rename-use-of-stdout-and-stderr.patch b/meta-xfce/recipes-extended/imsettings/imsettings/0001-Rename-use-of-stdout-and-stderr.patch
deleted file mode 100644
index d77ce4d25..000000000
--- a/meta-xfce/recipes-extended/imsettings/imsettings/0001-Rename-use-of-stdout-and-stderr.patch
+++ /dev/null
@@ -1,72 +0,0 @@
1From 7ee62ef0083844ab2fffcd106e3ee2e5f29b2a91 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 12 Jul 2017 18:53:56 -0700
4Subject: [PATCH] Rename use of stdout and stderr
5
6Since it shadow the standard definitions especially
7seen on musl where libc defines these as macros they
8cause all short of compilation errors on musl, using
9a leading underscore makes it unique
10
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 imsettings-daemon/imsettings-proc.c | 28 ++++++++++++++--------------
14 1 file changed, 14 insertions(+), 14 deletions(-)
15
16diff --git a/imsettings-daemon/imsettings-proc.c b/imsettings-daemon/imsettings-proc.c
17index 915e78b..b78fcff 100644
18--- a/imsettings-daemon/imsettings-proc.c
19+++ b/imsettings-daemon/imsettings-proc.c
20@@ -39,8 +39,8 @@
21 #define MAXRESTART 3
22
23 typedef struct _IMSettingsProcInfo {
24- GIOChannel *stdout;
25- GIOChannel *stderr;
26+ GIOChannel *_stdout;
27+ GIOChannel *_stderr;
28 GPid pid;
29 GTimeVal started_time;
30 guint id;
31@@ -368,12 +368,12 @@ _start_process(IMSettingsProc *proc,
32 &ofd, &efd,
33 error)) {
34 pinfo->pid = pid;
35- pinfo->stdout = g_io_channel_unix_new(ofd);
36- pinfo->stderr = g_io_channel_unix_new(efd);
37- g_io_channel_set_close_on_unref(pinfo->stdout, TRUE);
38- g_io_channel_set_close_on_unref(pinfo->stderr, TRUE);
39- pinfo->oid = g_io_add_watch(pinfo->stdout, G_IO_IN, _log_write_cb, proc);
40- pinfo->eid = g_io_add_watch(pinfo->stderr, G_IO_IN, _log_write_cb, proc);
41+ pinfo->_stdout = g_io_channel_unix_new(ofd);
42+ pinfo->_stderr = g_io_channel_unix_new(efd);
43+ g_io_channel_set_close_on_unref(pinfo->_stdout, TRUE);
44+ g_io_channel_set_close_on_unref(pinfo->_stderr, TRUE);
45+ pinfo->oid = g_io_add_watch(pinfo->_stdout, G_IO_IN, _log_write_cb, proc);
46+ pinfo->eid = g_io_add_watch(pinfo->_stderr, G_IO_IN, _log_write_cb, proc);
47 g_get_current_time(&pinfo->started_time);
48 pinfo->id = g_child_watch_add(pid, _watch_im_status_cb, proc);
49
50@@ -521,13 +521,13 @@ imsettings_proc_get_property(GObject *object,
51 static void
52 imsettings_proc_info_finalize(IMSettingsProcInfo *pinfo)
53 {
54- if (pinfo->stdout) {
55- g_io_channel_unref(pinfo->stdout);
56- pinfo->stdout = NULL;
57+ if (pinfo->_stdout) {
58+ g_io_channel_unref(pinfo->_stdout);
59+ pinfo->_stdout = NULL;
60 }
61- if (pinfo->stderr) {
62- g_io_channel_unref(pinfo->stderr);
63- pinfo->stderr = NULL;
64+ if (pinfo->_stderr) {
65+ g_io_channel_unref(pinfo->_stderr);
66+ pinfo->_stderr = NULL;
67 }
68 if (pinfo->oid > 0) {
69 g_source_remove(pinfo->oid);
70--
712.13.2
72
diff --git a/meta-xfce/recipes-extended/imsettings/imsettings/gtk-is-required-by-notify.patch b/meta-xfce/recipes-extended/imsettings/imsettings/gtk-is-required-by-notify.patch
deleted file mode 100644
index d42358d69..000000000
--- a/meta-xfce/recipes-extended/imsettings/imsettings/gtk-is-required-by-notify.patch
+++ /dev/null
@@ -1,18 +0,0 @@
1gtk+ is required by linnotify. So make sure gtk be linked before libnotify
2
3Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com>
4
5diff -Nurp imsettings-1.6.7.orig/configure.ac imsettings-1.6.7/configure.ac
6--- imsettings-1.6.7.orig/configure.ac 2013-11-26 16:09:09.000000000 +0800
7+++ imsettings-1.6.7/configure.ac 2014-12-30 11:27:44.370003209 +0800
8@@ -93,8 +93,8 @@ PKG_CHECK_MODULES(LIBNOTIFY, libnotify,
9 has_old_libnotify=yes
10 PKG_CHECK_MODULES(GTK, gtk+-2.0 >= $GTK_REQUIRED)
11 AC_DEFINE(HAS_OLD_LIBNOTIFY,, [Using older libnotify])
12- IMDAEMON_CFLAGS="$GTK_CFLAGS $LIBNOTIFY_OLD_CFLAGS"
13- IMDAEMON_LIBS="$GTK_LIBS $LIBNOTIFY_OLD_LIBS"],[
14+ IMDAEMON_CFLAGS="$LIBNOTIFY_OLD_CFLAGS $GTK_CFLAGS"
15+ IMDAEMON_LIBS="$LIBNOTIFY_OLD_LIBS $GTK_LIBS"],[
16 has_old_libnotify=no
17 IMDAEMON_CFLAGS="$LIBNOTIFY_CFLAGS"
18 IMDAEMON_LIBS="$LIBNOTIFY_LIBS"])
diff --git a/meta-xfce/recipes-extended/imsettings/imsettings/multi-line-ACLOCAL_AMFLAGS-isnot-supported-by-autoreconf.patch b/meta-xfce/recipes-extended/imsettings/imsettings/multi-line-ACLOCAL_AMFLAGS-isnot-supported-by-autoreconf.patch
deleted file mode 100644
index d5ac87dc0..000000000
--- a/meta-xfce/recipes-extended/imsettings/imsettings/multi-line-ACLOCAL_AMFLAGS-isnot-supported-by-autoreconf.patch
+++ /dev/null
@@ -1,19 +0,0 @@
1multi-line ACLOCAL_AMFLAGS isn't supported by autoreconf.
2It will cause configure error as follow.
3
4 aclocal: error: non-option arguments are not accepted: '\'.
5
6Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com>
7
8diff -Nurp imsettings-1.7.1.orig/Makefile.am imsettings-1.7.1/Makefile.am
9--- imsettings-1.7.1.orig/Makefile.am 2013-02-08 11:33:59.000000000 +0900
10+++ imsettings-1.7.1/Makefile.am 2015-06-24 14:15:32.070000007 +0900
11@@ -1,7 +1,7 @@
12 NULL =
13 SUBDIRS = data imsettings imsettings-daemon backends utils po tests docs
14
15-ACLOCAL_AMFLAGS = -Im4macros
16+ACLOCAL_AMFLAGS = -I m4macros $(NULL)
17
18 CONFIGURE_DEPENDENCIES = \
19 requires \
diff --git a/meta-xfce/recipes-extended/imsettings/imsettings_1.7.2.bb b/meta-xfce/recipes-extended/imsettings/imsettings_1.7.3.bb
index 7a4ce05bf..c00b1936e 100644
--- a/meta-xfce/recipes-extended/imsettings/imsettings_1.7.2.bb
+++ b/meta-xfce/recipes-extended/imsettings/imsettings_1.7.3.bb
@@ -10,13 +10,10 @@ SECTION = "Applications/System"
10inherit autotools gtk-doc gobject-introspection 10inherit autotools gtk-doc gobject-introspection
11 11
12SRC_URI = "https://bitbucket.org/tagoh/imsettings/downloads/${BPN}-${PV}.tar.bz2 \ 12SRC_URI = "https://bitbucket.org/tagoh/imsettings/downloads/${BPN}-${PV}.tar.bz2 \
13 file://gtk-is-required-by-notify.patch \
14 file://multi-line-ACLOCAL_AMFLAGS-isnot-supported-by-autoreconf.patch \
15 file://0001-Rename-use-of-stdout-and-stderr.patch \
16 " 13 "
17 14
18SRC_URI[md5sum] = "8153b0583a9f47d8a62af1f92fb9d3bf" 15SRC_URI[md5sum] = "c6c65a2b2654fe9dfe9ab2e8b80c079a"
19SRC_URI[sha256sum] = "41addf0458f760212b6b6100835066e16deb3a8a50eb005a0fc17fbac0a2ae66" 16SRC_URI[sha256sum] = "196d3a74cef254ff812c32682d1818d740e36a68b976fef9e99748d23a71a71a"
20 17
21LICENSE = "LGPLv2+" 18LICENSE = "LGPLv2+"
22LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1" 19LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"