summaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-03-22 15:14:12 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-05 19:26:12 +0200
commitb1b626c1650309bb5e1c9ed67681d7f0dc268d46 (patch)
treeefaaa34bf42487ded646a11b24c99b4ddcff2b23 /meta-xfce
parent56c233bb2c22aedb5e1a6e0fb7997e8a9d8ce2a1 (diff)
downloadmeta-openembedded-b1b626c1650309bb5e1c9ed67681d7f0dc268d46.tar.gz
xfce4-closebutton-plugin: Fix build with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-panel-plugins/closebutton/xfce4-closebutton-plugin/0001-Use-g_return_val_if_fail-in-functions-expecting-a-re.patch62
-rw-r--r--meta-xfce/recipes-panel-plugins/closebutton/xfce4-closebutton-plugin_git.bb4
2 files changed, 65 insertions, 1 deletions
diff --git a/meta-xfce/recipes-panel-plugins/closebutton/xfce4-closebutton-plugin/0001-Use-g_return_val_if_fail-in-functions-expecting-a-re.patch b/meta-xfce/recipes-panel-plugins/closebutton/xfce4-closebutton-plugin/0001-Use-g_return_val_if_fail-in-functions-expecting-a-re.patch
new file mode 100644
index 000000000..2e824ec0d
--- /dev/null
+++ b/meta-xfce/recipes-panel-plugins/closebutton/xfce4-closebutton-plugin/0001-Use-g_return_val_if_fail-in-functions-expecting-a-re.patch
@@ -0,0 +1,62 @@
1From b0bda2dfc2d8d7bb244e59897b5bf0776f4fe44c Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 22 Mar 2017 15:07:26 -0700
4Subject: [PATCH] Use g_return_val_if_fail() in functions expecting a return
5 value
6
7Clang detects that we are not returning any value when function
8expects it.
9
10Fixes
11
12| ../../git/panel-plugin/closebutton.c:170:3: error: non-void function 'closebutton_plugin_set_icon' should return a value [-Wreturn-type]
13| g_return_if_fail (XFCE_IS_PANEL_IMAGE (icon));
14
15Signed-off-by: Khem Raj <raj.khem@gmail.com>
16---
17Upstream-Status: Pending
18
19 panel-plugin/closebutton-settings.c | 2 +-
20 panel-plugin/closebutton.c | 6 +++---
21 2 files changed, 4 insertions(+), 4 deletions(-)
22
23diff --git a/panel-plugin/closebutton-settings.c b/panel-plugin/closebutton-settings.c
24index f2fa370..d4e6b0c 100644
25--- a/panel-plugin/closebutton-settings.c
26+++ b/panel-plugin/closebutton-settings.c
27@@ -60,7 +60,7 @@ closebutton_builder_new (XfcePanelPlugin *panel_plugin,
28 GtkBuilder *builder;
29 GObject *dialog, *button;
30
31- g_return_if_fail (XFCE_IS_PANEL_PLUGIN (panel_plugin));
32+ g_return_val_if_fail (XFCE_IS_PANEL_PLUGIN (panel_plugin), 0);
33
34 builder = gtk_builder_new ();
35 if (gtk_builder_add_from_string (builder, buffer, length, &error))
36diff --git a/panel-plugin/closebutton.c b/panel-plugin/closebutton.c
37index fd0a7b5..2120728 100644
38--- a/panel-plugin/closebutton.c
39+++ b/panel-plugin/closebutton.c
40@@ -167,8 +167,8 @@ closebutton_plugin_set_icon (CloseButtonPlugin *plugin, gboolean force_reload)
41 XfcePanelPlugin *panel_plugin = XFCE_PANEL_PLUGIN (plugin);
42 XfcePanelImage *icon = XFCE_PANEL_IMAGE (plugin->icon);
43
44- g_return_if_fail (XFCE_IS_PANEL_IMAGE (icon));
45- g_return_if_fail (XFCE_IS_CLOSEBUTTON_PLUGIN (plugin));
46+ g_return_val_if_fail (XFCE_IS_PANEL_IMAGE (icon), 0);
47+ g_return_val_if_fail (XFCE_IS_CLOSEBUTTON_PLUGIN (plugin), 0);
48
49 window = closebutton_plugin_get_effective_window (plugin);
50 if (window != NULL)
51@@ -404,7 +404,7 @@ closebutton_plugin_size_changed (XfcePanelPlugin *panel_plugin,
52 gint size)
53 {
54 CloseButtonPlugin *plugin = XFCE_CLOSEBUTTON_PLUGIN (panel_plugin);
55- g_return_if_fail (XFCE_IS_CLOSEBUTTON_PLUGIN (plugin));
56+ g_return_val_if_fail (XFCE_IS_CLOSEBUTTON_PLUGIN (plugin), 0);
57
58 #if LIBXFCE4PANEL_CHECK_VERSION(4,9,0)
59 size /= xfce_panel_plugin_get_nrows (panel_plugin);
60--
612.12.0
62
diff --git a/meta-xfce/recipes-panel-plugins/closebutton/xfce4-closebutton-plugin_git.bb b/meta-xfce/recipes-panel-plugins/closebutton/xfce4-closebutton-plugin_git.bb
index 341107fa1..746b1222a 100644
--- a/meta-xfce/recipes-panel-plugins/closebutton/xfce4-closebutton-plugin_git.bb
+++ b/meta-xfce/recipes-panel-plugins/closebutton/xfce4-closebutton-plugin_git.bb
@@ -9,7 +9,9 @@ DEPENDS += "exo-native libwnck xfconf"
9 9
10PV = "0.1.0+gitr${SRCPV}" 10PV = "0.1.0+gitr${SRCPV}"
11 11
12SRC_URI = "git://github.com/schnitzeltony/xfce4-closebutton-plugin.git;branch=master" 12SRC_URI = "git://github.com/schnitzeltony/xfce4-closebutton-plugin.git;branch=master \
13 file://0001-Use-g_return_val_if_fail-in-functions-expecting-a-re.patch \
14 "
13SRCREV = "bd76154afe26ba8a5251a1887d88f9d855301850" 15SRCREV = "bd76154afe26ba8a5251a1887d88f9d855301850"
14S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
15 17