summaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2017-04-12 17:50:59 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-18 14:21:52 +0200
commit6dc31ce48b712950f74a06708dd73da2cf38fe45 (patch)
tree1bed8ac4876698fab408ae229c534ebab2b37891 /meta-xfce
parent33b05cc85b89c2982d7ef81d0b349ef522bda2de (diff)
downloadmeta-openembedded-6dc31ce48b712950f74a06708dd73da2cf38fe45.tar.gz
xarchiver: Upstream printf-fix-patch
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-apps/xarchiver/xarchiver/0001-Add-proper-formatting-string-to-printf-like-function.patch40
-rw-r--r--meta-xfce/recipes-apps/xarchiver/xarchiver_git.bb6
2 files changed, 2 insertions, 44 deletions
diff --git a/meta-xfce/recipes-apps/xarchiver/xarchiver/0001-Add-proper-formatting-string-to-printf-like-function.patch b/meta-xfce/recipes-apps/xarchiver/xarchiver/0001-Add-proper-formatting-string-to-printf-like-function.patch
deleted file mode 100644
index a1158831a..000000000
--- a/meta-xfce/recipes-apps/xarchiver/xarchiver/0001-Add-proper-formatting-string-to-printf-like-function.patch
+++ /dev/null
@@ -1,40 +0,0 @@
1From baf93ea9acf845c5455d577ac19a6f680dac3d2d Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 30 Mar 2017 11:22:42 -0700
4Subject: [PATCH] Add proper formatting string to printf-like functions
5
6Avoids potential security holes and makes compiler happy
7
8| ../../../../../../../workspace/sources/xarchiver/src/window.c:236:72: error: format string is not a string literal (potentially insecure) [-Werror,-Wformat-security]
9| gtk_message_dialog_format_secondary_text (GTK_MESSAGE_DIALOG (dialog),message2);
10
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 src/window.c | 6 +++---
14 1 file changed, 3 insertions(+), 3 deletions(-)
15
16Index: git/src/window.c
17===================================================================
18--- git.orig/src/window.c
19+++ git/src/window.c
20@@ -231,9 +231,9 @@ int xa_show_message_dialog (GtkWindow *w
21 {
22 int response;
23
24- dialog = gtk_message_dialog_new (window,mode,type,button,message1);
25+ dialog = gtk_message_dialog_new (window,mode,type,button,"%s",message1);
26 gtk_dialog_set_default_response (GTK_DIALOG (dialog),GTK_RESPONSE_NO);
27- gtk_message_dialog_format_secondary_text (GTK_MESSAGE_DIALOG (dialog),message2);
28+ gtk_message_dialog_format_secondary_text (GTK_MESSAGE_DIALOG (dialog),"%s",message2);
29 response = gtk_dialog_run (GTK_DIALOG (dialog));
30 gtk_widget_destroy (GTK_WIDGET (dialog));
31 return response;
32@@ -511,7 +511,7 @@ void xa_list_archive (GtkMenuItem *menui
33 g_fprintf (stream,_("Comment:\n"));
34 if (bp)
35 g_fprintf(stream,"</b><pre>");
36- g_fprintf (stream,archive[idx]->comment->str);
37+ g_fprintf (stream,"%s",archive[idx]->comment->str);
38 if (bp)
39 g_fprintf(stream,"</pre>");
40 g_fprintf (stream,"\n");
diff --git a/meta-xfce/recipes-apps/xarchiver/xarchiver_git.bb b/meta-xfce/recipes-apps/xarchiver/xarchiver_git.bb
index ea34a52c1..e275af031 100644
--- a/meta-xfce/recipes-apps/xarchiver/xarchiver_git.bb
+++ b/meta-xfce/recipes-apps/xarchiver/xarchiver_git.bb
@@ -7,10 +7,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
7 7
8DEPENDS = "gtk+ glib-2.0 xfce4-dev-tools-native intltool-native" 8DEPENDS = "gtk+ glib-2.0 xfce4-dev-tools-native intltool-native"
9 9
10SRC_URI = "git://github.com/schnitzeltony/xarchiver.git;branch=master \ 10SRC_URI = "git://github.com/schnitzeltony/xarchiver.git;branch=master"
11 file://0001-Add-proper-formatting-string-to-printf-like-function.patch \ 11SRCREV = "5a26dd8ceab0af71b30c83286d7c7398a858c814"
12 "
13SRCREV = "e80e90528c9aab2fe36d9078b945b44c05cc20d3"
14PV = "0.5.3" 12PV = "0.5.3"
15S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
16 14