diff options
author | Andreas Müller <schnitzeltony@gmx.de> | 2011-11-02 22:50:22 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-11-03 09:49:46 +0100 |
commit | 0c8127413f1b87282a63f89bd663c536716df639 (patch) | |
tree | abba128ba3dc0e3ef3b888167d1172daf970ca2d /meta-xfce | |
parent | b3d7efbc9a1853a953177efd7988069fad3551ef (diff) | |
download | meta-openembedded-0c8127413f1b87282a63f89bd663c536716df639.tar.gz |
xfce4-netload-plugin: initial add 1.0.0
* patch taken from xfce-bugzilla [1]
* run tested with wlan0 on overo
[1] https://bugzilla.xfce.org/show_bug.cgi?id=7083
Signed-off-by: Andreas Müller <schnitzeltony@gmx.de>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-xfce')
-rw-r--r-- | meta-xfce/recipes-panel-plugins/netload/files/port-to-libxfce4ui.patch | 72 | ||||
-rw-r--r-- | meta-xfce/recipes-panel-plugins/netload/xfce4-netload-plugin_1.0.0.bb | 11 |
2 files changed, 83 insertions, 0 deletions
diff --git a/meta-xfce/recipes-panel-plugins/netload/files/port-to-libxfce4ui.patch b/meta-xfce/recipes-panel-plugins/netload/files/port-to-libxfce4ui.patch new file mode 100644 index 000000000..55bdffc3d --- /dev/null +++ b/meta-xfce/recipes-panel-plugins/netload/files/port-to-libxfce4ui.patch | |||
@@ -0,0 +1,72 @@ | |||
1 | From 95fcb98d0189c3f9a051b56416503b42ac29ff90 Mon Sep 17 00:00:00 2001 | ||
2 | From: Christoph J. Thompson <cjsthompson@gmail.com> | ||
3 | Date: Tue, 11 Jan 2011 16:17:48 +0100 | ||
4 | Subject: [PATCH 1/2] Port to libxfce4ui. | ||
5 | |||
6 | modified: configure.ac | ||
7 | modified: panel-plugin/Makefile.am | ||
8 | modified: panel-plugin/netload.c | ||
9 | --- | ||
10 | configure.ac | 2 +- | ||
11 | panel-plugin/Makefile.am | 4 ++-- | ||
12 | panel-plugin/netload.c | 5 +++-- | ||
13 | 3 files changed, 6 insertions(+), 5 deletions(-) | ||
14 | |||
15 | diff --git a/configure.ac b/configure.ac | ||
16 | index 0348bfa..3baaa14 100644 | ||
17 | --- a/configure.ac | ||
18 | +++ b/configure.ac | ||
19 | @@ -56,7 +56,7 @@ dnl configure the panel plugin | ||
20 | XDT_CHECK_PACKAGE([LIBXFCE4PANEL], [libxfce4panel-1.0], [4.3.20]) | ||
21 | |||
22 | dnl configure the libxfcegui4 | ||
23 | -XDT_CHECK_PACKAGE([LIBXFCEGUI4], [libxfcegui4-1.0], [4.4.0]) | ||
24 | +XDT_CHECK_PACKAGE([LIBXFCE4UI], [libxfce4ui-1], [4.7.0]) | ||
25 | |||
26 | dnl Check for i18n support | ||
27 | XDT_I18N([@LINGUAS@]) | ||
28 | diff --git a/panel-plugin/Makefile.am b/panel-plugin/Makefile.am | ||
29 | index 0635d67..2163277 100644 | ||
30 | --- a/panel-plugin/Makefile.am | ||
31 | +++ b/panel-plugin/Makefile.am | ||
32 | @@ -17,12 +17,12 @@ xfce4_netload_plugin_SOURCES = \ | ||
33 | xfce4_netload_plugin_CFLAGS = \ | ||
34 | -DPACKAGE_LOCALE_DIR=\"$(localedir)\" \ | ||
35 | @LIBXFCE4PANEL_CFLAGS@ \ | ||
36 | - @LIBXFCEGUI4_CFLAGS@ | ||
37 | + @LIBXFCE4UI_CFLAGS@ | ||
38 | |||
39 | xfce4_netload_plugin_LDADD = \ | ||
40 | @SOLLIBS@ \ | ||
41 | @LIBXFCE4PANEL_LIBS@ \ | ||
42 | - @LIBXFCEGUI4_LIBS@ | ||
43 | + @LIBXFCE4UI_LIBS@ | ||
44 | |||
45 | # .desktop file | ||
46 | # | ||
47 | diff --git a/panel-plugin/netload.c b/panel-plugin/netload.c | ||
48 | index b4868c4..43035f2 100644 | ||
49 | --- a/panel-plugin/netload.c | ||
50 | +++ b/panel-plugin/netload.c | ||
51 | @@ -30,7 +30,7 @@ | ||
52 | #include <gtk/gtk.h> | ||
53 | |||
54 | #include <libxfce4util/libxfce4util.h> | ||
55 | -#include <libxfcegui4/libxfcegui4.h> | ||
56 | +#include <libxfce4ui/libxfce4ui.h> | ||
57 | #include <libxfce4panel/xfce-panel-plugin.h> | ||
58 | |||
59 | |||
60 | @@ -460,7 +460,8 @@ static void setup_monitor(t_global_monitor *global, gboolean supress_warnings) | ||
61 | if (!init_netload( &(global->monitor->data), global->monitor->options.network_device) | ||
62 | && !supress_warnings) | ||
63 | { | ||
64 | - xfce_err (_("%s: Error in initalizing:\n%s"), | ||
65 | + xfce_dialog_show_error (NULL, NULL, | ||
66 | + _("%s: Error in initalizing:\n%s"), | ||
67 | _(APP_NAME), | ||
68 | _(errormessages[ | ||
69 | global->monitor->data.errorcode == 0 | ||
70 | -- | ||
71 | 1.7.1 | ||
72 | |||
diff --git a/meta-xfce/recipes-panel-plugins/netload/xfce4-netload-plugin_1.0.0.bb b/meta-xfce/recipes-panel-plugins/netload/xfce4-netload-plugin_1.0.0.bb new file mode 100644 index 000000000..a0013b4f5 --- /dev/null +++ b/meta-xfce/recipes-panel-plugins/netload/xfce4-netload-plugin_1.0.0.bb | |||
@@ -0,0 +1,11 @@ | |||
1 | DESCRIPTION = "Panel plugin displaying current load of the network interfaces" | ||
2 | HOMEPAGE = "http://goodies.xfce.org/projects/panel-plugins/xfce4-netload-plugin" | ||
3 | LICENSE = "GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=35a7203c41b86d15546dddc05995f97f" | ||
5 | |||
6 | inherit xfce-panel-plugin | ||
7 | |||
8 | # SRC_URI must follow inherited one | ||
9 | SRC_URI += "file://port-to-libxfce4ui.patch" | ||
10 | SRC_URI[md5sum] = "cab53e8cc2b9bfdf7ffd2230916ca3df" | ||
11 | SRC_URI[sha256sum] = "f312d19fc6bfae525886a1f6e84e7d839f19a9f672be4e01f3df1c813f6a6032" | ||