summaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-07-13 22:40:04 -0700
committerArmin Kuster <akuster808@gmail.com>2017-09-13 17:16:28 -0700
commita7c5d85ac31235fe9e0dab5c8f2b273ba48d4f4f (patch)
treec680a0df2adf3b9e6f3439bccf7bfc21e97f6a8a /meta-xfce
parent672c133b48f17004439eed16abea79e666495b75 (diff)
downloadmeta-openembedded-a7c5d85ac31235fe9e0dab5c8f2b273ba48d4f4f.tar.gz
imsettings: Fix build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit 0cb5343932bdd4df2629d41f16a471a611fdfa2e) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-extended/imsettings/imsettings/0001-Rename-use-of-stdout-and-stderr.patch72
-rw-r--r--meta-xfce/recipes-extended/imsettings/imsettings_1.7.1.bb4
2 files changed, 75 insertions, 1 deletions
diff --git a/meta-xfce/recipes-extended/imsettings/imsettings/0001-Rename-use-of-stdout-and-stderr.patch b/meta-xfce/recipes-extended/imsettings/imsettings/0001-Rename-use-of-stdout-and-stderr.patch
new file mode 100644
index 000000000..d77ce4d25
--- /dev/null
+++ b/meta-xfce/recipes-extended/imsettings/imsettings/0001-Rename-use-of-stdout-and-stderr.patch
@@ -0,0 +1,72 @@
1From 7ee62ef0083844ab2fffcd106e3ee2e5f29b2a91 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 12 Jul 2017 18:53:56 -0700
4Subject: [PATCH] Rename use of stdout and stderr
5
6Since it shadow the standard definitions especially
7seen on musl where libc defines these as macros they
8cause all short of compilation errors on musl, using
9a leading underscore makes it unique
10
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 imsettings-daemon/imsettings-proc.c | 28 ++++++++++++++--------------
14 1 file changed, 14 insertions(+), 14 deletions(-)
15
16diff --git a/imsettings-daemon/imsettings-proc.c b/imsettings-daemon/imsettings-proc.c
17index 915e78b..b78fcff 100644
18--- a/imsettings-daemon/imsettings-proc.c
19+++ b/imsettings-daemon/imsettings-proc.c
20@@ -39,8 +39,8 @@
21 #define MAXRESTART 3
22
23 typedef struct _IMSettingsProcInfo {
24- GIOChannel *stdout;
25- GIOChannel *stderr;
26+ GIOChannel *_stdout;
27+ GIOChannel *_stderr;
28 GPid pid;
29 GTimeVal started_time;
30 guint id;
31@@ -368,12 +368,12 @@ _start_process(IMSettingsProc *proc,
32 &ofd, &efd,
33 error)) {
34 pinfo->pid = pid;
35- pinfo->stdout = g_io_channel_unix_new(ofd);
36- pinfo->stderr = g_io_channel_unix_new(efd);
37- g_io_channel_set_close_on_unref(pinfo->stdout, TRUE);
38- g_io_channel_set_close_on_unref(pinfo->stderr, TRUE);
39- pinfo->oid = g_io_add_watch(pinfo->stdout, G_IO_IN, _log_write_cb, proc);
40- pinfo->eid = g_io_add_watch(pinfo->stderr, G_IO_IN, _log_write_cb, proc);
41+ pinfo->_stdout = g_io_channel_unix_new(ofd);
42+ pinfo->_stderr = g_io_channel_unix_new(efd);
43+ g_io_channel_set_close_on_unref(pinfo->_stdout, TRUE);
44+ g_io_channel_set_close_on_unref(pinfo->_stderr, TRUE);
45+ pinfo->oid = g_io_add_watch(pinfo->_stdout, G_IO_IN, _log_write_cb, proc);
46+ pinfo->eid = g_io_add_watch(pinfo->_stderr, G_IO_IN, _log_write_cb, proc);
47 g_get_current_time(&pinfo->started_time);
48 pinfo->id = g_child_watch_add(pid, _watch_im_status_cb, proc);
49
50@@ -521,13 +521,13 @@ imsettings_proc_get_property(GObject *object,
51 static void
52 imsettings_proc_info_finalize(IMSettingsProcInfo *pinfo)
53 {
54- if (pinfo->stdout) {
55- g_io_channel_unref(pinfo->stdout);
56- pinfo->stdout = NULL;
57+ if (pinfo->_stdout) {
58+ g_io_channel_unref(pinfo->_stdout);
59+ pinfo->_stdout = NULL;
60 }
61- if (pinfo->stderr) {
62- g_io_channel_unref(pinfo->stderr);
63- pinfo->stderr = NULL;
64+ if (pinfo->_stderr) {
65+ g_io_channel_unref(pinfo->_stderr);
66+ pinfo->_stderr = NULL;
67 }
68 if (pinfo->oid > 0) {
69 g_source_remove(pinfo->oid);
70--
712.13.2
72
diff --git a/meta-xfce/recipes-extended/imsettings/imsettings_1.7.1.bb b/meta-xfce/recipes-extended/imsettings/imsettings_1.7.1.bb
index e35e8b312..c3e15db9c 100644
--- a/meta-xfce/recipes-extended/imsettings/imsettings_1.7.1.bb
+++ b/meta-xfce/recipes-extended/imsettings/imsettings_1.7.1.bb
@@ -11,7 +11,9 @@ inherit autotools gtk-doc gobject-introspection
11 11
12SRC_URI = "https://bitbucket.org/tagoh/imsettings/downloads/${BPN}-${PV}.tar.bz2 \ 12SRC_URI = "https://bitbucket.org/tagoh/imsettings/downloads/${BPN}-${PV}.tar.bz2 \
13 file://gtk-is-required-by-notify.patch \ 13 file://gtk-is-required-by-notify.patch \
14 file://multi-line-ACLOCAL_AMFLAGS-isnot-supported-by-autoreconf.patch" 14 file://multi-line-ACLOCAL_AMFLAGS-isnot-supported-by-autoreconf.patch \
15 file://0001-Rename-use-of-stdout-and-stderr.patch \
16 "
15 17
16SRC_URI[md5sum] = "ab439e21a7d86fa99fbc04586c755349" 18SRC_URI[md5sum] = "ab439e21a7d86fa99fbc04586c755349"
17SRC_URI[sha256sum] = "12c35352386057ba68d69a0b7d9a1d0d01ebbd893aafe0a094c3158c8079ac9a" 19SRC_URI[sha256sum] = "12c35352386057ba68d69a0b7d9a1d0d01ebbd893aafe0a094c3158c8079ac9a"