diff options
author | Andreas Müller <schnitzeltony@googlemail.com> | 2013-09-21 10:41:34 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-10-05 12:36:06 +0200 |
commit | bbedab064fbb5590ae6740b1ed27269dbeb80e32 (patch) | |
tree | d8e67e8fe9952e22a51041268f7eaed1193a7b52 /meta-xfce | |
parent | 473f5b33968dd9f2c54bd088d8118febcfcae866 (diff) | |
download | meta-openembedded-bbedab064fbb5590ae6740b1ed27269dbeb80e32.tar.gz |
xfce4-cpufreq-plugin: update to 1.1.0
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-xfce')
3 files changed, 15 insertions, 149 deletions
diff --git a/meta-xfce/recipes-panel-plugins/cpufreq/files/port-to-libxfce4ui.patch b/meta-xfce/recipes-panel-plugins/cpufreq/files/port-to-libxfce4ui.patch deleted file mode 100644 index 7afec612a..000000000 --- a/meta-xfce/recipes-panel-plugins/cpufreq/files/port-to-libxfce4ui.patch +++ /dev/null | |||
@@ -1,138 +0,0 @@ | |||
1 | From 273bac3e85098f422036b5e5f7c803b8abaecb7c Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmx.de> | ||
3 | Date: Mon, 17 Oct 2011 23:14:29 +0200 | ||
4 | Subject: [PATCH] port to libxfce4ui | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | |||
10 | Signed-off-by: Andreas Müller <schnitzeltony@gmx.de> | ||
11 | --- | ||
12 | configure.ac | 6 +++--- | ||
13 | panel-plugin/Makefile.am | 4 ++-- | ||
14 | panel-plugin/xfce4-cpufreq-configure.c | 2 +- | ||
15 | panel-plugin/xfce4-cpufreq-linux.c | 4 ++-- | ||
16 | panel-plugin/xfce4-cpufreq-overview.c | 2 +- | ||
17 | panel-plugin/xfce4-cpufreq-plugin.c | 6 +++--- | ||
18 | 6 files changed, 12 insertions(+), 12 deletions(-) | ||
19 | |||
20 | diff --git a/configure.ac b/configure.ac | ||
21 | index 1856861..19672e0 100644 | ||
22 | --- a/configure.ac | ||
23 | +++ b/configure.ac | ||
24 | @@ -30,9 +30,9 @@ XDT_I18N([@LINGUAS@]) | ||
25 | dnl configure the panel plugin | ||
26 | XDT_CHECK_PACKAGE([GTHREAD], [gthread-2.0], [2.6.0]) | ||
27 | XDT_CHECK_PACKAGE([GTK], [gtk+-2.0], [2.6.0]) | ||
28 | -XDT_CHECK_PACKAGE([LIBXFCE4UTIL], [libxfce4util-1.0], [4.3.90]) | ||
29 | -XDT_CHECK_PACKAGE([LIBXFCEGUI4], [libxfcegui4-1.0], [4.3.90]) | ||
30 | -XDT_CHECK_PACKAGE([LIBXFCE4PANEL], [libxfce4panel-1.0], [4.3.90]) | ||
31 | +XDT_CHECK_PACKAGE([LIBXFCE4UTIL], [libxfce4util-1.0], [4.8.0]) | ||
32 | +XDT_CHECK_PACKAGE([LIBXFCE4UI], [libxfce4ui-1], [4.8.0]) | ||
33 | +XDT_CHECK_PACKAGE([LIBXFCE4PANEL], [libxfce4panel-1.0], [4.8.0]) | ||
34 | |||
35 | dnl *********************************** | ||
36 | dnl *** Check for debugging support *** | ||
37 | diff --git a/panel-plugin/Makefile.am b/panel-plugin/Makefile.am | ||
38 | index d890f85..688402a 100644 | ||
39 | --- a/panel-plugin/Makefile.am | ||
40 | +++ b/panel-plugin/Makefile.am | ||
41 | @@ -5,13 +5,13 @@ xfce4_cpufreq_plugin_CFLAGS = \ | ||
42 | -I$(top_srcdir) \ | ||
43 | @LIBXFCE4PANEL_CFLAGS@ \ | ||
44 | @LIBXFCE4UTIL_CFLAGS@ \ | ||
45 | - @LIBXFCEGUI4_CFLAGS@ \ | ||
46 | + @LIBXFCE4UI_CFLAGS@ \ | ||
47 | -DPACKAGE_LOCALE_DIR=\"$(localedir)\" | ||
48 | |||
49 | xfce4_cpufreq_plugin_LDADD = \ | ||
50 | @LIBXFCE4PANEL_LIBS@ \ | ||
51 | @LIBXFCE4UTIL_LIBS@ \ | ||
52 | - @LIBXFCEGUI4_LIBS@ | ||
53 | + @LIBXFCE4UI_LIBS@ | ||
54 | |||
55 | xfce4_cpufreq_plugin_SOURCES = \ | ||
56 | xfce4-cpufreq-plugin.h \ | ||
57 | diff --git a/panel-plugin/xfce4-cpufreq-configure.c b/panel-plugin/xfce4-cpufreq-configure.c | ||
58 | index 3de12c8..60af8a7 100644 | ||
59 | --- a/panel-plugin/xfce4-cpufreq-configure.c | ||
60 | +++ b/panel-plugin/xfce4-cpufreq-configure.c | ||
61 | @@ -23,7 +23,7 @@ | ||
62 | #include <config.h> | ||
63 | #endif | ||
64 | |||
65 | -#include <libxfcegui4/libxfcegui4.h> | ||
66 | +#include <libxfce4ui/libxfce4ui.h> | ||
67 | #include "xfce4-cpufreq-plugin.h" | ||
68 | #include "xfce4-cpufreq-configure.h" | ||
69 | |||
70 | diff --git a/panel-plugin/xfce4-cpufreq-linux.c b/panel-plugin/xfce4-cpufreq-linux.c | ||
71 | index 9a27419..00c6dd4 100644 | ||
72 | --- a/panel-plugin/xfce4-cpufreq-linux.c | ||
73 | +++ b/panel-plugin/xfce4-cpufreq-linux.c | ||
74 | @@ -27,7 +27,7 @@ | ||
75 | #include "xfce4-cpufreq-plugin.h" | ||
76 | #include "xfce4-cpufreq-linux.h" | ||
77 | |||
78 | -#include <libxfcegui4/libxfcegui4.h> | ||
79 | +#include <libxfce4ui/libxfce4ui.h> | ||
80 | |||
81 | #ifndef _ | ||
82 | # include <libintl.h> | ||
83 | @@ -410,7 +410,7 @@ cpufreq_linux_init (void) | ||
84 | { | ||
85 | if (cpuFreq->options->show_warning) | ||
86 | { | ||
87 | - xfce_warn (_("Your system does not support cpufreq.\nThe applet only shows the current cpu frequency")); | ||
88 | + xfce_dialog_show_warning (NULL, NULL, _("Your system does not support cpufreq.\nThe applet only shows the current cpu frequency")); | ||
89 | cpuFreq->options->show_warning = FALSE; | ||
90 | } | ||
91 | |||
92 | diff --git a/panel-plugin/xfce4-cpufreq-overview.c b/panel-plugin/xfce4-cpufreq-overview.c | ||
93 | index a186f30..c4937bf 100644 | ||
94 | --- a/panel-plugin/xfce4-cpufreq-overview.c | ||
95 | +++ b/panel-plugin/xfce4-cpufreq-overview.c | ||
96 | @@ -23,7 +23,7 @@ | ||
97 | #include <config.h> | ||
98 | #endif | ||
99 | |||
100 | -#include <libxfcegui4/libxfcegui4.h> | ||
101 | +#include <libxfce4ui/libxfce4ui.h> | ||
102 | #ifndef _ | ||
103 | # include <libintl.h> | ||
104 | # define _(String) gettext (String) | ||
105 | diff --git a/panel-plugin/xfce4-cpufreq-plugin.c b/panel-plugin/xfce4-cpufreq-plugin.c | ||
106 | index fd9788d..8bbc7c4 100644 | ||
107 | --- a/panel-plugin/xfce4-cpufreq-plugin.c | ||
108 | +++ b/panel-plugin/xfce4-cpufreq-plugin.c | ||
109 | @@ -26,7 +26,7 @@ | ||
110 | #endif | ||
111 | |||
112 | #include <libxfce4util/libxfce4util.h> | ||
113 | -#include <libxfcegui4/libxfcegui4.h> | ||
114 | +#include <libxfce4ui/libxfce4ui.h> | ||
115 | #ifndef _ | ||
116 | # include <libintl.h> | ||
117 | # define _(String) gettext (String) | ||
118 | @@ -329,7 +329,7 @@ cpufreq_construct (XfcePanelPlugin *plugin) | ||
119 | |||
120 | #ifdef __linux__ | ||
121 | if (cpufreq_linux_init () == FALSE) | ||
122 | - xfce_err (_("Your system is not configured correctly to support cpu frequency scaling !")); | ||
123 | + xfce_dialog_show_error (NULL, NULL, _("Your system is not configured correctly to support cpu frequency scaling !")); | ||
124 | |||
125 | gtk_widget_set_size_request (GTK_WIDGET (plugin), -1, -1); | ||
126 | cpufreq_widgets (); | ||
127 | @@ -339,7 +339,7 @@ cpufreq_construct (XfcePanelPlugin *plugin) | ||
128 | (GSourceFunc) cpufreq_update_cpus, | ||
129 | NULL); | ||
130 | #else | ||
131 | - xfce_err (_("Your system is not supported yet !")); | ||
132 | + xfce_dialog_show_error (NULL, NULL, _("Your system is not supported yet !")); | ||
133 | #endif /* __linux__ */ | ||
134 | |||
135 | g_signal_connect (plugin, "free-data", G_CALLBACK (cpufreq_free), | ||
136 | -- | ||
137 | 1.7.4.4 | ||
138 | |||
diff --git a/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin_1.0.0.bb b/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin_1.0.0.bb deleted file mode 100644 index 2c9789d62..000000000 --- a/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin_1.0.0.bb +++ /dev/null | |||
@@ -1,11 +0,0 @@ | |||
1 | DESCRIPTION = "Panel plugin to display frequency of all cpus" | ||
2 | HOMEPAGE = "http://goodies.xfce.org/projects/panel-plugins/xfce4-cpufreq-plugin" | ||
3 | LICENSE = "GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=1f6f1c0be32491a0c8d2915607a28f36" | ||
5 | |||
6 | inherit xfce-panel-plugin | ||
7 | |||
8 | # SRC_URI must follow inherited one | ||
9 | SRC_URI += "file://port-to-libxfce4ui.patch" | ||
10 | SRC_URI[md5sum] = "24cae9b8583cae82b715b4f72aa8e341" | ||
11 | SRC_URI[sha256sum] = "e1b39a997487ef67d4f7863c81e2d9c1a700abded840ebdbe009c72214925460" | ||
diff --git a/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin_1.1.0.bb b/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin_1.1.0.bb new file mode 100644 index 000000000..07b1a9a0e --- /dev/null +++ b/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin_1.1.0.bb | |||
@@ -0,0 +1,15 @@ | |||
1 | DESCRIPTION = "Panel plugin to display frequency of all cpus" | ||
2 | HOMEPAGE = "http://goodies.xfce.org/projects/panel-plugins/xfce4-cpufreq-plugin" | ||
3 | LICENSE = "GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=1f6f1c0be32491a0c8d2915607a28f36" | ||
5 | |||
6 | inherit xfce-panel-plugin | ||
7 | |||
8 | SRC_URI[md5sum] = "dcc56af0e19266956c297d124ba551f4" | ||
9 | SRC_URI[sha256sum] = "eafa261bf984231ed8487c08decea6d916339d82b52f4bbe748e5c6a95c7f6b6" | ||
10 | |||
11 | # defaults in xfce4-panel-plugin.bbclass don't match so override here | ||
12 | FILES_${PN} = "${datadir}/icons ${datadir}/xfce4 ${libdir}/xfce4/panel/plugins/*.so*" | ||
13 | |||
14 | # *.so are required for plugin detection | ||
15 | INSANE_SKIP_${PN} = "dev-so" | ||