summaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-xfce
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-apps/xfce4-screenshooter/xfce4-screenshooter_1.8.1.bb2
-rw-r--r--meta-xfce/recipes-art/cursor-themes/openzone_1.2.3.bb8
-rw-r--r--meta-xfce/recipes-panel-plugins/closebutton/xfce4-closebutton-plugin_git.bb2
-rw-r--r--meta-xfce/recipes-panel-plugins/weather/xfce4-weather-plugin_0.7.4.bb12
-rw-r--r--meta-xfce/recipes-xfce/exo/exo_0.10.2.bb4
-rw-r--r--meta-xfce/recipes-xfce/tumbler/tumbler_0.1.27.bb2
-rw-r--r--meta-xfce/recipes-xfce/xfce4-dev-tools/xfce4-dev-tools_4.10.0.bb4
-rw-r--r--meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.10.0.bb2
-rw-r--r--meta-xfce/recipes-xfce/xfce4-power-manager/xfce4-power-manager_1.2.0.bb4
-rw-r--r--meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_4.11.0.bb6
-rw-r--r--meta-xfce/recipes-xfce/xfwm4/xfwm4_4.10.0.bb2
11 files changed, 24 insertions, 24 deletions
diff --git a/meta-xfce/recipes-apps/xfce4-screenshooter/xfce4-screenshooter_1.8.1.bb b/meta-xfce/recipes-apps/xfce4-screenshooter/xfce4-screenshooter_1.8.1.bb
index b05c29873..9ec034a31 100644
--- a/meta-xfce/recipes-apps/xfce4-screenshooter/xfce4-screenshooter_1.8.1.bb
+++ b/meta-xfce/recipes-apps/xfce4-screenshooter/xfce4-screenshooter_1.8.1.bb
@@ -12,4 +12,4 @@ SRC_URI[md5sum] = "d0ffea2052a8e70154cf13789070711f"
12SRC_URI[sha256sum] = "40419892bd28989315eed053c159bba0f4264ed8c6c6738806024e481eab9492" 12SRC_URI[sha256sum] = "40419892bd28989315eed053c159bba0f4264ed8c6c6738806024e481eab9492"
13 13
14FILES_${PN} += "${datadir}/xfce4/panel/plugins \ 14FILES_${PN} += "${datadir}/xfce4/panel/plugins \
15 ${libdir}/xfce4/panel/plugins" 15 ${libdir}/xfce4/panel/plugins"
diff --git a/meta-xfce/recipes-art/cursor-themes/openzone_1.2.3.bb b/meta-xfce/recipes-art/cursor-themes/openzone_1.2.3.bb
index 2e19d8980..8d990f3fa 100644
--- a/meta-xfce/recipes-art/cursor-themes/openzone_1.2.3.bb
+++ b/meta-xfce/recipes-art/cursor-themes/openzone_1.2.3.bb
@@ -14,10 +14,10 @@ SRC_URI[sha256sum] = "dc20f97a49e1ff1becf7853ef5f137ed30a4c27490540e755021d78d33
14S = "${WORKDIR}/OpenZone" 14S = "${WORKDIR}/OpenZone"
15 15
16do_install() { 16do_install() {
17 install -d ${D}${datadir}/icons 17 install -d ${D}${datadir}/icons
18 for theme in `find -name '*.tar.xz'`; do 18 for theme in `find -name '*.tar.xz'`; do
19 tar -Jxf ${theme} -C ${D}${datadir}/icons 19 tar -Jxf ${theme} -C ${D}${datadir}/icons
20 done 20 done
21} 21}
22 22
23python populate_packages_prepend () { 23python populate_packages_prepend () {
diff --git a/meta-xfce/recipes-panel-plugins/closebutton/xfce4-closebutton-plugin_git.bb b/meta-xfce/recipes-panel-plugins/closebutton/xfce4-closebutton-plugin_git.bb
index 879d1d6c8..7348170b1 100644
--- a/meta-xfce/recipes-panel-plugins/closebutton/xfce4-closebutton-plugin_git.bb
+++ b/meta-xfce/recipes-panel-plugins/closebutton/xfce4-closebutton-plugin_git.bb
@@ -16,7 +16,7 @@ S = "${WORKDIR}/git"
16EXTRA_OECONF += "--enable-maintainer-mode" 16EXTRA_OECONF += "--enable-maintainer-mode"
17 17
18do_configure_prepend() { 18do_configure_prepend() {
19 NOCONFIGURE=yes ./autogen.sh 19 NOCONFIGURE=yes ./autogen.sh
20} 20}
21 21
22FILES_${PN} += "${datadir}/xfce4/closebutton/themes" 22FILES_${PN} += "${datadir}/xfce4/closebutton/themes"
diff --git a/meta-xfce/recipes-panel-plugins/weather/xfce4-weather-plugin_0.7.4.bb b/meta-xfce/recipes-panel-plugins/weather/xfce4-weather-plugin_0.7.4.bb
index 202078ee7..68307a8ee 100644
--- a/meta-xfce/recipes-panel-plugins/weather/xfce4-weather-plugin_0.7.4.bb
+++ b/meta-xfce/recipes-panel-plugins/weather/xfce4-weather-plugin_0.7.4.bb
@@ -11,12 +11,12 @@ SRC_URI[md5sum] = "03c972d13eba5cd226432ff66e3ff282"
11SRC_URI[sha256sum] = "3f76207b8a845d15bfec6825bd5300aedd086c455259c4dd8670a89a3c8ab382" 11SRC_URI[sha256sum] = "3f76207b8a845d15bfec6825bd5300aedd086c455259c4dd8670a89a3c8ab382"
12 12
13do_compile_prepend() { 13do_compile_prepend() {
14 # Switch to a working license key 14 # Switch to a working license key
15 # https://bugs.archlinux.org/task/26815 15 # https://bugs.archlinux.org/task/26815
16 sed -i \ 16 sed -i \
17 -e 's/^#define PARTNER_ID.*/#define PARTNER_ID "1003666583"/' \ 17 -e 's/^#define PARTNER_ID.*/#define PARTNER_ID "1003666583"/' \
18 -e 's/^#define LICENSE_KEY.*/#define LICENSE_KEY "4128909340a9b2fc"/' \ 18 -e 's/^#define LICENSE_KEY.*/#define LICENSE_KEY "4128909340a9b2fc"/' \
19 ${S}/panel-plugin/weather.h 19 ${S}/panel-plugin/weather.h
20 20
21} 21}
22 22
diff --git a/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb b/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb
index 5e6b5acdb..09aacc3da 100644
--- a/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb
+++ b/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb
@@ -27,10 +27,10 @@ PACKAGES =+ "exo-csource"
27# pyxfce see http://comments.gmane.org/gmane.comp.desktop.xfce.devel.version4/19560 27# pyxfce see http://comments.gmane.org/gmane.comp.desktop.xfce.devel.version4/19560
28FILES_${PN} += "${datadir}/xfce4/ \ 28FILES_${PN} += "${datadir}/xfce4/ \
29 ${libdir}/xfce4/exo-1 \ 29 ${libdir}/xfce4/exo-1 \
30 " 30"
31 31
32FILES_${PN}-dbg += "${libdir}/gio/modules/.debug \ 32FILES_${PN}-dbg += "${libdir}/gio/modules/.debug \
33 " 33"
34 34
35FILES_exo-csource += "${bindir}/exo-csource" 35FILES_exo-csource += "${bindir}/exo-csource"
36 36
diff --git a/meta-xfce/recipes-xfce/tumbler/tumbler_0.1.27.bb b/meta-xfce/recipes-xfce/tumbler/tumbler_0.1.27.bb
index 663e67c7c..93a95d534 100644
--- a/meta-xfce/recipes-xfce/tumbler/tumbler_0.1.27.bb
+++ b/meta-xfce/recipes-xfce/tumbler/tumbler_0.1.27.bb
@@ -20,7 +20,7 @@ FILES_${PN} += "${datadir}/dbus-1/services \
20 ${libdir}/tumbler-1/tumblerd \ 20 ${libdir}/tumbler-1/tumblerd \
21 ${libdir}/tumbler-1/plugins/*.so \ 21 ${libdir}/tumbler-1/plugins/*.so \
22 ${libdir}/tumbler-1/plugins/cache/*.so \ 22 ${libdir}/tumbler-1/plugins/cache/*.so \
23 " 23"
24 24
25FILES_${PN}-dev += "${libdir}/tumbler-1/plugins/*.la \ 25FILES_${PN}-dev += "${libdir}/tumbler-1/plugins/*.la \
26 ${libdir}/tumbler-1/plugins/cache/*.la" 26 ${libdir}/tumbler-1/plugins/cache/*.la"
diff --git a/meta-xfce/recipes-xfce/xfce4-dev-tools/xfce4-dev-tools_4.10.0.bb b/meta-xfce/recipes-xfce/xfce4-dev-tools/xfce4-dev-tools_4.10.0.bb
index 1955fccb0..8779b01f4 100644
--- a/meta-xfce/recipes-xfce/xfce4-dev-tools/xfce4-dev-tools_4.10.0.bb
+++ b/meta-xfce/recipes-xfce/xfce4-dev-tools/xfce4-dev-tools_4.10.0.bb
@@ -14,8 +14,8 @@ SRC_URI[md5sum] = "372b74f432e7e02d946c2ea9d3de2805"
14SRC_URI[sha256sum] = "f79649bbfbbf16881494ee9f67035063765aec12e23ab9bac31de2c8a4f32bf8" 14SRC_URI[sha256sum] = "f79649bbfbbf16881494ee9f67035063765aec12e23ab9bac31de2c8a4f32bf8"
15 15
16do_install_append() { 16do_install_append() {
17 install -d ${D}${datadir}/aclocal 17 install -d ${D}${datadir}/aclocal
18 install -m 644 m4macros/*.m4 ${D}${datadir}/aclocal/ 18 install -m 644 m4macros/*.m4 ${D}${datadir}/aclocal/
19} 19}
20 20
21FILES_${PN} += "${datadir}/xfce4/dev-tools/m4macros/*.m4" 21FILES_${PN} += "${datadir}/xfce4/dev-tools/m4macros/*.m4"
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.10.0.bb b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.10.0.bb
index f7d7c4687..02a6cb1c9 100644
--- a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.10.0.bb
+++ b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.10.0.bb
@@ -26,4 +26,4 @@ FILES_${PN} += "${libdir}/xfce4/panel/migrate \
26 ${libdir}/xfce4/panel/wrapper" 26 ${libdir}/xfce4/panel/wrapper"
27 27
28FILES_${PN}-dbg += "${libdir}/xfce4/panel/plugins/.debug \ 28FILES_${PN}-dbg += "${libdir}/xfce4/panel/plugins/.debug \
29 " 29"
diff --git a/meta-xfce/recipes-xfce/xfce4-power-manager/xfce4-power-manager_1.2.0.bb b/meta-xfce/recipes-xfce/xfce4-power-manager/xfce4-power-manager_1.2.0.bb
index 670fc251e..af2ba5e64 100644
--- a/meta-xfce/recipes-xfce/xfce4-power-manager/xfce4-power-manager_1.2.0.bb
+++ b/meta-xfce/recipes-xfce/xfce4-power-manager/xfce4-power-manager_1.2.0.bb
@@ -15,14 +15,14 @@ EXTRA_OECONF = " \
15 --enable-polkit \ 15 --enable-polkit \
16 --enable-network-manager \ 16 --enable-network-manager \
17 --enable-panel-plugins \ 17 --enable-panel-plugins \
18 " 18"
19 19
20PACKAGES += "xfce4-brightness-plugin" 20PACKAGES += "xfce4-brightness-plugin"
21FILES_${PN} += "${datadir}/polkit-1" 21FILES_${PN} += "${datadir}/polkit-1"
22FILES_xfce4-brightness-plugin = " \ 22FILES_xfce4-brightness-plugin = " \
23 ${libdir}/xfce4/panel-plugins/xfce4-brightness-plugin \ 23 ${libdir}/xfce4/panel-plugins/xfce4-brightness-plugin \
24 ${datadir}/xfce4/panel-plugins/xfce4-brightness-plugin.desktop \ 24 ${datadir}/xfce4/panel-plugins/xfce4-brightness-plugin.desktop \
25 " 25"
26 26
27SRC_URI[md5sum] = "935599b7114b0a4b0e2c9a5d6c72524c" 27SRC_URI[md5sum] = "935599b7114b0a4b0e2c9a5d6c72524c"
28SRC_URI[sha256sum] = "d7fb98a540284b62f4201527de17d4b24123f9d26c9f49131dd497c8387184e9" 28SRC_URI[sha256sum] = "d7fb98a540284b62f4201527de17d4b24123f9d26c9f49131dd497c8387184e9"
diff --git a/meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_4.11.0.bb b/meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_4.11.0.bb
index c5cb03371..d633fa6d1 100644
--- a/meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_4.11.0.bb
+++ b/meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_4.11.0.bb
@@ -23,9 +23,9 @@ SRC_URI[sha256sum] = "4a4f1e79a58b524f3a6dd030b6fc687671b35566f847e6f516c6f84211
23FILES_${PN} += "${libdir}/xfce4" 23FILES_${PN} += "${libdir}/xfce4"
24 24
25do_install_prepend() { 25do_install_prepend() {
26 # somehow binary files are not patched correctly by oe-patch - so copy them 26 # somehow binary files are not patched correctly by oe-patch - so copy them
27 cp ${WORKDIR}/touchscreen/invisible ${S}/cursors 27 cp ${WORKDIR}/touchscreen/invisible ${S}/cursors
28 cp ${WORKDIR}/touchscreen/wait ${S}/cursors 28 cp ${WORKDIR}/touchscreen/wait ${S}/cursors
29} 29}
30 30
31RRECOMMENDS_${PN} += "gnome-icon-theme" 31RRECOMMENDS_${PN} += "gnome-icon-theme"
diff --git a/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.10.0.bb b/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.10.0.bb
index 4f686a581..5801c517a 100644
--- a/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.10.0.bb
+++ b/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.10.0.bb
@@ -23,6 +23,6 @@ ALTERNATIVE_PRIORITY[x-window-manager] = "30"
23RDEPENDS_${PN} = "xfwm4-theme-default" 23RDEPENDS_${PN} = "xfwm4-theme-default"
24FILES_${PN} += "${libdir}/xfce4/xfwm4/helper-dialog \ 24FILES_${PN} += "${libdir}/xfce4/xfwm4/helper-dialog \
25 ${datadir}/xfwm4/defaults \ 25 ${datadir}/xfwm4/defaults \
26 " 26"
27FILES_${PN}-dbg += "${libexecdir}/xfce4/xfwm4/.debug/*" 27FILES_${PN}-dbg += "${libexecdir}/xfce4/xfwm4/.debug/*"
28 28