summaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2013-04-05 23:03:32 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-09 21:34:16 +0200
commit3efa3275c2c6ce563d7a7f037c5aa8e151daa30b (patch)
treeb6242b995a5b6b66b235b711c23b6c707c4be71a /meta-xfce
parent313113839ce6a9236ef62d9c36439747ba12507a (diff)
downloadmeta-openembedded-3efa3275c2c6ce563d7a7f037c5aa8e151daa30b.tar.gz
exo: remove gnome-mount wrapper
exo-mount was removed long time ago [1] [1] http://git.xfce.org/xfce/exo/commit/?id=5d698bf98b190d7c76a6b406bd5f542b915d0bd1 Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-xfce/exo/exo/gnome-mount64
-rw-r--r--meta-xfce/recipes-xfce/exo/exo_0.10.2.bb9
2 files changed, 1 insertions, 72 deletions
diff --git a/meta-xfce/recipes-xfce/exo/exo/gnome-mount b/meta-xfce/recipes-xfce/exo/exo/gnome-mount
deleted file mode 100644
index 85fdb25e8..000000000
--- a/meta-xfce/recipes-xfce/exo/exo/gnome-mount
+++ /dev/null
@@ -1,64 +0,0 @@
1#!/bin/sh
2#
3# gnome-mount - wrapper script for use with exo-mount
4#
5# Copyright 2009 Enrico Tröger <enrico(at)xfce(dot)org>
6# Licence: GPLv2
7#
8#
9# This script aims to be a wrapper script to provide the
10# gnome-mount utility on envrionments which only have
11# exo-mount (e.g. Xfce). It accepts all command line arguments
12# which are passed but ignores all which are not supported by
13# exo-mount.
14#
15# (This script was tested with Bash and Dash.)
16#
17# Possible use case is as a drop-in replacement to get mounting
18# local resources with GVfs working, e.g. mounting disks in CD drives.
19#
20# Usage:
21# Save this script as 'gnome-mount' in a directory in your path,
22# e.g. /usr/local/bin or ~/bin and make it executable.
23#
24
25
26
27OPTS=""
28
29# first catch all passed arguments and keep those exo-mount supports,
30# ignore all other arguments
31while [ -n "$*" ]
32do
33 case $1 in
34 -\?|--help)
35 OPTS="$OPTS --help"
36 ;;
37 -e|--eject)
38 OPTS="$OPTS --eject"
39 ;;
40 -u|--unmount)
41 OPTS="$OPTS --unmount"
42 ;;
43 -h|--hal-udi)
44 OPTS="$OPTS --hal-udi"
45 shift
46 OPTS="$OPTS $1"
47 ;;
48 -d|--device)
49 OPTS="$OPTS --device"
50 shift
51 OPTS="$OPTS $1"
52 ;;
53 -n|--no-ui)
54 OPTS="$OPTS --no-ui"
55 ;;
56 -V|--version)
57 OPTS="$OPTS --version"
58 ;;
59 esac
60 shift
61done
62
63# now run exo-mount and hope things go well
64exo-mount $OPTS
diff --git a/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb b/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb
index ff529dbbe..5e6b5acdb 100644
--- a/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb
+++ b/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb
@@ -4,7 +4,7 @@ LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" 4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5DEPENDS = "gtk+ libxfce4util libxfce4ui virtual/libx11 liburi-perl-native cairo" 5DEPENDS = "gtk+ libxfce4util libxfce4ui virtual/libx11 liburi-perl-native cairo"
6DEPENDS_class-native = "glib-2.0-native xfce4-dev-tools-native" 6DEPENDS_class-native = "glib-2.0-native xfce4-dev-tools-native"
7PR = "r3" 7PR = "r4"
8 8
9inherit xfce pythonnative perlnative 9inherit xfce pythonnative perlnative
10 10
@@ -12,7 +12,6 @@ inherit xfce pythonnative perlnative
12SRC_URI += " \ 12SRC_URI += " \
13 file://exo-no-tests-0.8.patch \ 13 file://exo-no-tests-0.8.patch \
14 file://configure.patch \ 14 file://configure.patch \
15 file://gnome-mount \
16" 15"
17 16
18SRC_URI_append_class-native = " \ 17SRC_URI_append_class-native = " \
@@ -22,12 +21,6 @@ SRC_URI_append_class-native = " \
22SRC_URI[md5sum] = "c70f2a217811bfba2e62f938d4b8f748" 21SRC_URI[md5sum] = "c70f2a217811bfba2e62f938d4b8f748"
23SRC_URI[sha256sum] = "b385828bf8a38204da3254b57fdfa25a72694495aa189fabd5040f707eec76ce" 22SRC_URI[sha256sum] = "b385828bf8a38204da3254b57fdfa25a72694495aa189fabd5040f707eec76ce"
24 23
25# see http://wiki.xfce.org/gnomemount-replacement
26do_install_append () {
27 install -m 755 -d ${D}${bindir}/exo-mount-wrapper
28 install -m 755 ${WORKDIR}//gnome-mount ${D}${bindir}/exo-mount-wrapper
29}
30
31PACKAGES =+ "exo-csource" 24PACKAGES =+ "exo-csource"
32 25
33# Note: python bindings did not work in oe-dev and are about to be moved to 26# Note: python bindings did not work in oe-dev and are about to be moved to