summaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2013-09-21 10:41:40 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-10-05 12:36:13 +0200
commit228ca3b736a09587f6661a5cfc53797b916a518f (patch)
tree78a56fcab8427e74a9e2a0c1606a5bf2d466c287 /meta-xfce
parentd902f8756713364d29e63777867301bf7604accf (diff)
downloadmeta-openembedded-228ca3b736a09587f6661a5cfc53797b916a518f.tar.gz
xfce4-notes-plugin: initial add 1.7.7
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-panel-plugins/notes/files/0001-Bump-dependency-to-Xfce-4.10.patch128
-rw-r--r--meta-xfce/recipes-panel-plugins/notes/files/0002-main-status-icon.c-remove-deprecated-g_type_init.patch32
-rw-r--r--meta-xfce/recipes-panel-plugins/notes/xfce4-notes-plugin_1.7.7.bb20
3 files changed, 180 insertions, 0 deletions
diff --git a/meta-xfce/recipes-panel-plugins/notes/files/0001-Bump-dependency-to-Xfce-4.10.patch b/meta-xfce/recipes-panel-plugins/notes/files/0001-Bump-dependency-to-Xfce-4.10.patch
new file mode 100644
index 000000000..4a3b1ce58
--- /dev/null
+++ b/meta-xfce/recipes-panel-plugins/notes/files/0001-Bump-dependency-to-Xfce-4.10.patch
@@ -0,0 +1,128 @@
1From 26c4ad1765d0d59b3918363d38174c5f5bfe0dcd Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Fri, 20 Sep 2013 22:49:47 +0200
4Subject: [PATCH] Bump dependency to Xfce 4.10
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Drop support for Xfce <= 4.6.
10Replace libxfcegui4 dependency against libxfce4ui.
11Update to new libtool syntax (use LT_PREREQ.)
12
13Upstream-status: Backport [1]
14
15[1] http://git.xfce.org/panel-plugins/xfce4-notes-plugin/commit/?id=d11fe51fae95b5b4963847be76ae4a07409a6076
16
17Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
18---
19 configure.ac | 23 ++++++++++-------------
20 src/Makefile.am | 4 ++--
21 src/xfce4-notes-settings.c | 6 +++---
22 3 files changed, 15 insertions(+), 18 deletions(-)
23
24diff --git a/configure.ac b/configure.ac
25index 20d27e5..8d4113f 100644
26--- a/configure.ac
27+++ b/configure.ac
28@@ -24,21 +24,17 @@ AC_INIT([Notes], [xfce4_notes_plugin_version], [http://bugzilla.xfce.org/], [xfc
29 AC_REVISION([xfce4_notes_plugin_version_build])
30 AC_CANONICAL_TARGET()
31
32+LT_PREREQ([2.2.6])
33+LT_INIT([disable-static])
34+
35 AM_INIT_AUTOMAKE([1.11 dist-bzip2])
36 AM_CONFIG_HEADER([config.h])
37 AM_MAINTAINER_MODE()
38 AM_SILENT_RULES([yes])
39
40-dnl Avoid g77 and g++ checks
41-m4_undefine([AC_PROG_CXX])
42-m4_defun([AC_PROG_CXX],[])
43-m4_undefine([AC_PROG_F77])
44-m4_defun([AC_PROG_F77],[])
45-
46 dnl Check for basic programs
47 AM_PROG_CC_C_O()
48 AC_PROG_LD()
49-AC_PROG_LIBTOOL()
50 AC_PROG_INSTALL()
51 AC_PROG_INTLTOOL()
52
53@@ -51,12 +47,13 @@ AC_SUBST([MATH_LIBS], [" -lm"])
54
55 dnl Check for required packages
56 XDT_CHECK_LIBX11_REQUIRE()
57-XDT_CHECK_PACKAGE([GLIB], [glib-2.0], [2.16.0])
58-XDT_CHECK_PACKAGE([GTK], [gtk+-2.0], [2.14.0])
59-XDT_CHECK_PACKAGE([LIBXFCEGUI4], [libxfcegui4-1.0], [4.4.0])
60-XDT_CHECK_PACKAGE([LIBXFCE4UTIL], [libxfce4util-1.0], [4.4.0])
61-XDT_CHECK_PACKAGE([LIBXFCE4PANEL], [libxfce4panel-1.0], [4.4.0])
62-XDT_CHECK_PACKAGE([XFCONF], [libxfconf-0], [4.6.0])
63+XDT_CHECK_PACKAGE([GLIB], [glib-2.0], [2.24.0])
64+XDT_CHECK_PACKAGE([GIO], [gio-2.0], [2.24.0])
65+XDT_CHECK_PACKAGE([GTK], [gtk+-2.0], [2.20.0])
66+XDT_CHECK_PACKAGE([LIBXFCE4UI], [libxfce4ui-1], [4.10.0])
67+XDT_CHECK_PACKAGE([LIBXFCE4UTIL], [libxfce4util-1.0], [4.10.0])
68+XDT_CHECK_PACKAGE([LIBXFCE4PANEL], [libxfce4panel-1.0], [4.10.0])
69+XDT_CHECK_PACKAGE([XFCONF], [libxfconf-0], [4.10.0])
70 XDT_CHECK_PACKAGE([UNIQUE], [unique-1.0], [1.0.0])
71
72 dnl Check for libxfce4panel >= 4.7
73diff --git a/src/Makefile.am b/src/Makefile.am
74index f69ab0f..2d97b63 100644
75--- a/src/Makefile.am
76+++ b/src/Makefile.am
77@@ -36,7 +36,7 @@ xfce4_notes_settings_SOURCES = \
78 xfce4_notes_settings_CFLAGS = \
79 @LIBX11_CFLAGS@ \
80 @GTK_CFLAGS@ \
81- @LIBXFCEGUI4_CFLAGS@ \
82+ @LIBXFCE4UI_CFLAGS@ \
83 @XFCONF_CFLAGS@ \
84 @UNIQUE_CFLAGS@
85
86@@ -44,7 +44,7 @@ xfce4_notes_settings_LDADD = \
87 $(top_builddir)/lib/libnotes.la \
88 @LIBX11_LIBS@ \
89 @GTK_LIBS@ \
90- @LIBXFCEGUI4_LIBS@ \
91+ @LIBXFCE4UI_LIBS@ \
92 @XFCONF_LIBS@ \
93 @UNIQUE_LIBS@
94
95diff --git a/src/xfce4-notes-settings.c b/src/xfce4-notes-settings.c
96index f66bb13..1d7cc70 100644
97--- a/src/xfce4-notes-settings.c
98+++ b/src/xfce4-notes-settings.c
99@@ -25,7 +25,7 @@
100 #include <xfconf/xfconf.h>
101 #include <gtk/gtk.h>
102 #include <libxfce4util/libxfce4util.h>
103-#include <libxfcegui4/libxfcegui4.h>
104+#include <libxfce4ui/libxfce4ui.h>
105
106 #include "defines.h"
107 #include "color.h"
108@@ -115,7 +115,7 @@ prop_dialog_new (void)
109
110 /* === Global settings === */
111 box = gtk_vbox_new (FALSE, BORDER);
112- frame = xfce_create_framebox_with_content (_("Global settings"), box);
113+ frame = xfce_gtk_frame_box_new_with_content (_("Global settings"), box);
114 gtk_container_set_border_width (GTK_CONTAINER (frame), BORDER);
115 gtk_container_add (GTK_CONTAINER (vbox), frame);
116
117@@ -163,7 +163,7 @@ prop_dialog_new (void)
118
119 /* === New window settings === */
120 box = gtk_vbox_new (FALSE, BORDER);
121- frame = xfce_create_framebox_with_content (_("New group settings"), box);
122+ frame = xfce_gtk_frame_box_new_with_content (_("New group settings"), box);
123 gtk_container_set_border_width (GTK_CONTAINER (frame), BORDER);
124 gtk_container_add (GTK_CONTAINER (vbox), frame);
125
126--
1271.8.3.1
128
diff --git a/meta-xfce/recipes-panel-plugins/notes/files/0002-main-status-icon.c-remove-deprecated-g_type_init.patch b/meta-xfce/recipes-panel-plugins/notes/files/0002-main-status-icon.c-remove-deprecated-g_type_init.patch
new file mode 100644
index 000000000..e1ede27c4
--- /dev/null
+++ b/meta-xfce/recipes-panel-plugins/notes/files/0002-main-status-icon.c-remove-deprecated-g_type_init.patch
@@ -0,0 +1,32 @@
1From 0218e5ebf38f94d58b908fca451ba3789efa8899 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Fri, 20 Sep 2013 23:09:25 +0200
4Subject: [PATCH] main-status-icon.c remove deprecated g_type_init
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9this file was auto created by valac and xfce-vala when creating tarball. So
10
11Upstream-Status: Inappropriate [other]
12
13Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
14---
15 src/main-status-icon.c | 1 -
16 1 file changed, 1 deletion(-)
17
18diff --git a/src/main-status-icon.c b/src/main-status-icon.c
19index c6d73f8..f7db773 100644
20--- a/src/main-status-icon.c
21+++ b/src/main-status-icon.c
22@@ -290,7 +290,6 @@ gint _vala_main (char** args, int args_length1) {
23
24
25 int main (int argc, char ** argv) {
26- g_type_init ();
27 return _vala_main (argv, argc);
28 }
29
30--
311.8.3.1
32
diff --git a/meta-xfce/recipes-panel-plugins/notes/xfce4-notes-plugin_1.7.7.bb b/meta-xfce/recipes-panel-plugins/notes/xfce4-notes-plugin_1.7.7.bb
new file mode 100644
index 000000000..b97bc24da
--- /dev/null
+++ b/meta-xfce/recipes-panel-plugins/notes/xfce4-notes-plugin_1.7.7.bb
@@ -0,0 +1,20 @@
1DESCRIPTION = "Notes plugin for the Xfce Panel"
2HOMEPAGE = "http://goodies.xfce.org/projects/panel-plugins/xfce4-notes-plugin"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
5
6inherit xfce-panel-plugin
7
8DEPENDS = "gtk+ libxfce4ui xfce4-panel xfconf libunique"
9
10SRC_URI += " \
11 file://0001-Bump-dependency-to-Xfce-4.10.patch \
12 file://0002-main-status-icon.c-remove-deprecated-g_type_init.patch \
13"
14SRC_URI[md5sum] = "42b924b23f2fec6a1099e9b7a87db4a3"
15SRC_URI[sha256sum] = "a7baa105b37ad05dea4d6b55d98fd3214c77ad5c7a0e91471d4906c81e5f5217"
16
17FILES_${PN} += "${libdir}/xfce4/panel-plugins/*.so.*"
18
19# *.so are required for plugin detection
20INSANE_SKIP_${PN} = "dev-so"