summaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2013-09-16 09:04:17 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-09-19 13:56:57 +0200
commit1a37464df56fc660c8592f44cdc15f7304fca769 (patch)
treeabdbbad6a2f637e387bafb57f4f384aeaabfec52 /meta-xfce
parent243b67457a142aa0ba1111ff7163098434927a7e (diff)
downloadmeta-openembedded-1a37464df56fc660c8592f44cdc15f7304fca769.tar.gz
xfce4-weather-plugin: update to 0.8.3
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-panel-plugins/weather/files/port-to-libxfce4ui.patch104
-rw-r--r--meta-xfce/recipes-panel-plugins/weather/xfce4-weather-plugin_0.7.4.bb23
-rw-r--r--meta-xfce/recipes-panel-plugins/weather/xfce4-weather-plugin_0.8.3.bb11
3 files changed, 11 insertions, 127 deletions
diff --git a/meta-xfce/recipes-panel-plugins/weather/files/port-to-libxfce4ui.patch b/meta-xfce/recipes-panel-plugins/weather/files/port-to-libxfce4ui.patch
deleted file mode 100644
index 968d84fc8..000000000
--- a/meta-xfce/recipes-panel-plugins/weather/files/port-to-libxfce4ui.patch
+++ /dev/null
@@ -1,104 +0,0 @@
1From 24da1964f72429b0b4d20e0805cbd8346179527f Mon Sep 17 00:00:00 2001
2From: Matias De lellis <mati86dl@gmail.com>
3Date: Mon, 5 Sep 2011 14:17:29 -0300
4Subject: [PATCH] Port xfce4-weather-plugin to libxfce4ui
5
6---
7 configure.ac | 2 +-
8 panel-plugin/Makefile.am | 4 ++--
9 panel-plugin/weather-config.c | 2 +-
10 panel-plugin/weather-search.c | 2 +-
11 panel-plugin/weather-summary.c | 2 +-
12 panel-plugin/weather.c | 2 +-
13 6 files changed, 7 insertions(+), 7 deletions(-)
14
15diff --git a/configure.ac b/configure.ac
16index 04f466a..d1bb58e 100644
17--- a/configure.ac
18+++ b/configure.ac
19@@ -59,7 +59,7 @@ dnl ***********************************
20 XDT_CHECK_PACKAGE([GTK], [gtk+-2.0], [2.6.0])
21 XDT_CHECK_PACKAGE([GTHREAD], [gthread-2.0], [2.6.0])
22 XDT_CHECK_PACKAGE([LIBXFCE4UTIL], [libxfce4util-1.0], [4.3.90.2])
23-XDT_CHECK_PACKAGE([LIBXFCEGUI4], [libxfcegui4-1.0], [4.3.90.2])
24+XDT_CHECK_PACKAGE([LIBXFCE4UI], [libxfce4ui-1], [4.7.0])
25 XDT_CHECK_PACKAGE([LIBXFCE4PANEL], [libxfce4panel-1.0], [4.3.99.1])
26 XDT_CHECK_PACKAGE([LIBXML], [libxml-2.0], [2.4.0])
27
28diff --git a/panel-plugin/Makefile.am b/panel-plugin/Makefile.am
29index 50fc962..ed06da1 100644
30--- a/panel-plugin/Makefile.am
31+++ b/panel-plugin/Makefile.am
32@@ -33,7 +33,7 @@ xfce4_weather_plugin_SOURCES = \
33
34 xfce4_weather_plugin_CFLAGS = \
35 $(LIBXFCE4PANEL_CFLAGS) \
36- $(LIBXFCEGUI4_CFLAGS) \
37+ $(LIBXFCE4UI_CFLAGS) \
38 $(LIBXFCE4UTIL_CFLAGS) \
39 $(GTK_CFLAGS) \
40 $(LIBXML_CFLAGS)
41@@ -41,7 +41,7 @@ xfce4_weather_plugin_CFLAGS = \
42 xfce4_weather_plugin_LDADD = \
43 $(LIBXFCE4PANEL_LIBS) \
44 $(LIBXFCE4UTIL_LIBS) \
45- $(LIBXFCEGUI4_LIBS) \
46+ $(LIBXFCE4UI_LIBS) \
47 $(GTK_LIBS) \
48 $(LIBXML_LIBS) \
49 $(LIBRESOLV)
50diff --git a/panel-plugin/weather-config.c b/panel-plugin/weather-config.c
51index 3023e11..d183e75 100644
52--- a/panel-plugin/weather-config.c
53+++ b/panel-plugin/weather-config.c
54@@ -20,7 +20,7 @@
55 #endif
56
57 #include <string.h>
58-#include <libxfcegui4/libxfcegui4.h>
59+#include <libxfce4ui/libxfce4ui.h>
60
61 #include "weather-parsers.h"
62 #include "weather-data.h"
63diff --git a/panel-plugin/weather-search.c b/panel-plugin/weather-search.c
64index c43ad15..dba395f 100644
65--- a/panel-plugin/weather-search.c
66+++ b/panel-plugin/weather-search.c
67@@ -21,7 +21,7 @@
68
69 #include <string.h>
70
71-#include <libxfcegui4/libxfcegui4.h>
72+#include <libxfce4ui/libxfce4ui.h>
73
74 #include "weather-parsers.h"
75 #include "weather-data.h"
76diff --git a/panel-plugin/weather-summary.c b/panel-plugin/weather-summary.c
77index 36eeb14..b584c7d 100644
78--- a/panel-plugin/weather-summary.c
79+++ b/panel-plugin/weather-summary.c
80@@ -19,7 +19,7 @@
81 #include <config.h>
82 #endif
83
84-#include <libxfcegui4/libxfcegui4.h>
85+#include <libxfce4ui/libxfce4ui.h>
86
87 #include "weather-parsers.h"
88 #include "weather-data.h"
89diff --git a/panel-plugin/weather.c b/panel-plugin/weather.c
90index cd341aa..c6c918d 100644
91--- a/panel-plugin/weather.c
92+++ b/panel-plugin/weather.c
93@@ -23,7 +23,7 @@
94 #include <sys/stat.h>
95
96 #include <libxfce4util/libxfce4util.h>
97-#include <libxfcegui4/libxfcegui4.h>
98+#include <libxfce4ui/libxfce4ui.h>
99
100 #include "weather-parsers.h"
101 #include "weather-data.h"
102--
1031.7.6
104
diff --git a/meta-xfce/recipes-panel-plugins/weather/xfce4-weather-plugin_0.7.4.bb b/meta-xfce/recipes-panel-plugins/weather/xfce4-weather-plugin_0.7.4.bb
deleted file mode 100644
index 68307a8ee..000000000
--- a/meta-xfce/recipes-panel-plugins/weather/xfce4-weather-plugin_0.7.4.bb
+++ /dev/null
@@ -1,23 +0,0 @@
1DESCRIPTION = "Panel plugin to display current temperature and weather condition"
2HOMEPAGE = "http://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
5PR = "r1"
6
7inherit xfce-panel-plugin
8
9SRC_URI += "file://port-to-libxfce4ui.patch"
10SRC_URI[md5sum] = "03c972d13eba5cd226432ff66e3ff282"
11SRC_URI[sha256sum] = "3f76207b8a845d15bfec6825bd5300aedd086c455259c4dd8670a89a3c8ab382"
12
13do_compile_prepend() {
14 # Switch to a working license key
15 # https://bugs.archlinux.org/task/26815
16 sed -i \
17 -e 's/^#define PARTNER_ID.*/#define PARTNER_ID "1003666583"/' \
18 -e 's/^#define LICENSE_KEY.*/#define LICENSE_KEY "4128909340a9b2fc"/' \
19 ${S}/panel-plugin/weather.h
20
21}
22
23FILES_${PN} += "${datadir}/xfce4/weather"
diff --git a/meta-xfce/recipes-panel-plugins/weather/xfce4-weather-plugin_0.8.3.bb b/meta-xfce/recipes-panel-plugins/weather/xfce4-weather-plugin_0.8.3.bb
new file mode 100644
index 000000000..551faab38
--- /dev/null
+++ b/meta-xfce/recipes-panel-plugins/weather/xfce4-weather-plugin_0.8.3.bb
@@ -0,0 +1,11 @@
1DESCRIPTION = "Panel plugin to display current temperature and weather condition"
2HOMEPAGE = "http://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5
6inherit xfce-panel-plugin
7
8SRC_URI[md5sum] = "755b33089c02afe88abb39253003a7f3"
9SRC_URI[sha256sum] = "40a6a22be7653b15a47174a430da89040f178695b48e5e01e77990050f715ce4"
10
11FILES_${PN} += "${datadir}/xfce4/weather"