summaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorAndreas Mueller <schnitzeltony@gmx.de>2011-08-01 17:16:29 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-08-05 19:49:58 +0200
commitf539027f6ac9a3e6fc1d86a26f347a42b4f359e4 (patch)
tree8643d0ded1e18098bd816cd622131d1aba002ac0 /meta-xfce
parent3fe0ebd466950f23b7e4b99863ab075f73411a49 (diff)
downloadmeta-openembedded-f539027f6ac9a3e6fc1d86a26f347a42b4f359e4.tar.gz
exo: Add initial recipe with version 0.6.2
* python bindings removed here (will be moved to pyxfce mainline [1]) * TBD: gnomemount replacement on postinst [2] [1] http://comments.gmane.org/gmane.comp.desktop.xfce.devel.version4/19560 [2] http://wiki.xfce.org/gnomemount-replacement
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-xfce/exo/exo/configure.patch43
-rw-r--r--meta-xfce/recipes-xfce/exo/exo/exo-no-tests-0.6.patch12
-rw-r--r--meta-xfce/recipes-xfce/exo/exo/fix-qa-desktop-type-error.patch531
-rw-r--r--meta-xfce/recipes-xfce/exo/exo/gnome-mount64
-rw-r--r--meta-xfce/recipes-xfce/exo/exo_0.6.2.bb36
5 files changed, 686 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/exo/exo/configure.patch b/meta-xfce/recipes-xfce/exo/exo/configure.patch
new file mode 100644
index 000000000..2ccfcfc99
--- /dev/null
+++ b/meta-xfce/recipes-xfce/exo/exo/configure.patch
@@ -0,0 +1,43 @@
1--- exo-0.3.4/configure.in~ 2007-12-02 10:37:06.000000000 -0200
2+++ exo-0.3.4/configure.in 2008-06-05 17:21:42.000000000 -0300
3@@ -127,22 +127,24 @@
4 dnl ***************************************
5 dnl *** Check for strftime() extensions ***
6 dnl ***************************************
7-AC_TRY_RUN([
8- #include <string.h>
9- #include <time.h>
10- int
11- main (int argc, char **argv)
12- {
13- struct tm tm;
14- char buffer[16];
15- tm.tm_year = 81;
16- if (strftime (buffer, 16, "%EY", &tm) == 4 && strcmp (buffer, "1981") == 0)
17- return 0;
18- return 1;
19- }
20-], [
21- AC_DEFINE([HAVE_STRFTIME_EXTENSION], 1, [Define if strftime supports %E and %O modifiers.])
22-])
23+dnl grrrr... this doesn't work for cross compiling, define it for OE
24+AC_DEFINE([HAVE_STRFTIME_EXTENSION], 1, [Define if strftime supports %E and %O modifiers.])
25+dnl AC_TRY_RUN([
26+dnl #include <string.h>
27+dnl #include <time.h>
28+dnl int
29+dnl main (int argc, char **argv)
30+dnl {
31+dnl struct tm tm;
32+dnl char buffer[16];
33+dnl tm.tm_year = 81;
34+dnl if (strftime (buffer, 16, "%EY", &tm) == 4 && strcmp (buffer, "1981") == 0)
35+dnl return 0;
36+dnl return 1;
37+dnl }
38+dnl ], [
39+dnl AC_DEFINE([HAVE_STRFTIME_EXTENSION], 1, [Define if strftime supports %E and %O modifiers.])
40+dnl ])
41
42 dnl ******************************
43 dnl *** Check for i18n support ***
diff --git a/meta-xfce/recipes-xfce/exo/exo/exo-no-tests-0.6.patch b/meta-xfce/recipes-xfce/exo/exo/exo-no-tests-0.6.patch
new file mode 100644
index 000000000..cab41a87d
--- /dev/null
+++ b/meta-xfce/recipes-xfce/exo/exo/exo-no-tests-0.6.patch
@@ -0,0 +1,12 @@
1--- a/Makefile.am.old 2011-01-16 16:38:21.000000000 +0100
2+++ b/Makefile.am 2011-03-24 22:14:26.000000000 +0100
3@@ -15,8 +15,7 @@
4 icons \
5 pixmaps \
6 po \
7- $(PYTHON_SUBDIR) \
8- tests
9+ $(PYTHON_SUBDIR)
10
11 AUTOMAKE_OPTIONS = \
12 1.8 \
diff --git a/meta-xfce/recipes-xfce/exo/exo/fix-qa-desktop-type-error.patch b/meta-xfce/recipes-xfce/exo/exo/fix-qa-desktop-type-error.patch
new file mode 100644
index 000000000..e4ba75ed7
--- /dev/null
+++ b/meta-xfce/recipes-xfce/exo/exo/fix-qa-desktop-type-error.patch
@@ -0,0 +1,531 @@
1--- a/exo-helper/exo-helper.c.old 2011-01-16 16:38:21.000000000 +0100
2+++ b/exo-helper/exo-helper.c 2011-03-07 12:31:49.000000000 +0100
3@@ -172,7 +172,7 @@
4 helper->startup_notify = xfce_rc_read_bool_entry (rc, "StartupNotify", FALSE);
5
6 /* verify the type of the desktop file */
7- str = xfce_rc_read_entry_untranslated (rc, "Type", NULL);
8+ str = xfce_rc_read_entry_untranslated (rc, "X-XFCE-Type", NULL);
9 if (G_UNLIKELY (!exo_str_is_equal (str, "X-XFCE-Helper")))
10 goto failed;
11
12@@ -897,7 +897,8 @@
13 xfce_rc_write_bool_entry (rc, "NoDisplay", TRUE);
14 xfce_rc_write_entry (rc, "Version", "1.0");
15 xfce_rc_write_entry (rc, "Encoding", "UTF-8");
16- xfce_rc_write_entry (rc, "Type", "X-XFCE-Helper");
17+ xfce_rc_write_entry (rc, "Type", "Application");
18+ xfce_rc_write_entry (rc, "X-XFCE-Type", "X-XFCE-Helper");
19 xfce_rc_write_entry (rc, "X-XFCE-Category", category_string);
20
21 /* check if the command includes a parameter */
22--- a/exo-helper/helpers/aterm.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
23+++ b/exo-helper/helpers/aterm.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
24@@ -1,10 +1,11 @@
25 [Desktop Entry]
26 Version=1.0
27 Icon=aterm
28-Type=X-XFCE-Helper
29+Type=Application
30 _Name=aterm
31 StartupNotify=false
32 X-XFCE-Binaries=aterm;
33 X-XFCE-Category=TerminalEmulator
34 X-XFCE-Commands=%B;
35 X-XFCE-CommandsWithParameter=%B -e %s;
36+X-XFCE-Type=X-XFCE-Helper
37--- a/exo-helper/helpers/balsa.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
38+++ b/exo-helper/helpers/balsa.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
39@@ -1,10 +1,11 @@
40 [Desktop Entry]
41 Version=1.0
42 Icon=gnome-balsa2
43-Type=X-XFCE-Helper
44+Type=Application
45 _Name=Balsa
46 StartupNotify=false
47 X-XFCE-Binaries=balsa;
48 X-XFCE-Category=MailReader
49 X-XFCE-Commands=%B;
50 X-XFCE-CommandsWithParameter=@HELPERDIR@/exo-compose-mail-1 balsa %B "mailto:%s";
51+X-XFCE-Type=X-XFCE-Helper
52--- a/exo-helper/helpers/debian-sensible-browser.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
53+++ b/exo-helper/helpers/debian-sensible-browser.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
54@@ -1,10 +1,11 @@
55 [Desktop Entry]
56 Version=1.0
57 Icon=debian
58-Type=X-XFCE-Helper
59+Type=Application
60 _Name=Debian Sensible Browser
61 StartupNotify=false
62 X-XFCE-Binaries=sensible-browser;
63 X-XFCE-Category=WebBrowser
64 X-XFCE-Commands=%B;
65 X-XFCE-CommandsWithParameter=%B "%s";
66+X-XFCE-Type=X-XFCE-Helper
67--- a/exo-helper/helpers/debian-x-terminal-emulator.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
68+++ b/exo-helper/helpers/debian-x-terminal-emulator.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
69@@ -1,10 +1,11 @@
70 [Desktop Entry]
71 Version=1.0
72 Icon=debian
73-Type=X-XFCE-Helper
74+Type=Application
75 _Name=Debian X Terminal Emulator
76 StartupNotify=false
77 X-XFCE-Binaries=x-terminal-emulator;
78 X-XFCE-Category=TerminalEmulator
79 X-XFCE-Commands=%B;
80 X-XFCE-CommandsWithParameter=%B -e %s;
81+X-XFCE-Type=X-XFCE-Helper
82--- a/exo-helper/helpers/encompass.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
83+++ b/exo-helper/helpers/encompass.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
84@@ -1,10 +1,11 @@
85 [Desktop Entry]
86 Version=1.0
87 Icon=encompass
88-Type=X-XFCE-Helper
89+Type=Application
90 _Name=Encompass
91 StartupNotify=true
92 X-XFCE-Binaries=encompass;
93 X-XFCE-Category=WebBrowser
94 X-XFCE-Commands=%B;
95 X-XFCE-CommandsWithParameter=%B "%s";
96+X-XFCE-Type=X-XFCE-Helper
97--- a/exo-helper/helpers/epiphany.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
98+++ b/exo-helper/helpers/epiphany.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
99@@ -1,10 +1,11 @@
100 [Desktop Entry]
101 Version=1.0
102 Icon=web-browser
103-Type=X-XFCE-Helper
104+Type=Application
105 _Name=Epiphany Web Browser
106 StartupNotify=true
107 X-XFCE-Binaries=epiphany;
108 X-XFCE-Category=WebBrowser
109 X-XFCE-Commands=%B;
110 X-XFCE-CommandsWithParameter=%B "%s";
111+X-XFCE-Type=X-XFCE-Helper
112--- a/exo-helper/helpers/eterm.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
113+++ b/exo-helper/helpers/eterm.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
114@@ -1,10 +1,11 @@
115 [Desktop Entry]
116 Version=1.0
117 Icon=Eterm
118-Type=X-XFCE-Helper
119+Type=Application
120 _Name=Enlightened Terminal Emulator
121 StartupNotify=false
122 X-XFCE-Binaries=Eterm;
123 X-XFCE-Category=TerminalEmulator
124 X-XFCE-Commands=%B;
125 X-XFCE-CommandsWithParameter=%B --exec "%s";
126+X-XFCE-Type=X-XFCE-Helper
127--- a/exo-helper/helpers/evolution.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
128+++ b/exo-helper/helpers/evolution.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
129@@ -1,10 +1,11 @@
130 [Desktop Entry]
131 Version=1.0
132 Icon=evolution
133-Type=X-XFCE-Helper
134+Type=Application
135 _Name=Novell Evolution
136 StartupNotify=false
137 X-XFCE-Binaries=evolution-2.4;evolution-2.3;evolution-2.2;evolution-2.0;evolution-1.6;evolution-1.5;evolution-1.4;evolution;
138 X-XFCE-Category=MailReader
139 X-XFCE-Commands=%B;
140 X-XFCE-CommandsWithParameter=@HELPERDIR@/exo-compose-mail-1 evolution %B "mailto:%s";
141+X-XFCE-Type=X-XFCE-Helper
142--- a/exo-helper/helpers/firefox.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
143+++ b/exo-helper/helpers/firefox.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
144@@ -1,10 +1,11 @@
145 [Desktop Entry]
146 Version=1.0
147 Icon=firefox
148-Type=X-XFCE-Helper
149+Type=Application
150 _Name=Mozilla Firefox
151 StartupNotify=false
152 X-XFCE-Binaries=firefox;firefox-gtk2;firefox-gtk;mozilla-firefox;
153 X-XFCE-Category=WebBrowser
154 X-XFCE-Commands=%B -remote "openURL(about:blank,new-window)";%B;
155 X-XFCE-CommandsWithParameter=%B -remote "openURL(%s)";%B %s;
156+X-XFCE-Type=X-XFCE-Helper
157--- a/exo-helper/helpers/galeon.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
158+++ b/exo-helper/helpers/galeon.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
159@@ -1,10 +1,11 @@
160 [Desktop Entry]
161 Version=1.0
162 Icon=galeon
163-Type=X-XFCE-Helper
164+Type=Application
165 _Name=Galeon Web Browser
166 StartupNotify=true
167 X-XFCE-Binaries=galeon;
168 X-XFCE-Category=WebBrowser
169 X-XFCE-Commands=%B;
170 X-XFCE-CommandsWithParameter=%B "%s";
171+X-XFCE-Type=X-XFCE-Helper
172--- a/exo-helper/helpers/gnome-terminal.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
173+++ b/exo-helper/helpers/gnome-terminal.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
174@@ -1,10 +1,11 @@
175 [Desktop Entry]
176 Version=1.0
177 Icon=gnome-terminal
178-Type=X-XFCE-Helper
179+Type=Application
180 _Name=GNOME Terminal
181 StartupNotify=true
182 X-XFCE-Binaries=gnome-terminal;gnometerminal;
183 X-XFCE-Category=TerminalEmulator
184 X-XFCE-Commands=%B;
185 X-XFCE-CommandsWithParameter=%B -x %s;
186+X-XFCE-Type=X-XFCE-Helper
187--- a/exo-helper/helpers/icedove.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
188+++ b/exo-helper/helpers/icedove.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
189@@ -1,10 +1,11 @@
190 [Desktop Entry]
191 Version=1.0
192 Icon=icedove
193-Type=X-XFCE-Helper
194+Type=Application
195 _Name=Icedove
196 StartupNotify=false
197 X-XFCE-Binaries=icedove;
198 X-XFCE-Category=MailReader
199 X-XFCE-Commands=%B;
200 X-XFCE-CommandsWithParameter=@HELPERDIR@/exo-compose-mail-1 mozilla-remote %B "mailto:%s";@HELPERDIR@/exo-compose-mail-1 mozilla %B "mailto:%s";
201+X-XFCE-Type=X-XFCE-Helper
202--- a/exo-helper/helpers/kmail.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
203+++ b/exo-helper/helpers/kmail.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
204@@ -1,10 +1,11 @@
205 [Desktop Entry]
206 Version=1.0
207 Icon=kmail
208-Type=X-XFCE-Helper
209+Type=Application
210 _Name=KMail
211 StartupNotify=true
212 X-XFCE-Binaries=kmail;
213 X-XFCE-Category=MailReader
214 X-XFCE-Commands=%B;
215 X-XFCE-CommandsWithParamter=@HELPERDIR@/exo-compose-mail-1 kmail %B "mailto:%s";
216+X-XFCE-Type=X-XFCE-Helper
217--- a/exo-helper/helpers/konqueror.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
218+++ b/exo-helper/helpers/konqueror.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
219@@ -1,10 +1,11 @@
220 [Desktop Entry]
221 Version=1.0
222 Icon=konqueror
223-Type=X-XFCE-Helper
224+Type=Application
225 _Name=Konqueror Web Browser
226 StartupNotify=true
227 X-XFCE-Binaries=konqueror;
228 X-XFCE-Category=WebBrowser
229 X-XFCE-Commands=%B;
230 X-XFCE-CommandsWithParameter=%B "%s";
231+X-XFCE-Type=X-XFCE-Helper
232--- a/exo-helper/helpers/links.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
233+++ b/exo-helper/helpers/links.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
234@@ -1,10 +1,11 @@
235 [Desktop Entry]
236 Version=1.0
237 Icon=links
238-Type=X-XFCE-Helper
239+Type=Application
240 _Name=Links Text Browser
241 StartupNotify=false
242 X-XFCE-Binaries=links;links-current;
243 X-XFCE-Category=WebBrowser
244 X-XFCE-Commands=exo-open --launch TerminalEmulator %B;
245 X-XFCE-CommandsWithParameter=exo-open --launch TerminalEmulator %B %s;
246+X-XFCE-Type=X-XFCE-Helper
247--- a/exo-helper/helpers/lynx.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
248+++ b/exo-helper/helpers/lynx.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
249@@ -1,10 +1,11 @@
250 [Desktop Entry]
251 Version=1.0
252 Icon=aterm
253-Type=X-XFCE-Helper
254+Type=Application
255 _Name=Lynx Text Browser
256 StartupNotify=false
257 X-XFCE-Binaries=lynx;lynx-current;
258 X-XFCE-Category=WebBrowser
259 X-XFCE-Commands=exo-open --launch TerminalEmulator %B;
260 X-XFCE-CommandsWithParameter=exo-open --launch TerminalEmulator %B %s;
261+X-XFCE-Type=X-XFCE-Helper
262--- a/exo-helper/helpers/midori.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
263+++ b/exo-helper/helpers/midori.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
264@@ -2,10 +2,11 @@
265 [Desktop Entry]
266 Version=1.0
267 Icon=midori
268-Type=X-XFCE-Helper
269+Type=Application
270 _Name=Midori
271 StartupNotify=true
272 X-XFCE-Binaries=midori;
273 X-XFCE-Category=WebBrowser
274 X-XFCE-Commands=%B;
275 X-XFCE-CommandsWithParameter=%B "%s";
276+X-XFCE-Type=X-XFCE-Helper
277--- a/exo-helper/helpers/mozilla-browser.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
278+++ b/exo-helper/helpers/mozilla-browser.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
279@@ -1,10 +1,11 @@
280 [Desktop Entry]
281 Version=1.0
282 Icon=mozilla
283-Type=X-XFCE-Helper
284+Type=Application
285 _Name=Mozilla Browser
286 StartupNotify=false
287 X-XFCE-Binaries=mozilla;mozilla-gtk2;mozilla-gtk;
288 X-XFCE-Category=WebBrowser
289 X-XFCE-Commands=%B -remote "openURL(about:blank,new-window)";%B;
290 X-XFCE-CommandsWithParameter=%B -remote "openURL(%s,new-window)";%B %s;
291+X-XFCE-Type=X-XFCE-Helper
292--- a/exo-helper/helpers/mozilla-mailer.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
293+++ b/exo-helper/helpers/mozilla-mailer.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
294@@ -1,10 +1,11 @@
295 [Desktop Entry]
296 Version=1.0
297 Icon=mozilla
298-Type=X-XFCE-Helper
299+Type=Application
300 _Name=Mozilla Mail
301 StartupNotify=false
302 X-XFCE-Binaries=mozilla;mozilla-gtk2;mozilla-gtk;
303 X-XFCE-Category=MailReader
304 X-XFCE-Commands=%B -mail;
305 X-XFCE-CommandsWithParameter=@HELPERDIR@/exo-compose-mail-1 mozilla-remote %B "mailto:%s";@HELPERDIR@/exo-compose-mail-1 mozilla %B "mailto:%s";
306+X-XFCE-Type=X-XFCE-Helper
307--- a/exo-helper/helpers/mutt.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
308+++ b/exo-helper/helpers/mutt.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
309@@ -1,10 +1,11 @@
310 [Desktop Entry]
311 Version=1.0
312 Icon=mutt
313-Type=X-XFCE-Helper
314+Type=Application
315 _Name=Mutt
316 StartupNotify=false
317 X-XFCE-Binaries=mutt;
318 X-XFCE-Category=MailReader
319 X-XFCE-Commands=exo-open --launch TerminalEmulator %B;
320 X-XFCE-CommandsWithParameter=exo-open --launch TerminalEmulator @HELPERDIR@/exo-compose-mail-1 mutt %B "mailto:%s";
321+X-XFCE-Type=X-XFCE-Helper
322--- a/exo-helper/helpers/nautilus.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
323+++ b/exo-helper/helpers/nautilus.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
324@@ -2,10 +2,11 @@
325 [Desktop Entry]
326 Version=1.0
327 Icon=nautilus
328-Type=X-XFCE-Helper
329+Type=Application
330 _Name=Nautilus
331 StartupNotify=true
332 X-XFCE-Binaries=nautilus;
333 X-XFCE-Category=FileManager
334 X-XFCE-Commands=%B;
335 X-XFCE-CommandsWithParameter=%B "%s";
336+X-XFCE-Type=X-XFCE-Helper
337--- a/exo-helper/helpers/netscape-navigator.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
338+++ b/exo-helper/helpers/netscape-navigator.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
339@@ -1,10 +1,11 @@
340 [Desktop Entry]
341 Version=1.0
342 Icon=mozilla
343-Type=X-XFCE-Helper
344+Type=Application
345 _Name=Netscape Navigator
346 StartupNotify=false
347 X-XFCE-Binaries=netscape;
348 X-XFCE-Category=WebBrowser
349 X-XFCE-Commands=%B -remote "openURL(about:blank,new-window)";%B;
350 X-XFCE-CommandsWithParameter=%B -remote "openURL(%s,new-window)";%B %s;
351+X-XFCE-Type=X-XFCE-Helper
352--- a/exo-helper/helpers/nxterm.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
353+++ b/exo-helper/helpers/nxterm.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
354@@ -1,10 +1,11 @@
355 [Desktop Entry]
356 Version=1.0
357 Icon=nxterm
358-Type=X-XFCE-Helper
359+Type=Application
360 _Name=NXterm
361 StartupNotify=false
362 X-XFCE-Binaries=nxterm;
363 X-XFCE-Category=TerminalEmulator
364 X-XFCE-Commands=%B;
365 X-XFCE-CommandsWithParameter=%B -e %s;
366+X-XFCE-Type=X-XFCE-Helper
367--- a/exo-helper/helpers/opera-browser.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
368+++ b/exo-helper/helpers/opera-browser.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
369@@ -1,10 +1,11 @@
370 [Desktop Entry]
371 Version=1.0
372 Icon=opera
373-Type=X-XFCE-Helper
374+Type=Application
375 _Name=Opera Browser
376 StartupNotify=false
377 X-XFCE-Binaries=opera;
378 X-XFCE-Category=WebBrowser
379 X-XFCE-Commands=%B;
380 X-XFCE-CommandsWithParameter=%B "%s";
381+X-XFCE-Type=X-XFCE-Helper
382--- a/exo-helper/helpers/opera-mailer.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
383+++ b/exo-helper/helpers/opera-mailer.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
384@@ -1,10 +1,11 @@
385 [Desktop Entry]
386 Version=1.0
387 Icon=opera
388-Type=X-XFCE-Helper
389+Type=Application
390 _Name=Opera Mail
391 StartupNotify=false
392 X-XFCE-Binaries=opera;
393 X-XFCE-Category=MailReader
394 X-XFCE-Commands=%B;
395 X-XFCE-CommandsWithParameter=%B -remote "openURL(mailto:%s)";%B "mailto:%s";
396+X-XFCE-Type=X-XFCE-Helper
397--- a/exo-helper/helpers/pcmanfm.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
398+++ b/exo-helper/helpers/pcmanfm.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
399@@ -2,10 +2,11 @@
400 [Desktop Entry]
401 Version=1.0
402 Icon=pcmanfm
403-Type=X-XFCE-Helper
404+Type=Application
405 _Name=PCMan File Manager
406 StartupNotify=true
407 X-XFCE-Binaries=pcmanfm;
408 X-XFCE-Category=FileManager
409 X-XFCE-Commands=%B;
410 X-XFCE-CommandsWithParameter=%B "%s";
411+X-XFCE-Type=X-XFCE-Helper
412--- a/exo-helper/helpers/sylpheed-claws.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
413+++ b/exo-helper/helpers/sylpheed-claws.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
414@@ -1,10 +1,11 @@
415 [Desktop Entry]
416 Version=1.0
417 Icon=claws-mail
418-Type=X-XFCE-Helper
419+Type=Application
420 _Name=Claws Mail
421 StartupNotify=true
422 X-XFCE-Binaries=claws-mail;sylpheed-claws-gtk2;sylpheed-claws
423 X-XFCE-Category=MailReader
424 X-XFCE-Commands=%B;
425 X-XFCE-CommandsWithParameter=@HELPERDIR@/exo-compose-mail-1 sylpheed %B "mailto:%s";
426+X-XFCE-Type=X-XFCE-Helper
427--- a/exo-helper/helpers/sylpheed.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
428+++ b/exo-helper/helpers/sylpheed.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
429@@ -1,10 +1,11 @@
430 [Desktop Entry]
431 Version=1.0
432 Icon=sylpheed
433-Type=X-XFCE-Helper
434+Type=Application
435 _Name=Sylpheed
436 StartupNotify=true
437 X-XFCE-Binaries=sylpheed;
438 X-XFCE-Category=MailReader
439 X-XFCE-Commands=%B;
440 X-XFCE-CommandsWithParameter=@HELPERDIR@/exo-compose-mail-1 sylpheed %B "mailto:%s";
441+X-XFCE-Type=X-XFCE-Helper
442--- a/exo-helper/helpers/Terminal.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
443+++ b/exo-helper/helpers/Terminal.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
444@@ -1,10 +1,11 @@
445 [Desktop Entry]
446 Version=1.0
447 Icon=Terminal
448-Type=X-XFCE-Helper
449+Type=Application
450 _Name=Xfce Terminal
451 StartupNotify=true
452 X-XFCE-Binaries=Terminal;xterminal;xfce4-terminal;
453 X-XFCE-Category=TerminalEmulator
454 X-XFCE-Commands=%B;
455 X-XFCE-CommandsWithParameter=%B -x %s;
456+X-XFCE-Type=X-XFCE-Helper
457--- a/exo-helper/helpers/Thunar.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
458+++ b/exo-helper/helpers/Thunar.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
459@@ -2,10 +2,11 @@
460 [Desktop Entry]
461 Version=1.0
462 Icon=Thunar
463-Type=X-XFCE-Helper
464+Type=Application
465 _Name=Thunar
466 StartupNotify=true
467 X-XFCE-Binaries=Thunar;
468 X-XFCE-Category=FileManager
469 X-XFCE-Commands=%B;
470 X-XFCE-CommandsWithParameter=%B "%s";
471+X-XFCE-Type=X-XFCE-Helper
472--- a/exo-helper/helpers/thunderbird.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
473+++ b/exo-helper/helpers/thunderbird.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
474@@ -1,10 +1,11 @@
475 [Desktop Entry]
476 Version=1.0
477 Icon=thunderbird
478-Type=X-XFCE-Helper
479+Type=Application
480 _Name=Mozilla Thunderbird
481 StartupNotify=false
482 X-XFCE-Binaries=thunderbird;thunderbird-gtk2;thunderbird-gtk;mozilla-thunderbird;
483 X-XFCE-Category=MailReader
484 X-XFCE-Commands=%B;
485 X-XFCE-CommandsWithParameter=@HELPERDIR@/exo-compose-mail-1 mozilla-remote %B "mailto:%s";@HELPERDIR@/exo-compose-mail-1 mozilla %B "mailto:%s";
486+X-XFCE-Type=X-XFCE-Helper
487--- a/exo-helper/helpers/urxvt.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
488+++ b/exo-helper/helpers/urxvt.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
489@@ -1,10 +1,11 @@
490 [Desktop Entry]
491 Version=1.0
492 Icon=rxvt
493-Type=X-XFCE-Helper
494+Type=Application
495 _Name=RXVT Unicode
496 StartupNotify=false
497 X-XFCE-Binaries=urxvt;
498 X-XFCE-Category=TerminalEmulator
499 X-XFCE-Commands=%B;
500 X-XFCE-CommandsWithParameter=%B -e %s;
501+X-XFCE-Type=X-XFCE-Helper
502--- a/exo-helper/helpers/w3m.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
503+++ b/exo-helper/helpers/w3m.desktop.in.in 2011-03-07 12:08:30.000000000 +0100
504@@ -1,10 +1,11 @@
505 [Desktop Entry]
506 Version=1.0
507 Icon=w3m
508-Type=X-XFCE-Helper
509+Type=Application
510 _Name=W3M Text Browser
511 StartupNotify=false
512 X-XFCE-Binaries=w3m;
513 X-XFCE-Category=WebBrowser
514 X-XFCE-Commands=exo-open --launch TerminalEmulator %B;
515 X-XFCE-CommandsWithParameter=exo-open --launch TerminalEmulator %B %s;
516+X-XFCE-Type=X-XFCE-Helper
517--- a/exo-helper/helpers/xterm.desktop.in.in.old 2011-03-07 12:08:30.000000000 +0100
518+++ b/exo-helper/helpers/xterm.desktop.in.in 2011-03-07 12:08:31.000000000 +0100
519@@ -1,10 +1,11 @@
520 [Desktop Entry]
521 Version=1.0
522 Icon=xterm
523-Type=X-XFCE-Helper
524+Type=Application
525 _Name=X Terminal
526 StartupNotify=false
527 X-XFCE-Binaries=xterm;
528 X-XFCE-Category=TerminalEmulator
529 X-XFCE-Commands=%B;
530 X-XFCE-CommandsWithParameter=%B -e %s;
531+X-XFCE-Type=X-XFCE-Helper
diff --git a/meta-xfce/recipes-xfce/exo/exo/gnome-mount b/meta-xfce/recipes-xfce/exo/exo/gnome-mount
new file mode 100644
index 000000000..85fdb25e8
--- /dev/null
+++ b/meta-xfce/recipes-xfce/exo/exo/gnome-mount
@@ -0,0 +1,64 @@
1#!/bin/sh
2#
3# gnome-mount - wrapper script for use with exo-mount
4#
5# Copyright 2009 Enrico Tröger <enrico(at)xfce(dot)org>
6# Licence: GPLv2
7#
8#
9# This script aims to be a wrapper script to provide the
10# gnome-mount utility on envrionments which only have
11# exo-mount (e.g. Xfce). It accepts all command line arguments
12# which are passed but ignores all which are not supported by
13# exo-mount.
14#
15# (This script was tested with Bash and Dash.)
16#
17# Possible use case is as a drop-in replacement to get mounting
18# local resources with GVfs working, e.g. mounting disks in CD drives.
19#
20# Usage:
21# Save this script as 'gnome-mount' in a directory in your path,
22# e.g. /usr/local/bin or ~/bin and make it executable.
23#
24
25
26
27OPTS=""
28
29# first catch all passed arguments and keep those exo-mount supports,
30# ignore all other arguments
31while [ -n "$*" ]
32do
33 case $1 in
34 -\?|--help)
35 OPTS="$OPTS --help"
36 ;;
37 -e|--eject)
38 OPTS="$OPTS --eject"
39 ;;
40 -u|--unmount)
41 OPTS="$OPTS --unmount"
42 ;;
43 -h|--hal-udi)
44 OPTS="$OPTS --hal-udi"
45 shift
46 OPTS="$OPTS $1"
47 ;;
48 -d|--device)
49 OPTS="$OPTS --device"
50 shift
51 OPTS="$OPTS $1"
52 ;;
53 -n|--no-ui)
54 OPTS="$OPTS --no-ui"
55 ;;
56 -V|--version)
57 OPTS="$OPTS --version"
58 ;;
59 esac
60 shift
61done
62
63# now run exo-mount and hope things go well
64exo-mount $OPTS
diff --git a/meta-xfce/recipes-xfce/exo/exo_0.6.2.bb b/meta-xfce/recipes-xfce/exo/exo_0.6.2.bb
new file mode 100644
index 000000000..b9fc6870d
--- /dev/null
+++ b/meta-xfce/recipes-xfce/exo/exo_0.6.2.bb
@@ -0,0 +1,36 @@
1DESCRIPTION="Application library for the Xfce desktop environment"
2SECTION = "x11"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
5DEPENDS = "gtk+ libxfce4util virtual/libx11 perl-native cairo"
6
7PR = "r0"
8
9inherit xfce
10
11# SRC_URI must follow inherited one
12SRC_URI += " \
13 file://exo-no-tests-0.6.patch \
14 file://configure.patch \
15 file://gnome-mount \
16 file://fix-qa-desktop-type-error.patch \
17"
18
19
20# see http://wiki.xfce.org/gnomemount-replacement
21do_install_append () {
22 install -m 755 -d ${D}${bindir}/exo-mount-wrapper
23 install -m 755 ${WORKDIR}//gnome-mount ${D}${bindir}/exo-mount-wrapper
24}
25
26# Note: python bindings did not work in oe-dev and are about to be moved to
27# pyxfce see http://comments.gmane.org/gmane.comp.desktop.xfce.devel.version4/19560
28FILES_${PN} += "${datadir}/xfce4/ \
29 ${libdir}/xfce4/exo-1 \
30 "
31
32FILES_${PN}-dbg += "${libdir}/gio/modules/.debug \
33 "
34
35SRC_URI[md5sum] = "e25333df350abc30999cd16fe96ab690"
36SRC_URI[sha256sum] = "f49cf6a85546f47a1dddb58ce9a5f9364384a6f173cba99deb879e027c811f39"