diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-13 22:49:41 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-15 16:23:17 +0200 |
commit | a45830a39bb47a9eab27980d52966226c9504ea4 (patch) | |
tree | 001209d9740e8668b2eeeac4212b3561aecebf29 /meta-xfce/recipes-xfce | |
parent | 6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff) | |
download | meta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz |
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python
tasks).
* Some recipes were using tabs.
* Some were using 8 spaces.
* Some were using mix or different number of spaces.
* Make them consistently use 4 spaces everywhere.
* Yocto styleguide advises to use tabs (but the only reason to keep
tabs is the need to update a lot of recipes). Lately this advice
was also merged into the styleguide on the OE wiki.
* Using 4 spaces in both types of tasks is better because it's less
error prone when someone is not sure if e.g.
do_generate_toolchain_file() is Python or shell task and also allows
to highlight every tab used in .bb, .inc, .bbappend, .bbclass as
potentially bad (shouldn't be used for indenting of multiline
variable assignments and cannot be used for Python tasks).
* Don't indent closing quote on multiline variables
we're quite inconsistent wheater it's first character on line
under opening quote or under first non-whitespace character in
previous line.
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-xfce/recipes-xfce')
7 files changed, 12 insertions, 12 deletions
diff --git a/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb b/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb index 5e6b5acdb..09aacc3da 100644 --- a/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb +++ b/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb | |||
@@ -27,10 +27,10 @@ PACKAGES =+ "exo-csource" | |||
27 | # pyxfce see http://comments.gmane.org/gmane.comp.desktop.xfce.devel.version4/19560 | 27 | # pyxfce see http://comments.gmane.org/gmane.comp.desktop.xfce.devel.version4/19560 |
28 | FILES_${PN} += "${datadir}/xfce4/ \ | 28 | FILES_${PN} += "${datadir}/xfce4/ \ |
29 | ${libdir}/xfce4/exo-1 \ | 29 | ${libdir}/xfce4/exo-1 \ |
30 | " | 30 | " |
31 | 31 | ||
32 | FILES_${PN}-dbg += "${libdir}/gio/modules/.debug \ | 32 | FILES_${PN}-dbg += "${libdir}/gio/modules/.debug \ |
33 | " | 33 | " |
34 | 34 | ||
35 | FILES_exo-csource += "${bindir}/exo-csource" | 35 | FILES_exo-csource += "${bindir}/exo-csource" |
36 | 36 | ||
diff --git a/meta-xfce/recipes-xfce/tumbler/tumbler_0.1.27.bb b/meta-xfce/recipes-xfce/tumbler/tumbler_0.1.27.bb index 663e67c7c..93a95d534 100644 --- a/meta-xfce/recipes-xfce/tumbler/tumbler_0.1.27.bb +++ b/meta-xfce/recipes-xfce/tumbler/tumbler_0.1.27.bb | |||
@@ -20,7 +20,7 @@ FILES_${PN} += "${datadir}/dbus-1/services \ | |||
20 | ${libdir}/tumbler-1/tumblerd \ | 20 | ${libdir}/tumbler-1/tumblerd \ |
21 | ${libdir}/tumbler-1/plugins/*.so \ | 21 | ${libdir}/tumbler-1/plugins/*.so \ |
22 | ${libdir}/tumbler-1/plugins/cache/*.so \ | 22 | ${libdir}/tumbler-1/plugins/cache/*.so \ |
23 | " | 23 | " |
24 | 24 | ||
25 | FILES_${PN}-dev += "${libdir}/tumbler-1/plugins/*.la \ | 25 | FILES_${PN}-dev += "${libdir}/tumbler-1/plugins/*.la \ |
26 | ${libdir}/tumbler-1/plugins/cache/*.la" | 26 | ${libdir}/tumbler-1/plugins/cache/*.la" |
diff --git a/meta-xfce/recipes-xfce/xfce4-dev-tools/xfce4-dev-tools_4.10.0.bb b/meta-xfce/recipes-xfce/xfce4-dev-tools/xfce4-dev-tools_4.10.0.bb index 1955fccb0..8779b01f4 100644 --- a/meta-xfce/recipes-xfce/xfce4-dev-tools/xfce4-dev-tools_4.10.0.bb +++ b/meta-xfce/recipes-xfce/xfce4-dev-tools/xfce4-dev-tools_4.10.0.bb | |||
@@ -14,8 +14,8 @@ SRC_URI[md5sum] = "372b74f432e7e02d946c2ea9d3de2805" | |||
14 | SRC_URI[sha256sum] = "f79649bbfbbf16881494ee9f67035063765aec12e23ab9bac31de2c8a4f32bf8" | 14 | SRC_URI[sha256sum] = "f79649bbfbbf16881494ee9f67035063765aec12e23ab9bac31de2c8a4f32bf8" |
15 | 15 | ||
16 | do_install_append() { | 16 | do_install_append() { |
17 | install -d ${D}${datadir}/aclocal | 17 | install -d ${D}${datadir}/aclocal |
18 | install -m 644 m4macros/*.m4 ${D}${datadir}/aclocal/ | 18 | install -m 644 m4macros/*.m4 ${D}${datadir}/aclocal/ |
19 | } | 19 | } |
20 | 20 | ||
21 | FILES_${PN} += "${datadir}/xfce4/dev-tools/m4macros/*.m4" | 21 | FILES_${PN} += "${datadir}/xfce4/dev-tools/m4macros/*.m4" |
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.10.0.bb b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.10.0.bb index f7d7c4687..02a6cb1c9 100644 --- a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.10.0.bb +++ b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.10.0.bb | |||
@@ -26,4 +26,4 @@ FILES_${PN} += "${libdir}/xfce4/panel/migrate \ | |||
26 | ${libdir}/xfce4/panel/wrapper" | 26 | ${libdir}/xfce4/panel/wrapper" |
27 | 27 | ||
28 | FILES_${PN}-dbg += "${libdir}/xfce4/panel/plugins/.debug \ | 28 | FILES_${PN}-dbg += "${libdir}/xfce4/panel/plugins/.debug \ |
29 | " | 29 | " |
diff --git a/meta-xfce/recipes-xfce/xfce4-power-manager/xfce4-power-manager_1.2.0.bb b/meta-xfce/recipes-xfce/xfce4-power-manager/xfce4-power-manager_1.2.0.bb index 670fc251e..af2ba5e64 100644 --- a/meta-xfce/recipes-xfce/xfce4-power-manager/xfce4-power-manager_1.2.0.bb +++ b/meta-xfce/recipes-xfce/xfce4-power-manager/xfce4-power-manager_1.2.0.bb | |||
@@ -15,14 +15,14 @@ EXTRA_OECONF = " \ | |||
15 | --enable-polkit \ | 15 | --enable-polkit \ |
16 | --enable-network-manager \ | 16 | --enable-network-manager \ |
17 | --enable-panel-plugins \ | 17 | --enable-panel-plugins \ |
18 | " | 18 | " |
19 | 19 | ||
20 | PACKAGES += "xfce4-brightness-plugin" | 20 | PACKAGES += "xfce4-brightness-plugin" |
21 | FILES_${PN} += "${datadir}/polkit-1" | 21 | FILES_${PN} += "${datadir}/polkit-1" |
22 | FILES_xfce4-brightness-plugin = " \ | 22 | FILES_xfce4-brightness-plugin = " \ |
23 | ${libdir}/xfce4/panel-plugins/xfce4-brightness-plugin \ | 23 | ${libdir}/xfce4/panel-plugins/xfce4-brightness-plugin \ |
24 | ${datadir}/xfce4/panel-plugins/xfce4-brightness-plugin.desktop \ | 24 | ${datadir}/xfce4/panel-plugins/xfce4-brightness-plugin.desktop \ |
25 | " | 25 | " |
26 | 26 | ||
27 | SRC_URI[md5sum] = "935599b7114b0a4b0e2c9a5d6c72524c" | 27 | SRC_URI[md5sum] = "935599b7114b0a4b0e2c9a5d6c72524c" |
28 | SRC_URI[sha256sum] = "d7fb98a540284b62f4201527de17d4b24123f9d26c9f49131dd497c8387184e9" | 28 | SRC_URI[sha256sum] = "d7fb98a540284b62f4201527de17d4b24123f9d26c9f49131dd497c8387184e9" |
diff --git a/meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_4.11.0.bb b/meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_4.11.0.bb index c5cb03371..d633fa6d1 100644 --- a/meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_4.11.0.bb +++ b/meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_4.11.0.bb | |||
@@ -23,9 +23,9 @@ SRC_URI[sha256sum] = "4a4f1e79a58b524f3a6dd030b6fc687671b35566f847e6f516c6f84211 | |||
23 | FILES_${PN} += "${libdir}/xfce4" | 23 | FILES_${PN} += "${libdir}/xfce4" |
24 | 24 | ||
25 | do_install_prepend() { | 25 | do_install_prepend() { |
26 | # somehow binary files are not patched correctly by oe-patch - so copy them | 26 | # somehow binary files are not patched correctly by oe-patch - so copy them |
27 | cp ${WORKDIR}/touchscreen/invisible ${S}/cursors | 27 | cp ${WORKDIR}/touchscreen/invisible ${S}/cursors |
28 | cp ${WORKDIR}/touchscreen/wait ${S}/cursors | 28 | cp ${WORKDIR}/touchscreen/wait ${S}/cursors |
29 | } | 29 | } |
30 | 30 | ||
31 | RRECOMMENDS_${PN} += "gnome-icon-theme" | 31 | RRECOMMENDS_${PN} += "gnome-icon-theme" |
diff --git a/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.10.0.bb b/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.10.0.bb index 4f686a581..5801c517a 100644 --- a/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.10.0.bb +++ b/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.10.0.bb | |||
@@ -23,6 +23,6 @@ ALTERNATIVE_PRIORITY[x-window-manager] = "30" | |||
23 | RDEPENDS_${PN} = "xfwm4-theme-default" | 23 | RDEPENDS_${PN} = "xfwm4-theme-default" |
24 | FILES_${PN} += "${libdir}/xfce4/xfwm4/helper-dialog \ | 24 | FILES_${PN} += "${libdir}/xfce4/xfwm4/helper-dialog \ |
25 | ${datadir}/xfwm4/defaults \ | 25 | ${datadir}/xfwm4/defaults \ |
26 | " | 26 | " |
27 | FILES_${PN}-dbg += "${libexecdir}/xfce4/xfwm4/.debug/*" | 27 | FILES_${PN}-dbg += "${libexecdir}/xfce4/xfwm4/.debug/*" |
28 | 28 | ||