summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.14.4.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2020-08-09 14:35:03 +0200
committerKhem Raj <raj.khem@gmail.com>2020-08-09 13:00:23 -0700
commit610b7e1d284f64ce888089792e1ebc6d8b76e39b (patch)
tree7eadc87ebaa37f4937554e5acecef1d5df0c656b /meta-xfce/recipes-xfce/xfwm4/xfwm4_4.14.4.bb
parent97e2948519d0c21f5596cb68408b4f5c49be84ca (diff)
downloadmeta-openembedded-610b7e1d284f64ce888089792e1ebc6d8b76e39b.tar.gz
xfwm4: upgrade 4.14.3 -> 4.14.4
Release notes for 4.14.4 ======================== 4.14.4 ====== - Fix a crash on FreeBSD (xfce/xfwm4#411) - Fix compilation warning due to g_type_class_add_private deprecation Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-xfce/recipes-xfce/xfwm4/xfwm4_4.14.4.bb')
-rw-r--r--meta-xfce/recipes-xfce/xfwm4/xfwm4_4.14.4.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.14.4.bb b/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.14.4.bb
new file mode 100644
index 000000000..d68e00864
--- /dev/null
+++ b/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.14.4.bb
@@ -0,0 +1,38 @@
1DESCRIPTION = "Xfce4 Window Manager"
2SECTION = "x11/wm"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d791728a073bc009b4ffaf00b7599855"
5DEPENDS = "virtual/libx11 libxfce4ui libwnck3 libxinerama exo-native"
6
7inherit xfce update-alternatives features_check
8
9REQUIRED_DISTRO_FEATURES = "x11"
10
11SRC_URI += "file://0001-Revert-compositor-Revert-to-GLX-as-default-vblank-me.patch"
12SRC_URI[sha256sum] = "b2a4e6acc3e6eb5503f247f2664c2b1a25240050d75ca93299955aa6b5e62a7e"
13
14PACKAGECONFIG ?= " \
15 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'epoxy', '', d)} \
16 xpresent \
17 startup-notification \
18"
19
20PACKAGECONFIG[epoxy] = "--enable-epoxy,--disable-epoxy,libepoxy"
21PACKAGECONFIG[xpresent] = "--enable-xpresent,--disable-xpresent,libxpresent"
22PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-startup-notification,startup-notification"
23
24python populate_packages_prepend () {
25 themedir = d.expand('${datadir}/themes')
26 do_split_packages(d, themedir, '^(.*)', 'xfwm4-theme-%s', 'XFWM4 theme %s', allow_dirs=True)
27}
28
29PACKAGES_DYNAMIC += "^xfwm4-theme-.*"
30
31ALTERNATIVE_${PN} = "x-window-manager"
32ALTERNATIVE_TARGET[x-window-manager] = "${bindir}/xfwm4"
33ALTERNATIVE_PRIORITY[x-window-manager] = "30"
34
35RDEPENDS_${PN} = "xfwm4-theme-default"
36FILES_${PN} += "${libdir}/xfce4/xfwm4/helper-dialog \
37 ${datadir}/xfwm4/defaults \
38"