summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.10.1.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2013-05-13 16:37:34 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-05-19 09:37:31 +0200
commitb06a88718a4eee1d6cdbd46767ddb8e764d4cd37 (patch)
tree69f7035afcd5637eb423ccdefe9bfa920f205ae9 /meta-xfce/recipes-xfce/xfwm4/xfwm4_4.10.1.bb
parent733a8deb040013cd90f01adf547c9696f98df961 (diff)
downloadmeta-openembedded-b06a88718a4eee1d6cdbd46767ddb8e764d4cd37.tar.gz
xfwm4: update to 4.10.1
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'meta-xfce/recipes-xfce/xfwm4/xfwm4_4.10.1.bb')
-rw-r--r--meta-xfce/recipes-xfce/xfwm4/xfwm4_4.10.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.10.1.bb b/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.10.1.bb
new file mode 100644
index 000000000..687339b26
--- /dev/null
+++ b/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.10.1.bb
@@ -0,0 +1,28 @@
1DESCRIPTION="Xfce4 Window Manager"
2SECTION = "x11/wm"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d791728a073bc009b4ffaf00b7599855"
5DEPENDS = "virtual/libx11 libxpm gtk+ libxfce4util libxfce4ui xfconf libwnck dbus-glib startup-notification"
6
7inherit xfce update-alternatives
8
9SRC_URI[md5sum] = "10de50c79ed944cbb9c87741062c2a76"
10SRC_URI[sha256sum] = "380c44fba6eb779e34be0fe94f3726cfa131803014d6073c45aec8a1257fa740"
11
12python populate_packages_prepend () {
13 themedir = d.expand('${datadir}/themes')
14 do_split_packages(d, themedir, '^(.*)', 'xfwm4-theme-%s', 'XFWM4 theme %s', allow_dirs=True)
15}
16
17PACKAGES_DYNAMIC += "^xfwm4-theme-.*"
18
19ALTERNATIVE_${PN} = "x-window-manager"
20ALTERNATIVE_TARGET[x-window-manager] = "${bindir}/xfwm4"
21ALTERNATIVE_PRIORITY[x-window-manager] = "30"
22
23RDEPENDS_${PN} = "xfwm4-theme-default"
24FILES_${PN} += "${libdir}/xfce4/xfwm4/helper-dialog \
25 ${datadir}/xfwm4/defaults \
26"
27FILES_${PN}-dbg += "${libexecdir}/xfce4/xfwm4/.debug/*"
28