summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/xfce4-settings
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-04-22 20:48:52 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-04-28 10:38:38 +0200
commitf08b75f64ccf52c416a2ebaeb2e27d1e50877583 (patch)
tree714583f0f25a207e60f003d73419473ef66831f9 /meta-xfce/recipes-xfce/xfce4-settings
parente5c807b77fbe753e28483ae7d58d8a5dec676ace (diff)
downloadmeta-openembedded-f08b75f64ccf52c416a2ebaeb2e27d1e50877583.tar.gz
meta-xfce: use bb.utils.contains() instead of base_contains()
base_contains() is a compatibility wrapper and may warn in the future, so replace all instances with bb.utils.contains(). Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-xfce/recipes-xfce/xfce4-settings')
-rw-r--r--meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_git.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_git.bb b/meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_git.bb
index c8224a16e..d5ed04468 100644
--- a/meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_git.bb
+++ b/meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_git.bb
@@ -21,8 +21,8 @@ PV = "4.12.0+git${SRCPV}"
21EXTRA_OECONF += "--enable-maintainer-mode --disable-debug" 21EXTRA_OECONF += "--enable-maintainer-mode --disable-debug"
22 22
23PACKAGECONFIG ??= " \ 23PACKAGECONFIG ??= " \
24 ${@base_contains('DISTRO_FEATURES','systemd','datetime-setter','',d)} \ 24 ${@bb.utils.contains('DISTRO_FEATURES','systemd','datetime-setter','',d)} \
25 ${@base_contains('DISTRO_FEATURES','alsa','sound-setter', base_contains('DISTRO_FEATURES','pulseaudio','sound-setter','',d),d)} \ 25 ${@bb.utils.contains('DISTRO_FEATURES','alsa','sound-setter', bb.utils.contains('DISTRO_FEATURES','pulseaudio','sound-setter','',d),d)} \
26" 26"
27PACKAGECONFIG[datetime-setter] = "--enable-datetime-settings, --disable-datetime-settings,, tzdata" 27PACKAGECONFIG[datetime-setter] = "--enable-datetime-settings, --disable-datetime-settings,, tzdata"
28PACKAGECONFIG[notify] = "--enable-libnotify,--disable-libnotify,libnotify" 28PACKAGECONFIG[notify] = "--enable-libnotify,--disable-libnotify,libnotify"
@@ -34,5 +34,5 @@ FILES_${PN} += " \
34" 34"
35 35
36RRECOMMENDS_${PN} += "adwaita-icon-theme" 36RRECOMMENDS_${PN} += "adwaita-icon-theme"
37RRECOMMENDS_${PN} += "${@base_contains('DISTRO_FEATURES','alsa','libcanberra-alsa','',d)}" 37RRECOMMENDS_${PN} += "${@bb.utils.contains('DISTRO_FEATURES','alsa','libcanberra-alsa','',d)}"
38RRECOMMENDS_${PN} += "${@base_contains('DISTRO_FEATURES','pulseaudio','libcanberra-pulse','',d)}" 38RRECOMMENDS_${PN} += "${@bb.utils.contains('DISTRO_FEATURES','pulseaudio','libcanberra-pulse','',d)}"