diff options
author | Andreas Müller <schnitzeltony@googlemail.com> | 2012-09-16 17:44:54 +0200 |
---|---|---|
committer | Andreas Müller <schnitzeltony@googlemail.com> | 2012-09-18 15:54:00 +0200 |
commit | db799a93e277a973481a6ed4cadafdc9d3985c40 (patch) | |
tree | 8a5364e1e66afc63c06b20404c8ac71996930442 /meta-xfce/recipes-xfce/xfce4-session | |
parent | 38c74312030dc56758d2b83c63ce74c2b2b59834 (diff) | |
download | meta-openembedded-db799a93e277a973481a6ed4cadafdc9d3985c40.tar.gz |
xfce4-session: update to 4.10.0
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'meta-xfce/recipes-xfce/xfce4-session')
-rw-r--r-- | meta-xfce/recipes-xfce/xfce4-session/files/0001-Handle-multiple-interactive-session-save-bug-5379.patch (renamed from meta-xfce/recipes-xfce/xfce4-session/files/0001-Don-t-loose-xfwm4-when-closing-session-with-multiple.patch) | 61 | ||||
-rw-r--r-- | meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.10.0.bb (renamed from meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.8.3.bb) | 14 |
2 files changed, 28 insertions, 47 deletions
diff --git a/meta-xfce/recipes-xfce/xfce4-session/files/0001-Don-t-loose-xfwm4-when-closing-session-with-multiple.patch b/meta-xfce/recipes-xfce/xfce4-session/files/0001-Handle-multiple-interactive-session-save-bug-5379.patch index 50bade87f..38949a5d7 100644 --- a/meta-xfce/recipes-xfce/xfce4-session/files/0001-Don-t-loose-xfwm4-when-closing-session-with-multiple.patch +++ b/meta-xfce/recipes-xfce/xfce4-session/files/0001-Handle-multiple-interactive-session-save-bug-5379.patch | |||
@@ -1,56 +1,39 @@ | |||
1 | From 64c0acb072057023870881f9fbac29ce08d357db Mon Sep 17 00:00:00 2001 | 1 | From 9f3077be682355e1cd07e9a9463e76307292208c Mon Sep 17 00:00:00 2001 |
2 | From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com> | 2 | From: Dimitar Zhekov <hamster@mbox.contact.bg> |
3 | Date: Wed, 5 Sep 2012 20:14:09 +0200 | 3 | Date: Thu, 30 Aug 2012 22:52:14 +0200 |
4 | Subject: [PATCH] Don't loose xfwm4 when closing session with multiple windows | 4 | Subject: [PATCH] Handle multiple interactive session save (bug #5379). |
5 | waiting for user input | ||
6 | MIME-Version: 1.0 | ||
7 | Content-Type: text/plain; charset=UTF-8 | ||
8 | Content-Transfer-Encoding: 8bit | ||
9 | 5 | ||
10 | When closing a session with more than one window open and waiting for unsaved | 6 | Additionnaly, we now use SmSaveGlobal on log out / shutdown without |
11 | data to be closed, at the next session xfwm4 was not started properly. | 7 | session save which avoids data loss. Previously clients would not save |
8 | anything on log out without session save. | ||
12 | 9 | ||
13 | The bug(fix) could be reproduced by | 10 | Based on original work by Chris Bainbridge (chris.bainbridge@gmail.com). |
14 | |||
15 | * opening gedit | ||
16 | * entering some text | ||
17 | * opening terminal | ||
18 | * closing session (no YNC-dialog / wait ~1min to close session) | ||
19 | * reopen session | ||
20 | |||
21 | Bugreport with this patch is found at [1] further discussion at [2]. | ||
22 | |||
23 | Upstream-Status: Pending | ||
24 | |||
25 | [1] https://bugzilla.xfce.org/show_bug.cgi?id=5379 | ||
26 | [2] http://mail.xfce.org/pipermail/xfce/2012-August/031174.html | ||
27 | |||
28 | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> | ||
29 | --- | 11 | --- |
12 | Upstream-status: applied | ||
30 | xfce4-session/xfsm-manager.c | 81 ++++++++++++++++++++++++----------------- | 13 | xfce4-session/xfsm-manager.c | 81 ++++++++++++++++++++++++----------------- |
31 | 1 files changed, 47 insertions(+), 34 deletions(-) | 14 | 1 files changed, 47 insertions(+), 34 deletions(-) |
32 | 15 | ||
33 | diff --git a/xfce4-session/xfsm-manager.c b/xfce4-session/xfsm-manager.c | 16 | diff --git a/xfce4-session/xfsm-manager.c b/xfce4-session/xfsm-manager.c |
34 | index 3078d6a..3cc4c89 100644 | 17 | index bf6a446..35811c5 100644 |
35 | --- a/xfce4-session/xfsm-manager.c | 18 | --- a/xfce4-session/xfsm-manager.c |
36 | +++ b/xfce4-session/xfsm-manager.c | 19 | +++ b/xfce4-session/xfsm-manager.c |
37 | @@ -96,6 +96,7 @@ struct _XfsmManager | 20 | @@ -98,6 +98,7 @@ struct _XfsmManager |
38 | 21 | ||
39 | XfsmManagerState state; | 22 | XfsmShutdownType shutdown_type; |
40 | XfsmShutdownType shutdown_type; | 23 | XfsmShutdown *shutdown_helper; |
41 | + gboolean save_session; | 24 | + gboolean save_session; |
42 | 25 | ||
43 | gboolean session_chooser; | 26 | gboolean session_chooser; |
44 | gchar *session_name; | 27 | gchar *session_name; |
45 | @@ -225,6 +226,7 @@ xfsm_manager_init (XfsmManager *manager) | 28 | @@ -230,6 +231,7 @@ xfsm_manager_init (XfsmManager *manager) |
46 | manager->session_chooser = FALSE; | ||
47 | manager->failsafe_mode = TRUE; | 29 | manager->failsafe_mode = TRUE; |
48 | manager->shutdown_type = XFSM_SHUTDOWN_LOGOUT; | 30 | manager->shutdown_type = XFSM_SHUTDOWN_LOGOUT; |
31 | manager->shutdown_helper = xfsm_shutdown_get (); | ||
49 | + manager->save_session = TRUE; | 32 | + manager->save_session = TRUE; |
50 | 33 | ||
51 | manager->pending_properties = g_queue_new (); | 34 | manager->pending_properties = g_queue_new (); |
52 | manager->starting_properties = g_queue_new (); | 35 | manager->starting_properties = g_queue_new (); |
53 | @@ -981,7 +983,9 @@ xfsm_manager_interact (XfsmManager *manager, | 36 | @@ -989,7 +991,9 @@ xfsm_manager_interact (XfsmManager *manager, |
54 | XfsmClient *cl = lp->data; | 37 | XfsmClient *cl = lp->data; |
55 | if (xfsm_client_get_state (cl) == XFSM_CLIENT_INTERACTING) | 38 | if (xfsm_client_get_state (cl) == XFSM_CLIENT_INTERACTING) |
56 | { | 39 | { |
@@ -61,9 +44,9 @@ index 3078d6a..3cc4c89 100644 | |||
61 | return; | 44 | return; |
62 | } | 45 | } |
63 | } | 46 | } |
64 | @@ -1158,44 +1162,47 @@ xfsm_manager_save_yourself_global (XfsmManager *manager, | 47 | @@ -1138,44 +1142,47 @@ xfsm_manager_save_yourself_global (XfsmManager *manager, |
48 | } | ||
65 | } | 49 | } |
66 | #endif | ||
67 | 50 | ||
68 | - if (!shutdown || shutdown_save) | 51 | - if (!shutdown || shutdown_save) |
69 | + /* don't save the session if shutting down without save */ | 52 | + /* don't save the session if shutting down without save */ |
@@ -140,7 +123,7 @@ index 3078d6a..3cc4c89 100644 | |||
140 | } | 123 | } |
141 | } | 124 | } |
142 | 125 | ||
143 | @@ -1267,7 +1274,12 @@ xfsm_manager_save_yourself_done (XfsmManager *manager, | 126 | @@ -1249,7 +1256,12 @@ xfsm_manager_save_yourself_done (XfsmManager *manager, |
144 | XfsmClient *client, | 127 | XfsmClient *client, |
145 | gboolean success) | 128 | gboolean success) |
146 | { | 129 | { |
@@ -154,7 +137,7 @@ index 3078d6a..3cc4c89 100644 | |||
154 | { | 137 | { |
155 | xfsm_verbose ("Client Id = %s send SAVE YOURSELF DONE, while not being " | 138 | xfsm_verbose ("Client Id = %s send SAVE YOURSELF DONE, while not being " |
156 | "in save mode. Prepare to be nuked!\n", | 139 | "in save mode. Prepare to be nuked!\n", |
157 | @@ -1539,7 +1551,8 @@ xfsm_manager_complete_saveyourself (XfsmManager *manager) | 140 | @@ -1521,7 +1533,8 @@ xfsm_manager_complete_saveyourself (XfsmManager *manager) |
158 | xfsm_verbose ("Manager finished SAVE YOURSELF, session data will be stored now.\n\n"); | 141 | xfsm_verbose ("Manager finished SAVE YOURSELF, session data will be stored now.\n\n"); |
159 | 142 | ||
160 | /* all clients done, store session data */ | 143 | /* all clients done, store session data */ |
@@ -165,5 +148,5 @@ index 3078d6a..3cc4c89 100644 | |||
165 | if (manager->state == XFSM_MANAGER_CHECKPOINT) | 148 | if (manager->state == XFSM_MANAGER_CHECKPOINT) |
166 | { | 149 | { |
167 | -- | 150 | -- |
168 | 1.7.6.5 | 151 | 1.7.4.4 |
169 | 152 | ||
diff --git a/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.8.3.bb b/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.10.0.bb index 4b9b32eb7..4df989495 100644 --- a/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.8.3.bb +++ b/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.10.0.bb | |||
@@ -2,13 +2,14 @@ DESCRIPTION = "xfce4-session is a session manager for Xfce 4 Desktop Environment | |||
2 | SECTION = "x11" | 2 | SECTION = "x11" |
3 | LICENSE = "GPLv2" | 3 | LICENSE = "GPLv2" |
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=9ac2e7cff1ddaf48b6eab6028f23ef88" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=9ac2e7cff1ddaf48b6eab6028f23ef88" |
5 | DEPENDS = "virtual/libx11 libsm libxfce4util libxfce4ui gtk+ libwnck dbus dbus-glib xfconf xfce4-panel gconf gnome-keyring" | 5 | DEPENDS = "virtual/libx11 libsm libxfce4util libxfce4ui gtk+ libwnck dbus dbus-glib xfconf gnome-keyring" |
6 | RDEPENDS_${PN} = "netbase xinit dbus-x11 iceauth consolekit" | 6 | RDEPENDS_${PN} = "netbase xinit dbus-x11 iceauth consolekit upower" |
7 | PR = "r2" | ||
8 | 7 | ||
9 | inherit xfce | 8 | inherit xfce |
10 | 9 | ||
11 | SRC_URI += "file://0001-Don-t-loose-xfwm4-when-closing-session-with-multiple.patch" | 10 | SRC_URI[md5sum] = "4768e1a41a0287af6aad18b329a0f230" |
11 | SRC_URI[sha256sum] = "bb8aa9a74c3d382840596fb4875144d66c7f3f47c8e9ee81d31e3428a72c46ce" | ||
12 | SRC_URI += "file://0001-Handle-multiple-interactive-session-save-bug-5379.patch" | ||
12 | 13 | ||
13 | # protect from frightening message that xfce might not work correctly | 14 | # protect from frightening message that xfce might not work correctly |
14 | pkg_postinst_${PN} () { | 15 | pkg_postinst_${PN} () { |
@@ -17,12 +18,9 @@ pkg_postinst_${PN} () { | |||
17 | 18 | ||
18 | FILES_${PN} += "${libdir}/xfce4/*/*/*.so \ | 19 | FILES_${PN} += "${libdir}/xfce4/*/*/*.so \ |
19 | ${libdir}/xfce4/session/*-*-* \ | 20 | ${libdir}/xfce4/session/*-*-* \ |
20 | ${datadir}/xfce4/*/* \ | 21 | ${datadir}/xsessions \ |
21 | ${datadir}/themes/Default/balou/*" | 22 | ${datadir}/themes/Default/balou/*" |
22 | 23 | ||
23 | FILES_${PN}-dbg += "${libdir}/xfce4/*/*/.debug" | 24 | FILES_${PN}-dbg += "${libdir}/xfce4/*/*/.debug" |
24 | 25 | ||
25 | FILES_${PN}-staticdev += "${libdir}/xfce4/*/*/*.*a" | 26 | FILES_${PN}-staticdev += "${libdir}/xfce4/*/*/*.*a" |
26 | |||
27 | SRC_URI[md5sum] = "461cc38bbd37cab881adbdf943f9a402" | ||
28 | SRC_URI[sha256sum] = "f0801b8c0ffa7e5d41b29b8df281ac127adf467bf50e8ded8aebe5a02bd99338" | ||