summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/xfce4-session
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-xfce/recipes-xfce/xfce4-session
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-xfce/recipes-xfce/xfce4-session')
-rw-r--r--meta-xfce/recipes-xfce/xfce4-session/xfce4-session/0001-configure.in-hard-code-path-to-iceauth.patch40
-rw-r--r--meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.10.1.bb36
2 files changed, 76 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/xfce4-session/xfce4-session/0001-configure.in-hard-code-path-to-iceauth.patch b/meta-xfce/recipes-xfce/xfce4-session/xfce4-session/0001-configure.in-hard-code-path-to-iceauth.patch
new file mode 100644
index 000000000..d619cde6c
--- /dev/null
+++ b/meta-xfce/recipes-xfce/xfce4-session/xfce4-session/0001-configure.in-hard-code-path-to-iceauth.patch
@@ -0,0 +1,40 @@
1From a629b051f4e5462150c77b95574bbc7a33bc9666 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Mon, 31 Dec 2012 16:35:29 +0100
4Subject: [PATCH] configure.ac: hard code path to iceauth
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9workaround AC_PATH_PROG which was meant to find programs required at build-time
10not at run-time.
11
12Upstream-Status: Inappropriate [config]
13
14Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
15---
16 configure.ac | 8 +-------
17 1 files changed, 1 insertions(+), 7 deletions(-)
18
19diff --git a/configure.ac b/configure.ac
20index 3cf3510..505e744 100644
21--- a/configure.ac
22+++ b/configure.ac
23@@ -111,13 +111,7 @@ XDT_FEATURE_DEBUG([xfsm_debug_default])
24 dnl Check for linker optimizations
25 XDT_FEATURE_LINKER_OPTS()
26
27-dnl Check for iceauth
28-AC_PATH_PROG([ICEAUTH], [iceauth])
29-if test x"$ICEAUTH" != x""; then
30- AC_DEFINE_UNQUOTED([ICEAUTH_CMD], ["$ICEAUTH"], [path to iceauth])
31-else
32- AC_MSG_ERROR([iceauth missing, please check your X11 installation])
33-fi
34+AC_DEFINE_UNQUOTED([ICEAUTH_CMD], ["$bindir/iceauth"], [path to iceauth])
35
36 dnl Find a location for the session desktop file
37 AC_MSG_CHECKING([what xsession-prefix to use])
38--
391.7.4.4
40
diff --git a/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.10.1.bb b/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.10.1.bb
new file mode 100644
index 000000000..74289fb35
--- /dev/null
+++ b/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.10.1.bb
@@ -0,0 +1,36 @@
1SUMMARY = "xfce4-session is a session manager for Xfce 4 Desktop Environment"
2SECTION = "x11"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=9ac2e7cff1ddaf48b6eab6028f23ef88"
5DEPENDS = "virtual/libx11 libsm libxfce4util libxfce4ui gtk+ libwnck dbus dbus-glib xfconf"
6RDEPENDS_${PN} = "netbase xinit dbus-x11 iceauth upower"
7
8inherit xfce update-alternatives
9
10SRC_URI[md5sum] = "1757657c1d590aa6274b7b7cbba33352"
11SRC_URI[sha256sum] = "0154fabdc398798c3445374ccc52a2f5bcb2d867fc94bc54114395b24f9cfc83"
12SRC_URI += " \
13 file://0001-configure.in-hard-code-path-to-iceauth.patch \
14"
15
16ALTERNATIVE_${PN} = "x-session-manager"
17ALTERNATIVE_TARGET[x-session-manager] = "${bindir}/xfce4-session"
18ALTERNATIVE_PRIORITY_${PN} = "100"
19
20# protect from frightening message that xfce might not work correctly
21pkg_postinst_${PN} () {
22 echo 127.0.0.1 ${MACHINE} >> /etc/hosts
23}
24
25PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES','systemd','systemd','consolekit',d)}"
26PACKAGECONFIG[systemd] = "--enable-systemd, --disable-systemd, polkit, systemd"
27PACKAGECONFIG[consolekit] = ",,,consolekit"
28
29FILES_${PN} += "${libdir}/xfce4/*/*/*.so \
30 ${libdir}/xfce4/session/*-*-* \
31 ${datadir}/xsessions \
32 ${datadir}/themes/Default/balou/*"
33
34FILES_${PN}-dbg += "${libdir}/xfce4/*/*/.debug"
35
36FILES_${PN}-staticdev += "${libdir}/xfce4/*/*/*.*a"