summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/xfce4-panel
diff options
context:
space:
mode:
authorAndreas Mueller <schnitzeltony@gmx.de>2011-08-01 17:30:55 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-08-05 19:49:58 +0200
commit444901da61e3b08406fc048d000276edaa04e665 (patch)
treee2ed84317ac4735cc38d66d5be8c84452cff7c06 /meta-xfce/recipes-xfce/xfce4-panel
parent68b9b715d15b5cce58d6dfa479e18081a1d5faa0 (diff)
downloadmeta-openembedded-444901da61e3b08406fc048d000276edaa04e665.tar.gz
xfce4-panel: Add initial recipe with version 4.8.5
Diffstat (limited to 'meta-xfce/recipes-xfce/xfce4-panel')
-rw-r--r--meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.8.5.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.8.5.bb b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.8.5.bb
new file mode 100644
index 000000000..d99f3325a
--- /dev/null
+++ b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.8.5.bb
@@ -0,0 +1,34 @@
1DESCRIPTION = "Xfce4 Panel"
2SECTION = "x11"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=26a8bd75d8f8498bdbbe64a27791d4ee"
5DEPENDS = "libxfce4util garcon libxfce4ui xfconf exo gtk+ dbus cairo virtual/libx11 libxml2 libwnck"
6
7PR = "r0"
8
9inherit xfce
10
11python populate_packages_prepend() {
12 plugin_dir = bb.data.expand('${libdir}/xfce4/panel/plugins/', d)
13 plugin_name = bb.data.expand('${PN}-plugin-%s', d)
14 do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name,
15 '${PN} plugin for %s', extra_depends='', prepend=True,
16 aux_files_pattern=['${datadir}/xfce4/panel/plugins/%s.desktop',
17 '${sysconfdir}/xdg/xfce/panel/%s-*',
18 '${datadir}/icons/hicolor/48x48/apps/*-%s.png',
19 '${bindir}/*%s*'])
20}
21
22PACKAGES_DYNAMIC = "${PN}-plugin-*"
23
24FILES_${PN} += "${libdir}/xfce4/panel/migrate \
25 ${libdir}/xfce4/panel/wrapper"
26
27FILES_${PN}-dbg += "${libdir}/xfce4/panel/plugins/.debug \
28 "
29
30FILES_${PN}-dev += "${libdir}/xfce4/panel/plugins/*.*a \
31 "
32
33SRC_URI[md5sum] = "3c00e92821709baa2a71b166a32d46a2"
34SRC_URI[sha256sum] = "df8379a18d337481b847cf232eec907a927287917788e7b730deef4a535deada"