diff options
author | Andreas Müller <schnitzeltony@gmail.com> | 2021-01-06 16:16:50 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-01-06 14:20:51 -0800 |
commit | d305ef139612757b3dae00a13a8b641109991075 (patch) | |
tree | fecb160e3ad880e86df386598acf46b7e6173a8c /meta-xfce/recipes-xfce/xfce4-dev-tools | |
parent | 02727307aa5e92d3fdd40b14cf67d5e9233e15d1 (diff) | |
download | meta-openembedded-d305ef139612757b3dae00a13a8b641109991075.tar.gz |
xfce4-dev-tools: upgrade 4.14.0 -> 4.16.0
Release notes for 4.16.0
========================
- Bump glib to 2.50 based on xfce4.16 roadmap
- Do not process @LINGUAS@ at xdt-autogen stage
- Fail xfce-build container generation if there is any error
- helpers: Prefer xfce-build over xfce-test (Fixes #38)
- helpers: Add new helper xfce-open-gitlab
- helpers: Add helper to locally run xfce-build
- helpers: Add xfce-build 'pull' argument
- xfce-build: Add Thunar to container (Fixes #40)
- Disable CFLAGS override when building CI container
- use strict CFLAGS to catch common mistakes in ci pipeline
- Add xvfb on xfce-build
Release notes for 4.15.1
========================
[Please note that this is a development release.]
Various improvements to the helpers introduced in 4.15.0,
cleanup of xdt-autogen code (thanks to Gaël Bonithon), various fixes for
our CI.
- get-translations: Fix line wrapping
- xdt-autogen: Various small improvements
- xdt-autogen: Properly handle whitespaces in filenames
- xdt-autogen: Use sed instead of tr to replace strings
- Updates README.md
- xfce-build: Add libclutter-1.0-dev for xfdashboard build
- Update .gitignore
- helpers: Use blank line for tags message
- helpers: Reuse release notes from NEWS for tag message
- helpers: Simplify xfce-update-news
- helpers: Do not strip NEWS blank line at EOF
- helpers: Install xfce-do-release
- xfce-build: Add depend for mousepad (Fixes #37)
- helpers: Add do-release helper and Readme
- xfce-build: Install python3 version of distutils-extra
- helpers: Make get-translations executable
- get-translations: Remove last comma
- get-translations: Correctly get locale from commit messages
- xfce-build: Replace build-dep with package names
Release notes for 4.15.0
========================
[Please note that this is a development release.]
- New macro XDT_VERSION_INIT(SEMVER[, TAG])
This macro takes care of setting up the version numbering.
It will define the following macros based on SEMVER and TAG:
- xdt_version
- xdt_version_major
- xdt_version_minor
- xdt_version_micro
- xdt_version_tag
- xdt_version_build
- xdt_debug_default
If TAG isn't specified, the xdt_version_tag and xdt_version_git
will be empty and xdt_debug_default will be set to "minimum",
otherwise the xdt_version_build will contain a git hash and
xdt_debug_default will be set to "yes"
Example usage:
XDT_VERSION_INIT([4.15.3],[git])
AC_INIT([xfce4-someproject], [xdt_version()])
...
XDT_FEATURE_DEBUG([xdt_debug_default])
- XDT_I18N macro will now automatically find the linguas if none are
specified during the autoconf run.
- Install m4 macros in default search dir. This makes autoconf find the
macros by default.
By setting version via XDT_VERSION_INIT and using XDT_I18N without
arguments,
this is no longer necessary to use a separate configure.ac.in and a
plain configure.ac can be used !
A big thank to Natanael Copa (ncopa) for his work on this part !
- xfce4-dev-tools now also handle the CI (docker container,
.gitlab-ci.yml templates files etc) on our new gitlab instance. A merge
request or a push to master to any of our projects automatically trigger
a build. This will help us to catch errors quicker and have better
quality. Thanks to Jason Yavorska and Simon Steinbeiss.
- New helpers are also available (xfce-get-release-notes,
xfce-get-translations, xfce-update-news) to help our maintainers to do
releases ! Thanks Simon again.
- Use datarootdir instead of datadir
- xdt-autogen: explicitly set search path for m4 macros
- Install the xfce-helpers
- Add two new helpers to help releasers
- Install m4 macros into default $datadir/aclocal
- Update README for new gitlab urls
- xdt-autogen: Improve and simplify linguas detection
- Let XDT_I18N automatically find the po/*.po as default
- Let configure generate the xdt-autogen script
- Implement XDT_VERSION_INIT
- Add manpage and tests to xdt-csource
- Add xfce4-dev-tools build in addition to container build
- Check BEFORE_SHA along with changes to .po files
- gitlabci: Ensure to run autogen in distcheck stage
- Switch to "foreign" mode for automake
- Add CI templates notes
- Update README with explanation of Dockerfile
- Fix whitespace error
- Add helper script to get all translation-updates
- Integrate xfce-build container build/creation
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-xfce/recipes-xfce/xfce4-dev-tools')
-rw-r--r-- | meta-xfce/recipes-xfce/xfce4-dev-tools/xfce4-dev-tools/0001-Run-native-xdt-csource-on-tests.patch | 33 | ||||
-rw-r--r-- | meta-xfce/recipes-xfce/xfce4-dev-tools/xfce4-dev-tools_4.16.0.bb (renamed from meta-xfce/recipes-xfce/xfce4-dev-tools/xfce4-dev-tools_4.14.0.bb) | 6 |
2 files changed, 37 insertions, 2 deletions
diff --git a/meta-xfce/recipes-xfce/xfce4-dev-tools/xfce4-dev-tools/0001-Run-native-xdt-csource-on-tests.patch b/meta-xfce/recipes-xfce/xfce4-dev-tools/xfce4-dev-tools/0001-Run-native-xdt-csource-on-tests.patch new file mode 100644 index 000000000..74b1679ab --- /dev/null +++ b/meta-xfce/recipes-xfce/xfce4-dev-tools/xfce4-dev-tools/0001-Run-native-xdt-csource-on-tests.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | From b2fcd5c09ee6b4ad03f93ee5e1dd32f2f062cf07 Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com> | ||
3 | Date: Sun, 3 Jan 2021 15:36:07 +0100 | ||
4 | Subject: [PATCH] Run native xdt-csource on tests | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | Tests cannot be opted out so let them pass. | ||
10 | |||
11 | Upstream-Status: Inappropriate [OE specific] | ||
12 | |||
13 | Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> | ||
14 | --- | ||
15 | tests/Makefile.am | 2 +- | ||
16 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
17 | |||
18 | diff --git a/tests/Makefile.am b/tests/Makefile.am | ||
19 | index fa0832c..7c46bbf 100644 | ||
20 | --- a/tests/Makefile.am | ||
21 | +++ b/tests/Makefile.am | ||
22 | @@ -26,7 +26,7 @@ DISTCLEANFILES = test-xdt-csource-data.c | ||
23 | BUILT_SOURCES = test-xdt-csource-data.c | ||
24 | |||
25 | test-xdt-csource-data.c: Makefile $(srcdir)/data/data.bin $(srcdir)/data/data.txt | ||
26 | - $(top_builddir)/xdt-csource/xdt-csource --extern --build-list data_bin $(srcdir)/data/data.bin data_txt $(srcdir)/data/data.txt > test-xdt-csource-data.c | ||
27 | + xdt-csource --extern --build-list data_bin $(srcdir)/data/data.bin data_txt $(srcdir)/data/data.txt > test-xdt-csource-data.c | ||
28 | |||
29 | clean-local: | ||
30 | rm -f *.core core core.* | ||
31 | -- | ||
32 | 2.26.2 | ||
33 | |||
diff --git a/meta-xfce/recipes-xfce/xfce4-dev-tools/xfce4-dev-tools_4.14.0.bb b/meta-xfce/recipes-xfce/xfce4-dev-tools/xfce4-dev-tools_4.16.0.bb index 0b1196619..143a0a5e7 100644 --- a/meta-xfce/recipes-xfce/xfce4-dev-tools/xfce4-dev-tools_4.14.0.bb +++ b/meta-xfce/recipes-xfce/xfce4-dev-tools/xfce4-dev-tools_4.16.0.bb | |||
@@ -3,15 +3,17 @@ HOMEPAGE = "http://www.xfce.org" | |||
3 | SECTION = "x11/libs" | 3 | SECTION = "x11/libs" |
4 | LICENSE = "GPLv2" | 4 | LICENSE = "GPLv2" |
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=9ac2e7cff1ddaf48b6eab6028f23ef88" | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=9ac2e7cff1ddaf48b6eab6028f23ef88" |
6 | |||
6 | DEPENDS = "glib-2.0" | 7 | DEPENDS = "glib-2.0" |
8 | DEPENDS_append_class-target = " ${BPN}-native" | ||
7 | 9 | ||
8 | inherit autotools pkgconfig | 10 | inherit autotools pkgconfig |
9 | 11 | ||
10 | BBCLASSEXTEND = "native" | 12 | BBCLASSEXTEND = "native" |
11 | 13 | ||
12 | SRC_URI = "http://archive.xfce.org/src/xfce/${BPN}/${@'${PV}'[0:4]}/${BPN}-${PV}.tar.bz2" | 14 | SRC_URI = "http://archive.xfce.org/src/xfce/${BPN}/${@'${PV}'[0:4]}/${BPN}-${PV}.tar.bz2" |
13 | SRC_URI[md5sum] = "5f8fc8af73819c08d9e4c26a3ac457e7" | 15 | SRC_URI_append_class-target = " file://0001-Run-native-xdt-csource-on-tests.patch" |
14 | SRC_URI[sha256sum] = "2c9eb8e0fe23e47dc31411a93b683fd1b7a49140e9163f0aab9e94a3d8a0b5fd" | 16 | SRC_URI[sha256sum] = "f50b3070e66f3ebdf331744dd1ec5e1af5de333965d491e15ce05545e8eb4f04" |
15 | 17 | ||
16 | do_install_append() { | 18 | do_install_append() { |
17 | install -d ${D}${datadir}/aclocal | 19 | install -d ${D}${datadir}/aclocal |