diff options
author | Andreas Müller <schnitzeltony@gmx.de> | 2011-09-22 00:48:16 +0200 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-09-22 17:16:28 +0200 |
commit | 89ef404be19d1d23b4ce23c2850c427ab5dcf280 (patch) | |
tree | 502833c1440968556c1407c38cf94008850668d9 /meta-xfce/recipes-xfce/thunar | |
parent | 84f6b67951d46ec630b1a2f347593d5e6b59148c (diff) | |
download | meta-openembedded-89ef404be19d1d23b4ce23c2850c427ab5dcf280.tar.gz |
thunar: Bump to version 1.2.3
fix-segfault-no-icons.patch is now mainline [1]
relative-symlinks-docs.patch is now mainline [2]
[1] http://git.xfce.org/xfce/thunar/commit/?h=xfce-4.8&id=a9a495c31aee0b171807b777b635a480692c6ce7
[2] http://git.xfce.org/xfce/thunar/commit/?h=xfce-4.8&id=432d7abc5b84b7a15bb37d35bb95869d98a824a8
Diffstat (limited to 'meta-xfce/recipes-xfce/thunar')
-rw-r--r-- | meta-xfce/recipes-xfce/thunar/thunar/fix-segfault-no-icons.patch | 61 | ||||
-rw-r--r-- | meta-xfce/recipes-xfce/thunar/thunar/relative-symlinks-docs.patch | 28 | ||||
-rw-r--r-- | meta-xfce/recipes-xfce/thunar/thunar_1.2.3.bb (renamed from meta-xfce/recipes-xfce/thunar/thunar_1.2.2.bb) | 11 |
3 files changed, 4 insertions, 96 deletions
diff --git a/meta-xfce/recipes-xfce/thunar/thunar/fix-segfault-no-icons.patch b/meta-xfce/recipes-xfce/thunar/thunar/fix-segfault-no-icons.patch deleted file mode 100644 index f0ff412dc8..0000000000 --- a/meta-xfce/recipes-xfce/thunar/thunar/fix-segfault-no-icons.patch +++ /dev/null | |||
@@ -1,61 +0,0 @@ | |||
1 | From 5066ca4983d82352fca078525e2be454b263fdfd Mon Sep 17 00:00:00 2001 | ||
2 | From: Andreas Mueller <schnitzeltony@gmx.de> | ||
3 | Date: Thu, 11 Aug 2011 10:00:33 +0200 | ||
4 | Subject: [PATCH] Fix segfaults in case icons are missing or not found | ||
5 | |||
6 | |||
7 | Signed-off-by: Andreas Mueller <schnitzeltony@gmx.de> | ||
8 | --- | ||
9 | thunar/thunar-location-button.c | 7 +++++-- | ||
10 | thunar/thunar-window.c | 13 +++++++++---- | ||
11 | 2 files changed, 14 insertions(+), 6 deletions(-) | ||
12 | |||
13 | diff --git a/thunar/thunar-location-button.c b/thunar/thunar-location-button.c | ||
14 | index 49be1f4..20d7110 100644 | ||
15 | --- a/thunar/thunar-location-button.c | ||
16 | +++ b/thunar/thunar-location-button.c | ||
17 | @@ -462,9 +462,12 @@ thunar_location_button_file_changed (ThunarLocationButton *location_button, | ||
18 | /* update the icon for the image */ | ||
19 | icon_factory = thunar_icon_factory_get_for_icon_theme (icon_theme); | ||
20 | icon = thunar_icon_factory_load_file_icon (icon_factory, file, location_button->file_icon_state, size); | ||
21 | - gtk_image_set_from_pixbuf (GTK_IMAGE (location_button->image), icon); | ||
22 | + if (G_LIKELY (icon != NULL)) | ||
23 | + { | ||
24 | + gtk_image_set_from_pixbuf (GTK_IMAGE (location_button->image), icon); | ||
25 | + g_object_unref (G_OBJECT (icon)); | ||
26 | + } | ||
27 | g_object_unref (G_OBJECT (icon_factory)); | ||
28 | - g_object_unref (G_OBJECT (icon)); | ||
29 | |||
30 | /* show the image widget */ | ||
31 | gtk_widget_show (location_button->image); | ||
32 | diff --git a/thunar/thunar-window.c b/thunar/thunar-window.c | ||
33 | index d258d8f..2ed1af7 100644 | ||
34 | --- a/thunar/thunar-window.c | ||
35 | +++ b/thunar/thunar-window.c | ||
36 | @@ -2410,13 +2410,18 @@ thunar_window_current_directory_changed (ThunarFile *current_directory, | ||
37 | gtk_action_set_sensitive (action, (thunar_file_get_item_count (current_directory) > 0)); | ||
38 | gtk_action_set_visible (action, (thunar_file_is_root (current_directory) && thunar_file_is_trashed (current_directory))); | ||
39 | |||
40 | - /* set window title and icon */ | ||
41 | + /* set window title */ | ||
42 | title = g_strdup_printf ("%s - %s", thunar_file_get_display_name (current_directory), _("File Manager")); | ||
43 | - icon = thunar_icon_factory_load_file_icon (window->icon_factory, current_directory, THUNAR_FILE_ICON_STATE_DEFAULT, 48); | ||
44 | gtk_window_set_title (GTK_WINDOW (window), title); | ||
45 | - gtk_window_set_icon (GTK_WINDOW (window), icon); | ||
46 | - g_object_unref (G_OBJECT (icon)); | ||
47 | g_free (title); | ||
48 | + | ||
49 | + /* set window icon */ | ||
50 | + icon = thunar_icon_factory_load_file_icon (window->icon_factory, current_directory, THUNAR_FILE_ICON_STATE_DEFAULT, 48); | ||
51 | + if (G_LIKELY (icon != NULL)) | ||
52 | + { | ||
53 | + gtk_window_set_icon (GTK_WINDOW (window), icon); | ||
54 | + g_object_unref (G_OBJECT (icon)); | ||
55 | + } | ||
56 | } | ||
57 | |||
58 | |||
59 | -- | ||
60 | 1.7.4.4 | ||
61 | |||
diff --git a/meta-xfce/recipes-xfce/thunar/thunar/relative-symlinks-docs.patch b/meta-xfce/recipes-xfce/thunar/thunar/relative-symlinks-docs.patch deleted file mode 100644 index 26f35be085..0000000000 --- a/meta-xfce/recipes-xfce/thunar/thunar/relative-symlinks-docs.patch +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | From 3123ef0e38d18b6dfda644abeb4da48520aa7cb9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Andreas Mueller <schnitzeltony@gmx.de> | ||
3 | Date: Thu, 21 Jul 2011 23:18:47 +0200 | ||
4 | Subject: [PATCH] docs: On installation create relative paths in symlinks to | ||
5 | images | ||
6 | |||
7 | |||
8 | Signed-off-by: Andreas Mueller <schnitzeltony@gmx.de> | ||
9 | --- | ||
10 | docs/manual/Makefile.am | 2 +- | ||
11 | 1 files changed, 1 insertions(+), 1 deletions(-) | ||
12 | |||
13 | diff --git a/docs/manual/Makefile.am b/docs/manual/Makefile.am | ||
14 | index 57c7c00..5207733 100644 | ||
15 | --- a/docs/manual/Makefile.am | ||
16 | +++ b/docs/manual/Makefile.am | ||
17 | @@ -20,7 +20,7 @@ install-data-local: | ||
18 | done; \ | ||
19 | if test x"$$lang" != x"C" -a ! -d $(srcdir)/images/$$lang; then \ | ||
20 | echo "--- Creating symlink to C images for $$lang"; \ | ||
21 | - ln -sf $(docdir)/html/C/images $(DESTDIR)$(docdir)/html/$$lang/images; \ | ||
22 | + ln -sf ../C/images $(DESTDIR)$(docdir)/html/$$lang/images; \ | ||
23 | fi \ | ||
24 | fi \ | ||
25 | done; | ||
26 | -- | ||
27 | 1.7.4.4 | ||
28 | |||
diff --git a/meta-xfce/recipes-xfce/thunar/thunar_1.2.2.bb b/meta-xfce/recipes-xfce/thunar/thunar_1.2.3.bb index 1c553ab9a3..a4500296d3 100644 --- a/meta-xfce/recipes-xfce/thunar/thunar_1.2.2.bb +++ b/meta-xfce/recipes-xfce/thunar/thunar_1.2.3.bb | |||
@@ -4,15 +4,12 @@ LICENSE = "GPLv2" | |||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
5 | DEPENDS = "exo gtk+ gdk-pixbuf libxfce4util libxfce4ui libsm dbus-glib startup-notification libnotify" | 5 | DEPENDS = "exo gtk+ gdk-pixbuf libxfce4util libxfce4ui libsm dbus-glib startup-notification libnotify" |
6 | 6 | ||
7 | PR = "r1" | 7 | PR = "r0" |
8 | 8 | ||
9 | inherit xfce | 9 | inherit xfce |
10 | 10 | ||
11 | # SRC_URI must follow inherited one | 11 | # SRC_URI must follow inherited one |
12 | SRC_URI = "http://archive.xfce.org/src/xfce/${PN}/${@'${PV}'[0:3]}/Thunar-${PV}.tar.bz2 \ | 12 | SRC_URI = "http://archive.xfce.org/src/xfce/${PN}/${@'${PV}'[0:3]}/Thunar-${PV}.tar.bz2" |
13 | file://relative-symlinks-docs.patch \ | ||
14 | file://fix-segfault-no-icons.patch \ | ||
15 | " | ||
16 | 13 | ||
17 | S = "${WORKDIR}/Thunar-${PV}/" | 14 | S = "${WORKDIR}/Thunar-${PV}/" |
18 | 15 | ||
@@ -27,5 +24,5 @@ FILES_${PN}-dbg += "${libdir}/thunarx-2/.debug/ \ | |||
27 | ${libdir}/xfce4/panel/plugins/.debug/ \ | 24 | ${libdir}/xfce4/panel/plugins/.debug/ \ |
28 | ${libdir}/Thunar/.debug/" | 25 | ${libdir}/Thunar/.debug/" |
29 | 26 | ||
30 | SRC_URI[md5sum] = "a86df0212db71e61f459bda6bc7b7fb6" | 27 | SRC_URI[md5sum] = "0a2c36cdd3cb3a2ab52cbf6055415b85" |
31 | SRC_URI[sha256sum] = "56b07dddde423ae7854c5edd433948a912c27afe2a60689ffc50df3d981e90f6" | 28 | SRC_URI[sha256sum] = "e66aa9ad61a9202e15cc7c5fffc7b961da9ab3b4428f874c1ec8e46eb4ffaca6" |