summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/libxfce4ui
diff options
context:
space:
mode:
authorstephen.arnold42 <stephen.arnold42@gmail.com>2014-03-17 21:34:44 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-03-23 21:53:57 +0100
commitb306212c8919a8638d5e97acfd6262bcbd3401ed (patch)
treedb99bdec09d535fb579b0f5551e93666f4e60183 /meta-xfce/recipes-xfce/libxfce4ui
parent3a41db396dcf787a2167dad101cd2ebf084c5ee0 (diff)
downloadmeta-openembedded-b306212c8919a8638d5e97acfd6262bcbd3401ed.tar.gz
recipes-xfce/libxfce4ui: depends and autotools fixes
Note: this patch (v3) obseletes previous versions libxfce4ui_4.10.0.bb: Upstream changes required autotools and gettext (intl) fixes, as well as moving the autogen stuff to a separate task. Full depends were also added (2 were converted to PACKAGECONFIG options) along with a vendor config option. Signed-off-by: Stephen Arnold <stephen.arnold42@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-xfce/recipes-xfce/libxfce4ui')
-rw-r--r--meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.10.0.bb14
1 files changed, 10 insertions, 4 deletions
diff --git a/meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.10.0.bb b/meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.10.0.bb
index cc63a9f03..1e141c41e 100644
--- a/meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.10.0.bb
+++ b/meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.10.0.bb
@@ -2,9 +2,9 @@ SUMMARY = "Xfce4 Widget library and X Window System interaction"
2SECTION = "x11/libs" 2SECTION = "x11/libs"
3LICENSE = "GPLv2" 3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=252890d9eee26aab7b432e8b8a616475" 4LIC_FILES_CHKSUM = "file://COPYING;md5=252890d9eee26aab7b432e8b8a616475"
5DEPENDS = "gtk+ intltool libxfce4util startup-notification xfconf glade3" 5DEPENDS = "perl-native glib-2.0 gtk+ intltool libxfce4util xfconf xfce4-dev-tools virtual/libx11 libsm libice"
6 6
7inherit xfce 7inherit autotools gettext xfce
8 8
9SRC_URI = " \ 9SRC_URI = " \
10 git://git.xfce.org/xfce/libxfce4ui;protocol=git \ 10 git://git.xfce.org/xfce/libxfce4ui;protocol=git \
@@ -15,9 +15,13 @@ SRCREV = "530b72f50fcbd8cb4b970fcc97be0321bf78183e"
15PV = "4.10.0+git${SRCPV}" 15PV = "4.10.0+git${SRCPV}"
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
17 17
18EXTRA_OECONF += "--enable-maintainer-mode --disable-debug" 18EXTRA_OECONF += "--enable-maintainer-mode --disable-debug --with-vendor-info=${DISTRO}"
19 19
20do_configure_prepend() { 20PACKAGECONFIG ??= ""
21PACKAGECONFIG[gladeui] = "--enable-gladeui,--disable-gladeui,glade3"
22PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-startup-notification,startup-notification"
23
24do_src_prepare() {
21 NOCONFIGURE=yes ./autogen.sh 25 NOCONFIGURE=yes ./autogen.sh
22} 26}
23 27
@@ -27,3 +31,5 @@ FILES_${PN}-dev += "${libdir}/glade3/modules/*.la \
27PACKAGES += "${PN}-glade" 31PACKAGES += "${PN}-glade"
28FILES_${PN}-glade = "${libdir}/glade3 \ 32FILES_${PN}-glade = "${libdir}/glade3 \
29 ${datadir}/glade3" 33 ${datadir}/glade3"
34
35addtask do_src_prepare before do_configure after do_patch