summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2013-01-02 15:16:05 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-01-03 23:25:44 +0100
commit4b5ee45d7030cbe956059876dc1069f6f4c134c2 (patch)
tree5ba7306a67116b744bd4bcd45b168434a79b2a51 /meta-xfce/recipes-xfce/exo/exo_0.10.2.bb
parentd29ca327fb23db312da1904dfea2a66d29eb6e7f (diff)
downloadmeta-openembedded-4b5ee45d7030cbe956059876dc1069f6f4c134c2.tar.gz
exo: update to 0.10.2
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-xfce/recipes-xfce/exo/exo_0.10.2.bb')
-rw-r--r--meta-xfce/recipes-xfce/exo/exo_0.10.2.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb b/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb
new file mode 100644
index 000000000..4fdfd48c0
--- /dev/null
+++ b/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb
@@ -0,0 +1,32 @@
1DESCRIPTION="Application library for the Xfce desktop environment"
2SECTION = "x11"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5DEPENDS = "gtk+ libxfce4util libxfce4ui virtual/libx11 perl-native cairo"
6
7inherit xfce pythonnative
8
9# SRC_URI must follow inherited one
10SRC_URI += " \
11 file://exo-no-tests-0.8.patch \
12 file://configure.patch \
13 file://gnome-mount \
14"
15
16SRC_URI[md5sum] = "c70f2a217811bfba2e62f938d4b8f748"
17SRC_URI[sha256sum] = "b385828bf8a38204da3254b57fdfa25a72694495aa189fabd5040f707eec76ce"
18
19# see http://wiki.xfce.org/gnomemount-replacement
20do_install_append () {
21 install -m 755 -d ${D}${bindir}/exo-mount-wrapper
22 install -m 755 ${WORKDIR}//gnome-mount ${D}${bindir}/exo-mount-wrapper
23}
24
25# Note: python bindings did not work in oe-dev and are about to be moved to
26# pyxfce see http://comments.gmane.org/gmane.comp.desktop.xfce.devel.version4/19560
27FILES_${PN} += "${datadir}/xfce4/ \
28 ${libdir}/xfce4/exo-1 \
29 "
30
31FILES_${PN}-dbg += "${libdir}/gio/modules/.debug \
32 "