summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-panel-plugins
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2018-08-06 01:54:01 -0700
committerKhem Raj <raj.khem@gmail.com>2018-08-08 12:04:13 -0700
commitd986829312541f41afed99752038768027b9d6e7 (patch)
treebf4aeb21853f14cde4d41f53d8aed0926f7c3a0e /meta-xfce/recipes-panel-plugins
parent840814b186c1c8e27bcf63c549f73b2c035200f4 (diff)
downloadmeta-openembedded-d986829312541f41afed99752038768027b9d6e7.tar.gz
xfce4-hotcorner-plugin: fix library install path
The library install path may be ${CMAKE_INSTALL_PREFIX}/lib64 rather than fixed ${CMAKE_INSTALL_PREFIX}/lib. Add a variable in CMakeLists.txt to make it could be overrode by cmake command line. And it is overridden with ${baselib} in meta-oe. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-xfce/recipes-panel-plugins')
-rw-r--r--meta-xfce/recipes-panel-plugins/hotcorner/xfce4-hotcorner-plugin/0001-CMakeLists.txt-fix-library-install-path.patch39
-rw-r--r--meta-xfce/recipes-panel-plugins/hotcorner/xfce4-hotcorner-plugin_0.0.2.bb5
2 files changed, 43 insertions, 1 deletions
diff --git a/meta-xfce/recipes-panel-plugins/hotcorner/xfce4-hotcorner-plugin/0001-CMakeLists.txt-fix-library-install-path.patch b/meta-xfce/recipes-panel-plugins/hotcorner/xfce4-hotcorner-plugin/0001-CMakeLists.txt-fix-library-install-path.patch
new file mode 100644
index 000000000..df348dc85
--- /dev/null
+++ b/meta-xfce/recipes-panel-plugins/hotcorner/xfce4-hotcorner-plugin/0001-CMakeLists.txt-fix-library-install-path.patch
@@ -0,0 +1,39 @@
1Upstream-Status: Submitted [https://github.com/brianhsu/xfce4-hotcorner-plugin/pull/8]
2
3The library install path may be ${CMAKE_INSTALL_PREFIX}/lib64 rather
4than fixed ${CMAKE_INSTALL_PREFIX}/lib. Provide a variable to make it
5could override by cmake command line.
6
7Signed-off-by: Kai Kang <kai.kang@windriver.com>
8---
9 CMakeLists.txt | 7 ++++---
10 1 file changed, 4 insertions(+), 3 deletions(-)
11
12diff --git a/CMakeLists.txt b/CMakeLists.txt
13index e193787..84cb52d 100644
14--- a/CMakeLists.txt
15+++ b/CMakeLists.txt
16@@ -10,8 +10,9 @@ include(GNUInstallDirs)
17
18 PKG_CHECK_MODULES(GTK REQUIRED libxfce4panel-1.0 libxfce4ui-1 libwnck-3.0)
19
20-set(CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/lib)
21-set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/lib)
22+set(BASE_LIB_PATH "lib" CACHE STRING "base library install path")
23+set(CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/${BASE_LIB_PATH})
24+set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/${BASE_LIB_PATH})
25 set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin)
26
27 INCLUDE_DIRECTORIES(${GTK_INCLUDE_DIRS})
28@@ -28,7 +29,7 @@ ADD_LIBRARY(hotcorner SHARED src/hotcorner.c src/util.c)
29
30 TARGET_LINK_LIBRARIES(hotcorner ${GTK_LIBRARIES})
31
32-INSTALL(TARGETS hotcorner LIBRARY DESTINATION lib/xfce4/panel/plugins/)
33+INSTALL(TARGETS hotcorner LIBRARY DESTINATION ${BASE_LIB_PATH}/xfce4/panel/plugins/)
34 INSTALL(FILES hotcorner.desktop DESTINATION share/xfce4/panel/plugins/)
35 GETTEXT_CREATE_TRANSLATIONS(po/xfce4-hotcorner-plugin.pot ALL po/zh_TW.po)
36
37--
382.11.0
39
diff --git a/meta-xfce/recipes-panel-plugins/hotcorner/xfce4-hotcorner-plugin_0.0.2.bb b/meta-xfce/recipes-panel-plugins/hotcorner/xfce4-hotcorner-plugin_0.0.2.bb
index f86c92ed2..57a815b1b 100644
--- a/meta-xfce/recipes-panel-plugins/hotcorner/xfce4-hotcorner-plugin_0.0.2.bb
+++ b/meta-xfce/recipes-panel-plugins/hotcorner/xfce4-hotcorner-plugin_0.0.2.bb
@@ -6,6 +6,9 @@ inherit xfce-panel-plugin cmake
6 6
7DEPENDS += "libwnck3" 7DEPENDS += "libwnck3"
8 8
9SRC_URI = "https://github.com/brianhsu/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.gz" 9SRC_URI = "https://github.com/brianhsu/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.gz \
10 file://0001-CMakeLists.txt-fix-library-install-path.patch"
10SRC_URI[md5sum] = "ac31b45cda1867cb6bd69bb285638263" 11SRC_URI[md5sum] = "ac31b45cda1867cb6bd69bb285638263"
11SRC_URI[sha256sum] = "942684c92f96a158e1417e597947f822769ac56aa1993a8c9f166ee633ef2b8d" 12SRC_URI[sha256sum] = "942684c92f96a158e1417e597947f822769ac56aa1993a8c9f166ee633ef2b8d"
13
14EXTRA_OECMAKE = "-DBASE_LIB_PATH=${baselib}"