diff options
author | Andreas Müller <schnitzeltony@googlemail.com> | 2017-04-12 17:29:46 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-18 14:21:51 +0200 |
commit | 33b05cc85b89c2982d7ef81d0b349ef522bda2de (patch) | |
tree | 0b65d1abfb9c22c800a2b1462d07aec689bd316f /meta-xfce/recipes-panel-plugins | |
parent | 4f25ed6dfacc38ae98ad641ce3af7ab90122158d (diff) | |
download | meta-openembedded-33b05cc85b89c2982d7ef81d0b349ef522bda2de.tar.gz |
xfce4-closebutton-plugin: Upstream clang-fix-patch
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'meta-xfce/recipes-panel-plugins')
2 files changed, 2 insertions, 66 deletions
diff --git a/meta-xfce/recipes-panel-plugins/closebutton/xfce4-closebutton-plugin/0001-Use-g_return_val_if_fail-in-functions-expecting-a-re.patch b/meta-xfce/recipes-panel-plugins/closebutton/xfce4-closebutton-plugin/0001-Use-g_return_val_if_fail-in-functions-expecting-a-re.patch deleted file mode 100644 index 2e824ec0d..000000000 --- a/meta-xfce/recipes-panel-plugins/closebutton/xfce4-closebutton-plugin/0001-Use-g_return_val_if_fail-in-functions-expecting-a-re.patch +++ /dev/null | |||
@@ -1,62 +0,0 @@ | |||
1 | From b0bda2dfc2d8d7bb244e59897b5bf0776f4fe44c Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 22 Mar 2017 15:07:26 -0700 | ||
4 | Subject: [PATCH] Use g_return_val_if_fail() in functions expecting a return | ||
5 | value | ||
6 | |||
7 | Clang detects that we are not returning any value when function | ||
8 | expects it. | ||
9 | |||
10 | Fixes | ||
11 | |||
12 | | ../../git/panel-plugin/closebutton.c:170:3: error: non-void function 'closebutton_plugin_set_icon' should return a value [-Wreturn-type] | ||
13 | | g_return_if_fail (XFCE_IS_PANEL_IMAGE (icon)); | ||
14 | |||
15 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
16 | --- | ||
17 | Upstream-Status: Pending | ||
18 | |||
19 | panel-plugin/closebutton-settings.c | 2 +- | ||
20 | panel-plugin/closebutton.c | 6 +++--- | ||
21 | 2 files changed, 4 insertions(+), 4 deletions(-) | ||
22 | |||
23 | diff --git a/panel-plugin/closebutton-settings.c b/panel-plugin/closebutton-settings.c | ||
24 | index f2fa370..d4e6b0c 100644 | ||
25 | --- a/panel-plugin/closebutton-settings.c | ||
26 | +++ b/panel-plugin/closebutton-settings.c | ||
27 | @@ -60,7 +60,7 @@ closebutton_builder_new (XfcePanelPlugin *panel_plugin, | ||
28 | GtkBuilder *builder; | ||
29 | GObject *dialog, *button; | ||
30 | |||
31 | - g_return_if_fail (XFCE_IS_PANEL_PLUGIN (panel_plugin)); | ||
32 | + g_return_val_if_fail (XFCE_IS_PANEL_PLUGIN (panel_plugin), 0); | ||
33 | |||
34 | builder = gtk_builder_new (); | ||
35 | if (gtk_builder_add_from_string (builder, buffer, length, &error)) | ||
36 | diff --git a/panel-plugin/closebutton.c b/panel-plugin/closebutton.c | ||
37 | index fd0a7b5..2120728 100644 | ||
38 | --- a/panel-plugin/closebutton.c | ||
39 | +++ b/panel-plugin/closebutton.c | ||
40 | @@ -167,8 +167,8 @@ closebutton_plugin_set_icon (CloseButtonPlugin *plugin, gboolean force_reload) | ||
41 | XfcePanelPlugin *panel_plugin = XFCE_PANEL_PLUGIN (plugin); | ||
42 | XfcePanelImage *icon = XFCE_PANEL_IMAGE (plugin->icon); | ||
43 | |||
44 | - g_return_if_fail (XFCE_IS_PANEL_IMAGE (icon)); | ||
45 | - g_return_if_fail (XFCE_IS_CLOSEBUTTON_PLUGIN (plugin)); | ||
46 | + g_return_val_if_fail (XFCE_IS_PANEL_IMAGE (icon), 0); | ||
47 | + g_return_val_if_fail (XFCE_IS_CLOSEBUTTON_PLUGIN (plugin), 0); | ||
48 | |||
49 | window = closebutton_plugin_get_effective_window (plugin); | ||
50 | if (window != NULL) | ||
51 | @@ -404,7 +404,7 @@ closebutton_plugin_size_changed (XfcePanelPlugin *panel_plugin, | ||
52 | gint size) | ||
53 | { | ||
54 | CloseButtonPlugin *plugin = XFCE_CLOSEBUTTON_PLUGIN (panel_plugin); | ||
55 | - g_return_if_fail (XFCE_IS_CLOSEBUTTON_PLUGIN (plugin)); | ||
56 | + g_return_val_if_fail (XFCE_IS_CLOSEBUTTON_PLUGIN (plugin), 0); | ||
57 | |||
58 | #if LIBXFCE4PANEL_CHECK_VERSION(4,9,0) | ||
59 | size /= xfce_panel_plugin_get_nrows (panel_plugin); | ||
60 | -- | ||
61 | 2.12.0 | ||
62 | |||
diff --git a/meta-xfce/recipes-panel-plugins/closebutton/xfce4-closebutton-plugin_git.bb b/meta-xfce/recipes-panel-plugins/closebutton/xfce4-closebutton-plugin_git.bb index 746b1222a..3cd4ee65e 100644 --- a/meta-xfce/recipes-panel-plugins/closebutton/xfce4-closebutton-plugin_git.bb +++ b/meta-xfce/recipes-panel-plugins/closebutton/xfce4-closebutton-plugin_git.bb | |||
@@ -9,10 +9,8 @@ DEPENDS += "exo-native libwnck xfconf" | |||
9 | 9 | ||
10 | PV = "0.1.0+gitr${SRCPV}" | 10 | PV = "0.1.0+gitr${SRCPV}" |
11 | 11 | ||
12 | SRC_URI = "git://github.com/schnitzeltony/xfce4-closebutton-plugin.git;branch=master \ | 12 | SRC_URI = "git://github.com/schnitzeltony/xfce4-closebutton-plugin.git;branch=master" |
13 | file://0001-Use-g_return_val_if_fail-in-functions-expecting-a-re.patch \ | 13 | SRCREV = "02b74f13ad6f639234c8db1854963038b2780a2c" |
14 | " | ||
15 | SRCREV = "bd76154afe26ba8a5251a1887d88f9d855301850" | ||
16 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
17 | 15 | ||
18 | EXTRA_OECONF += "--enable-maintainer-mode" | 16 | EXTRA_OECONF += "--enable-maintainer-mode" |