summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-panel-plugins
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmx.de>2012-01-15 00:41:38 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-01-15 10:09:41 +0100
commitc4e7f781f9c194934288d69f4d31e5d0143979af (patch)
tree47b7f1b166365230505b665f651ccd1846aba614 /meta-xfce/recipes-panel-plugins
parent8741e35957eeb4392ca9a340f63095beddb779df (diff)
downloadmeta-openembedded-c4e7f781f9c194934288d69f4d31e5d0143979af.tar.gz
xfce4-netload-plugin: update to 1.1.0
Signed-off-by: Andreas Müller <schnitzeltony@gmx.de> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-xfce/recipes-panel-plugins')
-rw-r--r--meta-xfce/recipes-panel-plugins/netload/files/port-to-libxfce4ui.patch72
-rw-r--r--meta-xfce/recipes-panel-plugins/netload/xfce4-netload-plugin_1.1.0.bb (renamed from meta-xfce/recipes-panel-plugins/netload/xfce4-netload-plugin_1.0.0.bb)6
2 files changed, 2 insertions, 76 deletions
diff --git a/meta-xfce/recipes-panel-plugins/netload/files/port-to-libxfce4ui.patch b/meta-xfce/recipes-panel-plugins/netload/files/port-to-libxfce4ui.patch
deleted file mode 100644
index 55bdffc3d..000000000
--- a/meta-xfce/recipes-panel-plugins/netload/files/port-to-libxfce4ui.patch
+++ /dev/null
@@ -1,72 +0,0 @@
1From 95fcb98d0189c3f9a051b56416503b42ac29ff90 Mon Sep 17 00:00:00 2001
2From: Christoph J. Thompson <cjsthompson@gmail.com>
3Date: Tue, 11 Jan 2011 16:17:48 +0100
4Subject: [PATCH 1/2] Port to libxfce4ui.
5
6 modified: configure.ac
7 modified: panel-plugin/Makefile.am
8 modified: panel-plugin/netload.c
9---
10 configure.ac | 2 +-
11 panel-plugin/Makefile.am | 4 ++--
12 panel-plugin/netload.c | 5 +++--
13 3 files changed, 6 insertions(+), 5 deletions(-)
14
15diff --git a/configure.ac b/configure.ac
16index 0348bfa..3baaa14 100644
17--- a/configure.ac
18+++ b/configure.ac
19@@ -56,7 +56,7 @@ dnl configure the panel plugin
20 XDT_CHECK_PACKAGE([LIBXFCE4PANEL], [libxfce4panel-1.0], [4.3.20])
21
22 dnl configure the libxfcegui4
23-XDT_CHECK_PACKAGE([LIBXFCEGUI4], [libxfcegui4-1.0], [4.4.0])
24+XDT_CHECK_PACKAGE([LIBXFCE4UI], [libxfce4ui-1], [4.7.0])
25
26 dnl Check for i18n support
27 XDT_I18N([@LINGUAS@])
28diff --git a/panel-plugin/Makefile.am b/panel-plugin/Makefile.am
29index 0635d67..2163277 100644
30--- a/panel-plugin/Makefile.am
31+++ b/panel-plugin/Makefile.am
32@@ -17,12 +17,12 @@ xfce4_netload_plugin_SOURCES = \
33 xfce4_netload_plugin_CFLAGS = \
34 -DPACKAGE_LOCALE_DIR=\"$(localedir)\" \
35 @LIBXFCE4PANEL_CFLAGS@ \
36- @LIBXFCEGUI4_CFLAGS@
37+ @LIBXFCE4UI_CFLAGS@
38
39 xfce4_netload_plugin_LDADD = \
40 @SOLLIBS@ \
41 @LIBXFCE4PANEL_LIBS@ \
42- @LIBXFCEGUI4_LIBS@
43+ @LIBXFCE4UI_LIBS@
44
45 # .desktop file
46 #
47diff --git a/panel-plugin/netload.c b/panel-plugin/netload.c
48index b4868c4..43035f2 100644
49--- a/panel-plugin/netload.c
50+++ b/panel-plugin/netload.c
51@@ -30,7 +30,7 @@
52 #include <gtk/gtk.h>
53
54 #include <libxfce4util/libxfce4util.h>
55-#include <libxfcegui4/libxfcegui4.h>
56+#include <libxfce4ui/libxfce4ui.h>
57 #include <libxfce4panel/xfce-panel-plugin.h>
58
59
60@@ -460,7 +460,8 @@ static void setup_monitor(t_global_monitor *global, gboolean supress_warnings)
61 if (!init_netload( &(global->monitor->data), global->monitor->options.network_device)
62 && !supress_warnings)
63 {
64- xfce_err (_("%s: Error in initalizing:\n%s"),
65+ xfce_dialog_show_error (NULL, NULL,
66+ _("%s: Error in initalizing:\n%s"),
67 _(APP_NAME),
68 _(errormessages[
69 global->monitor->data.errorcode == 0
70--
711.7.1
72
diff --git a/meta-xfce/recipes-panel-plugins/netload/xfce4-netload-plugin_1.0.0.bb b/meta-xfce/recipes-panel-plugins/netload/xfce4-netload-plugin_1.1.0.bb
index a0013b4f5..5dba77adc 100644
--- a/meta-xfce/recipes-panel-plugins/netload/xfce4-netload-plugin_1.0.0.bb
+++ b/meta-xfce/recipes-panel-plugins/netload/xfce4-netload-plugin_1.1.0.bb
@@ -5,7 +5,5 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=35a7203c41b86d15546dddc05995f97f"
5 5
6inherit xfce-panel-plugin 6inherit xfce-panel-plugin
7 7
8# SRC_URI must follow inherited one 8SRC_URI[md5sum] = "19bee8171e7d681cb79539417f0b5917"
9SRC_URI += "file://port-to-libxfce4ui.patch" 9SRC_URI[sha256sum] = "8a33dfed24a7bbd8eaf333524f94eb24e7d3a14ffccb181e5cab1d1b05ae3bf7"
10SRC_URI[md5sum] = "cab53e8cc2b9bfdf7ffd2230916ca3df"
11SRC_URI[sha256sum] = "f312d19fc6bfae525886a1f6e84e7d839f19a9f672be4e01f3df1c813f6a6032"