diff options
author | Andreas Müller <schnitzeltony@gmail.com> | 2021-01-06 16:17:10 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-01-06 14:20:51 -0800 |
commit | 1f850bd714c3394db6c2dcc564d8259ec8310703 (patch) | |
tree | 0415a2c49d1e03624bda46fff54044868af45b4a /meta-xfce/recipes-panel-plugins/sensors | |
parent | 67e455a1c00e305a3d04da8b7d81ffb609effeb4 (diff) | |
download | meta-openembedded-1f850bd714c3394db6c2dcc564d8259ec8310703.tar.gz |
xfce4-sensors-plugin: upgrade 1.3.92 -> 1.3.95
First version compatible to xfce 4.16
Release notes for 1.3.95
========================
Updated translations;
code cleanups (thanks to all contributors and Xfce dev team);
compatibility to Xfce 4.16.
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-xfce/recipes-panel-plugins/sensors')
-rw-r--r-- | meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin/0001-Fix-multiple-definition-errors-under-GCC-10.0.patch | 118 | ||||
-rw-r--r-- | meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.3.95.bb (renamed from meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.3.92.bb) | 7 |
2 files changed, 2 insertions, 123 deletions
diff --git a/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin/0001-Fix-multiple-definition-errors-under-GCC-10.0.patch b/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin/0001-Fix-multiple-definition-errors-under-GCC-10.0.patch deleted file mode 100644 index 30cb487c8..000000000 --- a/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin/0001-Fix-multiple-definition-errors-under-GCC-10.0.patch +++ /dev/null | |||
@@ -1,118 +0,0 @@ | |||
1 | From 6c6de7c07290248a3c72a50c7790885ee4bc13a2 Mon Sep 17 00:00:00 2001 | ||
2 | From: Robin Lee <cheeselee@fedoraproject.org> | ||
3 | Date: Mon, 24 Feb 2020 17:52:39 +0800 | ||
4 | Subject: [PATCH] Fix multiple definition errors under GCC 10.0 | ||
5 | |||
6 | Fixes #16436, RHBZ#1800268 | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | include/sensors-interface-common.h | 22 ++++++++++++++-------- | ||
12 | lib/sensors-interface-common.c | 1 + | ||
13 | 2 files changed, 15 insertions(+), 8 deletions(-) | ||
14 | |||
15 | diff --git a/include/sensors-interface-common.h b/include/sensors-interface-common.h | ||
16 | index 62a27eb..05146c5 100644 | ||
17 | --- a/include/sensors-interface-common.h | ||
18 | +++ b/include/sensors-interface-common.h | ||
19 | @@ -146,6 +146,12 @@ t_sensors_dialog; | ||
20 | |||
21 | |||
22 | |||
23 | +#ifdef XFCE4_SENSORS_INTERFACE_COMMON_DEFINING | ||
24 | +#define EXTERN | ||
25 | +#else | ||
26 | +#define EXTERN extern | ||
27 | +#endif | ||
28 | + | ||
29 | /* Extern functions that need to be re-implemented in the sensors-viewer and | ||
30 | * the panel code. | ||
31 | * They kind of need to be registered at the library by any software | ||
32 | @@ -157,7 +163,7 @@ t_sensors_dialog; | ||
33 | * @param ptr_widget: Pointer to original widget, i.e, the update timer box | ||
34 | * @param ptr_sensorsdialog: argument pointer to sensors dialog data | ||
35 | */ | ||
36 | -void | ||
37 | +EXTERN void | ||
38 | (*adjustment_value_changed) (GtkWidget *ptr_widget, | ||
39 | t_sensors_dialog *ptr_sensorsdialog); | ||
40 | |||
41 | @@ -167,7 +173,7 @@ void | ||
42 | * @param ptr_widget: Pointer to original widget, i.e, the sensor entry combobox | ||
43 | * @param ptr_sensorsdialog: argument pointer to sensors dialog data | ||
44 | */ | ||
45 | -void | ||
46 | +EXTERN void | ||
47 | (*sensor_entry_changed) (GtkWidget *ptr_widget, | ||
48 | t_sensors_dialog *ptr_sensorsdialog); | ||
49 | |||
50 | @@ -178,7 +184,7 @@ void | ||
51 | * @param ptr_str_newtext: Pointer to the string containing the new label | ||
52 | * @param ptr_sensorsdialog: argument pointer to sensors dialog data | ||
53 | */ | ||
54 | -void | ||
55 | +EXTERN void | ||
56 | (*list_cell_text_edited) (GtkCellRendererText *ptr_cellrenderertext, | ||
57 | gchar *ptr_str_path, gchar *ptr_str_newtext, | ||
58 | t_sensors_dialog *ptr_sensorsdialog); | ||
59 | @@ -189,7 +195,7 @@ void | ||
60 | * @param ptr_str_path: pointer to the string with the path of the changed item | ||
61 | * @param ptr_sensorsdialog: argument pointer to sensors dialog data | ||
62 | */ | ||
63 | -void | ||
64 | +EXTERN void | ||
65 | (*list_cell_toggle) (GtkCellRendererToggle *ptr_cellrenderertoggle, gchar *ptr_str_path, | ||
66 | t_sensors_dialog *ptr_sensorsdialog); | ||
67 | |||
68 | @@ -201,7 +207,7 @@ void | ||
69 | * hexadecimal rgb format #0011ff | ||
70 | * @param ptr_sensorsdialog: argument pointer to sensors dialog data | ||
71 | */ | ||
72 | -void | ||
73 | +EXTERN void | ||
74 | (*list_cell_color_edited) (GtkCellRendererText *ptr_cellrenderertext, | ||
75 | gchar *ptr_str_path, gchar *ptr_str_newcolor, | ||
76 | t_sensors_dialog *ptr_sensorsdialog); | ||
77 | @@ -214,7 +220,7 @@ void | ||
78 | * temperature | ||
79 | * @param ptr_sensorsdialog: argument pointer to sensors dialog data | ||
80 | */ | ||
81 | -void | ||
82 | +EXTERN void | ||
83 | (*minimum_changed) (GtkCellRendererText *ptr_cellrenderertext, gchar *ptr_str_path, | ||
84 | gchar *ptr_str_newmin, t_sensors_dialog *ptr_sensorsdialog); | ||
85 | |||
86 | @@ -226,7 +232,7 @@ void | ||
87 | * temperature | ||
88 | * @param ptr_sensorsdialog: argument pointer to sensors dialog data | ||
89 | */ | ||
90 | -void | ||
91 | +EXTERN void | ||
92 | (*maximum_changed) (GtkCellRendererText *ptr_cellrenderertext, gchar *ptr_str_path, | ||
93 | gchar *ptr_str_newmax, t_sensors_dialog *ptr_sensorsdialog); | ||
94 | |||
95 | @@ -236,7 +242,7 @@ void | ||
96 | * @param ptr_widget: Pointer to original widget, i.e, the update timer box | ||
97 | * @param ptr_sensorsdialog: argument pointer to sensors dialog data | ||
98 | */ | ||
99 | -void | ||
100 | +EXTERN void | ||
101 | (*temperature_unit_change) (GtkWidget *ptr_widget, | ||
102 | t_sensors_dialog *ptr_sensorsdialog); | ||
103 | |||
104 | diff --git a/lib/sensors-interface-common.c b/lib/sensors-interface-common.c | ||
105 | index 70aa154..8c79f1d 100644 | ||
106 | --- a/lib/sensors-interface-common.c | ||
107 | +++ b/lib/sensors-interface-common.c | ||
108 | @@ -28,6 +28,7 @@ | ||
109 | #include <libxfce4panel/xfce-panel-plugin.h> | ||
110 | |||
111 | /* Local/package includes */ | ||
112 | +#define XFCE4_SENSORS_INTERFACE_COMMON_DEFINING | ||
113 | #include <configuration.h> | ||
114 | #include <sensors-interface-common.h> | ||
115 | #include <middlelayer.h> | ||
116 | -- | ||
117 | 2.24.1 | ||
118 | |||
diff --git a/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.3.92.bb b/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.3.95.bb index aa5fe019d..3c7fa9a91 100644 --- a/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.3.92.bb +++ b/meta-xfce/recipes-panel-plugins/sensors/xfce4-sensors-plugin_1.3.95.bb | |||
@@ -5,11 +5,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b94789bed9aec03b9656a9cc5398c706" | |||
5 | 5 | ||
6 | inherit xfce-panel-plugin | 6 | inherit xfce-panel-plugin |
7 | 7 | ||
8 | SRC_URI[md5sum] = "7327c4c316ebd5d93665e77b432b8d89" | 8 | SRC_URI[sha256sum] = "83c64ae4618dd592971cfa0bc285a9b47af801a3ed856835cdb2a4c533c7846c" |
9 | SRC_URI[sha256sum] = "3dc6643d2c064b7718badff44b948f8d410f00f13db197820b26ae38045f5112" | 9 | SRC_URI += "file://0001-Do-not-check-for-sys-class-power_supply-we-are-cross.patch" |
10 | SRC_URI += "file://0001-Do-not-check-for-sys-class-power_supply-we-are-cross.patch \ | ||
11 | file://0001-Fix-multiple-definition-errors-under-GCC-10.0.patch \ | ||
12 | " | ||
13 | 10 | ||
14 | EXTRA_OECONF = " \ | 11 | EXTRA_OECONF = " \ |
15 | --disable-procacpi \ | 12 | --disable-procacpi \ |