diff options
author | Andreas Müller <schnitzeltony@googlemail.com> | 2012-01-29 21:30:56 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-01-30 13:03:39 +0100 |
commit | 748d7291ee23f861f9c8bade208031ae435f9360 (patch) | |
tree | 2d4eb711fa9cb241d4a4f7bb195a41fb562b7954 /meta-xfce/recipes-panel-plugins/genmon | |
parent | 22fd51e703d002a2063034a7c7398edc56aa2b3e (diff) | |
download | meta-openembedded-748d7291ee23f861f9c8bade208031ae435f9360.tar.gz |
xfce4-genmon-plugin: initial add 3.3.1
* build tested from scratch
* run tested on overo
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-xfce/recipes-panel-plugins/genmon')
-rw-r--r-- | meta-xfce/recipes-panel-plugins/genmon/files/port-to-libxfce4ui.patch | 150 | ||||
-rw-r--r-- | meta-xfce/recipes-panel-plugins/genmon/xfce4-genmon-plugin_3.3.1.bb | 11 |
2 files changed, 161 insertions, 0 deletions
diff --git a/meta-xfce/recipes-panel-plugins/genmon/files/port-to-libxfce4ui.patch b/meta-xfce/recipes-panel-plugins/genmon/files/port-to-libxfce4ui.patch new file mode 100644 index 000000000..b615fe5e7 --- /dev/null +++ b/meta-xfce/recipes-panel-plugins/genmon/files/port-to-libxfce4ui.patch | |||
@@ -0,0 +1,150 @@ | |||
1 | From 57e2a3787261ccc33f47d4d4061148d720d88d7d Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com> | ||
3 | Date: Thu, 26 Jan 2012 00:45:31 +0100 | ||
4 | Subject: [PATCH] port to libxfce4ui | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | Upstream status: pending https://bugzilla.xfce.org/show_bug.cgi?id=8406 | ||
9 | |||
10 | |||
11 | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> | ||
12 | --- | ||
13 | configure.ac | 4 ++-- | ||
14 | panel-plugin/Makefile.am | 4 ++-- | ||
15 | panel-plugin/cmdspawn.c | 2 +- | ||
16 | panel-plugin/config_gui.c | 2 +- | ||
17 | panel-plugin/config_gui.h | 1 - | ||
18 | panel-plugin/main.c | 17 ++++++----------- | ||
19 | 6 files changed, 12 insertions(+), 18 deletions(-) | ||
20 | |||
21 | diff --git a/configure.ac b/configure.ac | ||
22 | index b9d5bd3..a04d0ec 100644 | ||
23 | --- a/configure.ac | ||
24 | +++ b/configure.ac | ||
25 | @@ -31,8 +31,8 @@ dnl Check for standard header files | ||
26 | AC_HEADER_STDC | ||
27 | |||
28 | dnl configure the panel plugin | ||
29 | -XDT_CHECK_PACKAGE([LIBXFCE4PANEL], [libxfce4panel-1.0], [4.3.22]) | ||
30 | -XDT_CHECK_PACKAGE([LIBXFCEGUI4], [libxfcegui4-1.0], [4.2.0]) | ||
31 | +XDT_CHECK_PACKAGE([LIBXFCE4PANEL], [libxfce4panel-1.0], [4.8.0]) | ||
32 | +XDT_CHECK_PACKAGE([LIBXFCE4UI], [libxfce4ui-1], [4.8.0]) | ||
33 | |||
34 | dnl Translations | ||
35 | XDT_I18N([@LINGUAS@]) | ||
36 | diff --git a/panel-plugin/Makefile.am b/panel-plugin/Makefile.am | ||
37 | index 861a466..f819ff6 100644 | ||
38 | --- a/panel-plugin/Makefile.am | ||
39 | +++ b/panel-plugin/Makefile.am | ||
40 | @@ -4,11 +4,11 @@ plugin_PROGRAMS = xfce4-genmon-plugin | ||
41 | xfce4_genmon_plugin_CFLAGS = \ | ||
42 | -DPACKAGE_LOCALE_DIR=\"$(localedir)\" \ | ||
43 | @LIBXFCE4PANEL_CFLAGS@ \ | ||
44 | - @LIBXFCEGUI4_CFLAGS@ | ||
45 | + @LIBXFCE4UI_CFLAGS@ | ||
46 | |||
47 | xfce4_genmon_plugin_LDADD = \ | ||
48 | @LIBXFCE4PANEL_LIBS@ \ | ||
49 | - @LIBXFCEGUI4_LIBS@ | ||
50 | + @LIBXFCE4UI_LIBS@ | ||
51 | |||
52 | xfce4_genmon_plugin_SOURCES = \ | ||
53 | main.c \ | ||
54 | diff --git a/panel-plugin/cmdspawn.c b/panel-plugin/cmdspawn.c | ||
55 | index aef7689..ae9de82 100644 | ||
56 | --- a/panel-plugin/cmdspawn.c | ||
57 | +++ b/panel-plugin/cmdspawn.c | ||
58 | @@ -49,7 +49,7 @@ | ||
59 | #include <stdarg.h> | ||
60 | #include <errno.h> | ||
61 | #include <sys/wait.h> | ||
62 | -#include <libxfcegui4/libxfcegui4.h> | ||
63 | +#include <libxfce4ui/libxfce4ui.h> | ||
64 | |||
65 | |||
66 | /**********************************************************************/ | ||
67 | diff --git a/panel-plugin/config_gui.c b/panel-plugin/config_gui.c | ||
68 | index 49ef267..3550c35 100644 | ||
69 | --- a/panel-plugin/config_gui.c | ||
70 | +++ b/panel-plugin/config_gui.c | ||
71 | @@ -28,7 +28,7 @@ | ||
72 | #include <gtk/gtk.h> | ||
73 | |||
74 | #include <libxfce4util/libxfce4util.h> | ||
75 | -#include <libxfcegui4/dialogs.h> | ||
76 | +#include <libxfce4ui/libxfce4ui.h> | ||
77 | #include <libxfce4panel/xfce-panel-plugin.h> | ||
78 | |||
79 | |||
80 | diff --git a/panel-plugin/config_gui.h b/panel-plugin/config_gui.h | ||
81 | index 84024b2..c6bb672 100644 | ||
82 | --- a/panel-plugin/config_gui.h | ||
83 | +++ b/panel-plugin/config_gui.h | ||
84 | @@ -29,7 +29,6 @@ | ||
85 | #include <gtk/gtk.h> | ||
86 | |||
87 | #include <libxfce4util/libxfce4util.h> | ||
88 | -#include <libxfcegui4/dialogs.h> | ||
89 | #include <libxfce4panel/xfce-panel-plugin.h> | ||
90 | |||
91 | |||
92 | diff --git a/panel-plugin/main.c b/panel-plugin/main.c | ||
93 | index 1f741ee..14cf778 100644 | ||
94 | --- a/panel-plugin/main.c | ||
95 | +++ b/panel-plugin/main.c | ||
96 | @@ -31,8 +31,7 @@ | ||
97 | #include <gtk/gtk.h> | ||
98 | |||
99 | #include <libxfce4util/libxfce4util.h> | ||
100 | -#include <libxfcegui4/dialogs.h> | ||
101 | -#include <libxfcegui4/xfce-exec.h> | ||
102 | +#include <libxfce4ui/libxfce4ui.h> | ||
103 | #include <libxfce4panel/xfce-panel-plugin.h> | ||
104 | #include <libxfce4panel/xfce-panel-convenience.h> | ||
105 | |||
106 | @@ -98,7 +97,7 @@ static void ExecOnClickCmd (Widget_t p_wSc, void *p_pvPlugin) | ||
107 | struct monitor_t *poMonitor = &(poPlugin->oMonitor); | ||
108 | GError *error = NULL; | ||
109 | |||
110 | - xfce_exec(poMonitor->onClickCmd, 0, 0, &error); | ||
111 | + xfce_spawn_command_line_on_screen( gdk_screen_get_default(), poMonitor->onClickCmd, 0, 0, &error ); | ||
112 | if (error) { | ||
113 | char first[256]; | ||
114 | g_snprintf (first, sizeof(first), _("Could not run \"%s\""), poMonitor->onClickCmd); | ||
115 | @@ -592,7 +591,8 @@ static void UpdateConf (void *p_pvPlugin) | ||
116 | static void About (Widget_t w, void *unused) | ||
117 | /* Called back when the About button in clicked */ | ||
118 | { | ||
119 | - xfce_info (_("%s %s - Generic Monitor\n" | ||
120 | + xfce_dialog_show_info (NULL, NULL, | ||
121 | + _("%s %s - Generic Monitor\n" | ||
122 | "Cyclically spawns a script/program, captures its output " | ||
123 | "and displays the resulting string in the panel\n\n" | ||
124 | "(c) 2004 Roger Seguin <roger_seguin@msn.com>\n" | ||
125 | @@ -646,7 +646,7 @@ static void genmon_create_options (XfcePanelPlugin *plugin, | ||
126 | /* Plugin API */ | ||
127 | /* Create/pop up the configuration/options GUI */ | ||
128 | { | ||
129 | - GtkWidget *dlg, *header, *vbox; | ||
130 | + GtkWidget *dlg, *vbox; | ||
131 | struct param_t *poConf = &(poPlugin->oConf.oParam); | ||
132 | struct gui_t *poGUI = &(poPlugin->oConf.oGUI); | ||
133 | const char *pcFont = poConf->acFont; | ||
134 | @@ -667,12 +667,7 @@ static void genmon_create_options (XfcePanelPlugin *plugin, | ||
135 | |||
136 | gtk_container_set_border_width (GTK_CONTAINER (dlg), 2); | ||
137 | |||
138 | - header = xfce_create_header (NULL, _("Generic Monitor")); | ||
139 | - gtk_widget_set_size_request (GTK_BIN (header)->child, -1, 32); | ||
140 | - gtk_container_set_border_width (GTK_CONTAINER (header), BORDER - 2); | ||
141 | - gtk_widget_show (header); | ||
142 | - gtk_box_pack_start (GTK_BOX (GTK_DIALOG (dlg)->vbox), header, | ||
143 | - FALSE, TRUE, 0); | ||
144 | + xfce_titled_dialog_set_subtitle (XFCE_TITLED_DIALOG (dlg), _("Generic Monitor")); | ||
145 | |||
146 | vbox = gtk_vbox_new(FALSE, BORDER); | ||
147 | gtk_container_set_border_width (GTK_CONTAINER (vbox), BORDER - 2); | ||
148 | -- | ||
149 | 1.7.4.4 | ||
150 | |||
diff --git a/meta-xfce/recipes-panel-plugins/genmon/xfce4-genmon-plugin_3.3.1.bb b/meta-xfce/recipes-panel-plugins/genmon/xfce4-genmon-plugin_3.3.1.bb new file mode 100644 index 000000000..d2ed4fee7 --- /dev/null +++ b/meta-xfce/recipes-panel-plugins/genmon/xfce4-genmon-plugin_3.3.1.bb | |||
@@ -0,0 +1,11 @@ | |||
1 | DESCRIPTION = "This plugin cyclically spawns the indicated script/program, captures its output (stdout) and displays the resulting string into the panel." | ||
2 | HOMEPAGE = "http://goodies.xfce.org/projects/panel-plugins/xfce4-genmon-plugin" | ||
3 | LICENSE = "LGPLv2.1" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=68ad62c64cc6c620126241fd429e68fe" | ||
5 | |||
6 | inherit xfce-panel-plugin | ||
7 | |||
8 | SRC_URI += "file://port-to-libxfce4ui.patch" | ||
9 | |||
10 | SRC_URI[md5sum] = "e0022e15d4211a87c17d9f252b68e1d3" | ||
11 | SRC_URI[sha256sum] = "fe439d569f9ba3c8bdbfa907022a7c4a697ae4ae7fc5001a5600dfa5e1793471" | ||