diff options
author | Andreas Müller <schnitzeltony@gmx.de> | 2011-11-02 22:50:23 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-11-03 09:49:47 +0100 |
commit | 6d0fe0de240207e3a72a0d2cb3f755f8949f9b35 (patch) | |
tree | 926d0278bf2e5ce6cf182eb3e32ec881234bfdfb /meta-xfce/recipes-panel-plugins/diskperf | |
parent | 0c8127413f1b87282a63f89bd663c536716df639 (diff) | |
download | meta-openembedded-6d0fe0de240207e3a72a0d2cb3f755f8949f9b35.tar.gz |
xfce4-diskperf-plugin: initial add 2.3.0
* patch sent to xfce-bugzilla [1]
* run tested with memory stick on overo
[1] https://bugzilla.xfce.org/show_bug.cgi?id=8099
Signed-off-by: Andreas Müller <schnitzeltony@gmx.de>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-xfce/recipes-panel-plugins/diskperf')
-rw-r--r-- | meta-xfce/recipes-panel-plugins/diskperf/files/port-to-libxfce4ui.patch | 142 | ||||
-rw-r--r-- | meta-xfce/recipes-panel-plugins/diskperf/xfce4-diskperf-plugin_2.3.0.bb | 11 |
2 files changed, 153 insertions, 0 deletions
diff --git a/meta-xfce/recipes-panel-plugins/diskperf/files/port-to-libxfce4ui.patch b/meta-xfce/recipes-panel-plugins/diskperf/files/port-to-libxfce4ui.patch new file mode 100644 index 000000000..498bf115b --- /dev/null +++ b/meta-xfce/recipes-panel-plugins/diskperf/files/port-to-libxfce4ui.patch | |||
@@ -0,0 +1,142 @@ | |||
1 | From c154d023bca9b3022cc3b99094c0a3aedb2f3bfb Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmx.de> | ||
3 | Date: Wed, 2 Nov 2011 18:11:39 +0100 | ||
4 | Subject: [PATCH] port to libxfce4ui | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | |||
10 | Signed-off-by: Andreas Müller <schnitzeltony@gmx.de> | ||
11 | --- | ||
12 | configure.ac | 4 ++-- | ||
13 | panel-plugin/Makefile.am | 4 ++-- | ||
14 | panel-plugin/config_gui.c | 2 +- | ||
15 | panel-plugin/config_gui.h | 2 +- | ||
16 | panel-plugin/main.c | 17 +++++++++++------ | ||
17 | 5 files changed, 17 insertions(+), 12 deletions(-) | ||
18 | |||
19 | diff --git a/configure.ac b/configure.ac | ||
20 | index e083872..e0eb74b 100644 | ||
21 | --- a/configure.ac | ||
22 | +++ b/configure.ac | ||
23 | @@ -48,8 +48,8 @@ XDT_I18N([@LINGUAS@]) | ||
24 | dnl *********************************** | ||
25 | dnl *** Check for required packages *** | ||
26 | dnl *********************************** | ||
27 | -XDT_CHECK_PACKAGE([LIBXFCE4PANEL], [libxfce4panel-1.0], [4.3.90]) | ||
28 | -XDT_CHECK_PACKAGE([LIBXFCEGUI4], [libxfcegui4-1.0], [4.3.90]) | ||
29 | +XDT_CHECK_PACKAGE([LIBXFCE4PANEL], [libxfce4panel-1.0], [4.8.0]) | ||
30 | +XDT_CHECK_PACKAGE([LIBXFCE4UI], [libxfce4ui-1], [4.8.0]) | ||
31 | |||
32 | dnl *********************************** | ||
33 | dnl *** Check for debugging support *** | ||
34 | diff --git a/panel-plugin/Makefile.am b/panel-plugin/Makefile.am | ||
35 | index 8f86c9a..6a30116 100644 | ||
36 | --- a/panel-plugin/Makefile.am | ||
37 | +++ b/panel-plugin/Makefile.am | ||
38 | @@ -21,11 +21,11 @@ xfce4_diskperf_plugin_SOURCES = \ | ||
39 | |||
40 | xfce4_diskperf_plugin_CFLAGS = \ | ||
41 | $(LIBXFCE4PANEL_CFLAGS) \ | ||
42 | - $(LIBXFCEGUI4_CFLAGS) | ||
43 | + $(LIBXFCE4UI_CFLAGS) | ||
44 | |||
45 | xfce4_diskperf_plugin_LDADD= \ | ||
46 | $(LIBXFCE4PANEL_LIBS) \ | ||
47 | - $(LIBXFCEGUI4_LIBS) | ||
48 | + $(LIBXFCE4UI_LIBS) | ||
49 | |||
50 | # | ||
51 | # Desktop file | ||
52 | diff --git a/panel-plugin/config_gui.c b/panel-plugin/config_gui.c | ||
53 | index 89f630a..34982bf 100644 | ||
54 | --- a/panel-plugin/config_gui.c | ||
55 | +++ b/panel-plugin/config_gui.c | ||
56 | @@ -32,7 +32,7 @@ | ||
57 | #include <gtk/gtk.h> | ||
58 | |||
59 | #include <libxfce4util/libxfce4util.h> | ||
60 | -#include <libxfcegui4/dialogs.h> | ||
61 | +#include <libxfce4ui/libxfce4ui.h> | ||
62 | |||
63 | |||
64 | #define COPYVAL(var, field) ((var)->field = field) | ||
65 | diff --git a/panel-plugin/config_gui.h b/panel-plugin/config_gui.h | ||
66 | index aa49838..6b49a94 100644 | ||
67 | --- a/panel-plugin/config_gui.h | ||
68 | +++ b/panel-plugin/config_gui.h | ||
69 | @@ -24,7 +24,7 @@ | ||
70 | #include <gtk/gtk.h> | ||
71 | |||
72 | #include <libxfce4util/libxfce4util.h> | ||
73 | -#include <libxfcegui4/dialogs.h> | ||
74 | +#include <libxfce4ui/libxfce4ui.h> | ||
75 | |||
76 | |||
77 | typedef struct gui_t { | ||
78 | diff --git a/panel-plugin/main.c b/panel-plugin/main.c | ||
79 | index 43b0390..45020c1 100644 | ||
80 | --- a/panel-plugin/main.c | ||
81 | +++ b/panel-plugin/main.c | ||
82 | @@ -25,7 +25,7 @@ | ||
83 | #include <gtk/gtk.h> | ||
84 | |||
85 | #include <libxfce4util/libxfce4util.h> | ||
86 | -#include <libxfcegui4/libxfcegui4.h> | ||
87 | +#include <libxfce4ui/libxfce4ui.h> | ||
88 | #include <libxfce4panel/xfce-panel-plugin.h> | ||
89 | |||
90 | #include <stdlib.h> | ||
91 | @@ -631,7 +631,8 @@ static void SetDevice (Widget_t p_wTF, void *p_pvPlugin) | ||
92 | |||
93 | status = stat (pcDevice, &oStat); | ||
94 | if (status == -1) { | ||
95 | - xfce_err ("%s\n" | ||
96 | + xfce_dialog_show_error (NULL, NULL, | ||
97 | + "%s\n" | ||
98 | "%s: %s (%d)", | ||
99 | PLUGIN_NAME, pcDevice, strerror (errno), errno); | ||
100 | return; | ||
101 | @@ -853,7 +854,8 @@ static int CheckStatsAvailability () | ||
102 | return (0); | ||
103 | if (status < 0) { | ||
104 | status *= -1; | ||
105 | - xfce_err (_("%s\n" | ||
106 | + xfce_dialog_show_error (NULL, NULL, | ||
107 | + _("%s\n" | ||
108 | "%s: %s (%d)\n\n" | ||
109 | "This monitor will not work!\n" | ||
110 | "Please remove it."), | ||
111 | @@ -863,14 +865,16 @@ static int CheckStatsAvailability () | ||
112 | } | ||
113 | switch (status) { | ||
114 | case NO_EXTENDED_STATS: | ||
115 | - xfce_err (_("%s: No disk extended statistics found!\n" | ||
116 | + xfce_dialog_show_error (NULL, NULL, | ||
117 | + _("%s: No disk extended statistics found!\n" | ||
118 | "Either old kernel (< 2.4.20) or not\n" | ||
119 | "compiled with CONFIG_BLK_STATS turned on.\n\n" | ||
120 | "This monitor will not work!\n" | ||
121 | "Please remove it."), PLUGIN_NAME); | ||
122 | break; | ||
123 | default: | ||
124 | - xfce_err (_("%s: Unknown error\n\n" | ||
125 | + xfce_dialog_show_error (NULL, NULL, | ||
126 | + _("%s: Unknown error\n\n" | ||
127 | "This monitor will not work!\n" | ||
128 | "Please remove it."), PLUGIN_NAME); | ||
129 | } | ||
130 | @@ -882,7 +886,8 @@ static int CheckStatsAvailability () | ||
131 | static void About (Widget_t w, void *unused) | ||
132 | /* Called back when the About button in clicked */ | ||
133 | { | ||
134 | - xfce_info (_("%s %s - Disk Performance Monitor\n" | ||
135 | + xfce_dialog_show_info (NULL, NULL, | ||
136 | + _("%s %s - Disk Performance Monitor\n" | ||
137 | "Display instantaneous disk I/O transfer rates and busy times " | ||
138 | "on Linux and NetBSD systems\n\n" | ||
139 | "(c) 2003, 2004 Roger Seguin <roger_seguin@msn.com>\n" | ||
140 | -- | ||
141 | 1.7.4.4 | ||
142 | |||
diff --git a/meta-xfce/recipes-panel-plugins/diskperf/xfce4-diskperf-plugin_2.3.0.bb b/meta-xfce/recipes-panel-plugins/diskperf/xfce4-diskperf-plugin_2.3.0.bb new file mode 100644 index 000000000..39acd4040 --- /dev/null +++ b/meta-xfce/recipes-panel-plugins/diskperf/xfce4-diskperf-plugin_2.3.0.bb | |||
@@ -0,0 +1,11 @@ | |||
1 | DESCRIPTION = "Panel plugin displaying instant disk/partition performance" | ||
2 | HOMEPAGE = "http://goodies.xfce.org/projects/panel-plugins/xfce4-diskperf-plugin" | ||
3 | LICENSE = "RogerSeguin" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=d3e627798d6a60bece47aa8b3532e1f1" | ||
5 | |||
6 | inherit xfce-panel-plugin | ||
7 | |||
8 | # SRC_URI must follow inherited one | ||
9 | SRC_URI += "file://port-to-libxfce4ui.patch" | ||
10 | SRC_URI[md5sum] = "c6ece8123c762ee203cbc6fd5450b503" | ||
11 | SRC_URI[sha256sum] = "d75e2cd846c784cba804c5cc7796964b3965c764003ca4c1751c68ff83e85793" | ||