summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-panel-plugins/diskperf
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-05-19 18:15:21 +0200
committerAndreas Müller <schnitzeltony@googlemail.com>2012-06-08 14:28:17 +0200
commit459860b30a18846066d661fb9a1e79c51c4fe7db (patch)
tree346ba81bab43c044d97caa743574d071fdf3ba60 /meta-xfce/recipes-panel-plugins/diskperf
parentf631cd137ce5d48a7f87c743b1241512a684598e (diff)
downloadmeta-openembedded-459860b30a18846066d661fb9a1e79c51c4fe7db.tar.gz
xfce4-diskperf-plugin: update to 2.5.3
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'meta-xfce/recipes-panel-plugins/diskperf')
-rw-r--r--meta-xfce/recipes-panel-plugins/diskperf/files/port-to-libxfce4ui.patch142
-rw-r--r--meta-xfce/recipes-panel-plugins/diskperf/xfce4-diskperf-plugin_2.5.3.bb (renamed from meta-xfce/recipes-panel-plugins/diskperf/xfce4-diskperf-plugin_2.3.0.bb)6
2 files changed, 2 insertions, 146 deletions
diff --git a/meta-xfce/recipes-panel-plugins/diskperf/files/port-to-libxfce4ui.patch b/meta-xfce/recipes-panel-plugins/diskperf/files/port-to-libxfce4ui.patch
deleted file mode 100644
index 498bf115b..000000000
--- a/meta-xfce/recipes-panel-plugins/diskperf/files/port-to-libxfce4ui.patch
+++ /dev/null
@@ -1,142 +0,0 @@
1From c154d023bca9b3022cc3b99094c0a3aedb2f3bfb Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmx.de>
3Date: Wed, 2 Nov 2011 18:11:39 +0100
4Subject: [PATCH] port to libxfce4ui
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9
10Signed-off-by: Andreas Müller <schnitzeltony@gmx.de>
11---
12 configure.ac | 4 ++--
13 panel-plugin/Makefile.am | 4 ++--
14 panel-plugin/config_gui.c | 2 +-
15 panel-plugin/config_gui.h | 2 +-
16 panel-plugin/main.c | 17 +++++++++++------
17 5 files changed, 17 insertions(+), 12 deletions(-)
18
19diff --git a/configure.ac b/configure.ac
20index e083872..e0eb74b 100644
21--- a/configure.ac
22+++ b/configure.ac
23@@ -48,8 +48,8 @@ XDT_I18N([@LINGUAS@])
24 dnl ***********************************
25 dnl *** Check for required packages ***
26 dnl ***********************************
27-XDT_CHECK_PACKAGE([LIBXFCE4PANEL], [libxfce4panel-1.0], [4.3.90])
28-XDT_CHECK_PACKAGE([LIBXFCEGUI4], [libxfcegui4-1.0], [4.3.90])
29+XDT_CHECK_PACKAGE([LIBXFCE4PANEL], [libxfce4panel-1.0], [4.8.0])
30+XDT_CHECK_PACKAGE([LIBXFCE4UI], [libxfce4ui-1], [4.8.0])
31
32 dnl ***********************************
33 dnl *** Check for debugging support ***
34diff --git a/panel-plugin/Makefile.am b/panel-plugin/Makefile.am
35index 8f86c9a..6a30116 100644
36--- a/panel-plugin/Makefile.am
37+++ b/panel-plugin/Makefile.am
38@@ -21,11 +21,11 @@ xfce4_diskperf_plugin_SOURCES = \
39
40 xfce4_diskperf_plugin_CFLAGS = \
41 $(LIBXFCE4PANEL_CFLAGS) \
42- $(LIBXFCEGUI4_CFLAGS)
43+ $(LIBXFCE4UI_CFLAGS)
44
45 xfce4_diskperf_plugin_LDADD= \
46 $(LIBXFCE4PANEL_LIBS) \
47- $(LIBXFCEGUI4_LIBS)
48+ $(LIBXFCE4UI_LIBS)
49
50 #
51 # Desktop file
52diff --git a/panel-plugin/config_gui.c b/panel-plugin/config_gui.c
53index 89f630a..34982bf 100644
54--- a/panel-plugin/config_gui.c
55+++ b/panel-plugin/config_gui.c
56@@ -32,7 +32,7 @@
57 #include <gtk/gtk.h>
58
59 #include <libxfce4util/libxfce4util.h>
60-#include <libxfcegui4/dialogs.h>
61+#include <libxfce4ui/libxfce4ui.h>
62
63
64 #define COPYVAL(var, field) ((var)->field = field)
65diff --git a/panel-plugin/config_gui.h b/panel-plugin/config_gui.h
66index aa49838..6b49a94 100644
67--- a/panel-plugin/config_gui.h
68+++ b/panel-plugin/config_gui.h
69@@ -24,7 +24,7 @@
70 #include <gtk/gtk.h>
71
72 #include <libxfce4util/libxfce4util.h>
73-#include <libxfcegui4/dialogs.h>
74+#include <libxfce4ui/libxfce4ui.h>
75
76
77 typedef struct gui_t {
78diff --git a/panel-plugin/main.c b/panel-plugin/main.c
79index 43b0390..45020c1 100644
80--- a/panel-plugin/main.c
81+++ b/panel-plugin/main.c
82@@ -25,7 +25,7 @@
83 #include <gtk/gtk.h>
84
85 #include <libxfce4util/libxfce4util.h>
86-#include <libxfcegui4/libxfcegui4.h>
87+#include <libxfce4ui/libxfce4ui.h>
88 #include <libxfce4panel/xfce-panel-plugin.h>
89
90 #include <stdlib.h>
91@@ -631,7 +631,8 @@ static void SetDevice (Widget_t p_wTF, void *p_pvPlugin)
92
93 status = stat (pcDevice, &oStat);
94 if (status == -1) {
95- xfce_err ("%s\n"
96+ xfce_dialog_show_error (NULL, NULL,
97+ "%s\n"
98 "%s: %s (%d)",
99 PLUGIN_NAME, pcDevice, strerror (errno), errno);
100 return;
101@@ -853,7 +854,8 @@ static int CheckStatsAvailability ()
102 return (0);
103 if (status < 0) {
104 status *= -1;
105- xfce_err (_("%s\n"
106+ xfce_dialog_show_error (NULL, NULL,
107+ _("%s\n"
108 "%s: %s (%d)\n\n"
109 "This monitor will not work!\n"
110 "Please remove it."),
111@@ -863,14 +865,16 @@ static int CheckStatsAvailability ()
112 }
113 switch (status) {
114 case NO_EXTENDED_STATS:
115- xfce_err (_("%s: No disk extended statistics found!\n"
116+ xfce_dialog_show_error (NULL, NULL,
117+ _("%s: No disk extended statistics found!\n"
118 "Either old kernel (< 2.4.20) or not\n"
119 "compiled with CONFIG_BLK_STATS turned on.\n\n"
120 "This monitor will not work!\n"
121 "Please remove it."), PLUGIN_NAME);
122 break;
123 default:
124- xfce_err (_("%s: Unknown error\n\n"
125+ xfce_dialog_show_error (NULL, NULL,
126+ _("%s: Unknown error\n\n"
127 "This monitor will not work!\n"
128 "Please remove it."), PLUGIN_NAME);
129 }
130@@ -882,7 +886,8 @@ static int CheckStatsAvailability ()
131 static void About (Widget_t w, void *unused)
132 /* Called back when the About button in clicked */
133 {
134- xfce_info (_("%s %s - Disk Performance Monitor\n"
135+ xfce_dialog_show_info (NULL, NULL,
136+ _("%s %s - Disk Performance Monitor\n"
137 "Display instantaneous disk I/O transfer rates and busy times "
138 "on Linux and NetBSD systems\n\n"
139 "(c) 2003, 2004 Roger Seguin <roger_seguin@msn.com>\n"
140--
1411.7.4.4
142
diff --git a/meta-xfce/recipes-panel-plugins/diskperf/xfce4-diskperf-plugin_2.3.0.bb b/meta-xfce/recipes-panel-plugins/diskperf/xfce4-diskperf-plugin_2.5.3.bb
index 39acd4040..e80d0bd02 100644
--- a/meta-xfce/recipes-panel-plugins/diskperf/xfce4-diskperf-plugin_2.3.0.bb
+++ b/meta-xfce/recipes-panel-plugins/diskperf/xfce4-diskperf-plugin_2.5.3.bb
@@ -5,7 +5,5 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d3e627798d6a60bece47aa8b3532e1f1"
5 5
6inherit xfce-panel-plugin 6inherit xfce-panel-plugin
7 7
8# SRC_URI must follow inherited one 8SRC_URI[md5sum] = "ba880f763e273787d0c8365eebc4feab"
9SRC_URI += "file://port-to-libxfce4ui.patch" 9SRC_URI[sha256sum] = "418a250fe8d48f1fd87658206a8e6762032d35dc1b2e98e27d309a35f873f9b6"
10SRC_URI[md5sum] = "c6ece8123c762ee203cbc6fd5450b503"
11SRC_URI[sha256sum] = "d75e2cd846c784cba804c5cc7796964b3965c764003ca4c1751c68ff83e85793"