summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-apps
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2018-06-10 17:08:06 +0200
committerKhem Raj <raj.khem@gmail.com>2018-06-14 08:57:14 -0700
commit3e4c440ec2889110aac4201cc8c6ee43467b523d (patch)
treeb15393b7f372dfabaebf6deb6cbbb05c863184ef /meta-xfce/recipes-apps
parentf41e1739a13bb783235c6ee19883b886a170fc58 (diff)
downloadmeta-openembedded-3e4c440ec2889110aac4201cc8c6ee43467b523d.tar.gz
xfce4-mixer: fix build after update of xfconf
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
Diffstat (limited to 'meta-xfce/recipes-apps')
-rw-r--r--meta-xfce/recipes-apps/xfce4-mixer/files/0001-Fix-build-after-update-of-xfconf.patch61
-rw-r--r--meta-xfce/recipes-apps/xfce4-mixer/xfce4-mixer_4.11.0.bb5
2 files changed, 65 insertions, 1 deletions
diff --git a/meta-xfce/recipes-apps/xfce4-mixer/files/0001-Fix-build-after-update-of-xfconf.patch b/meta-xfce/recipes-apps/xfce4-mixer/files/0001-Fix-build-after-update-of-xfconf.patch
new file mode 100644
index 000000000..31216c038
--- /dev/null
+++ b/meta-xfce/recipes-apps/xfce4-mixer/files/0001-Fix-build-after-update-of-xfconf.patch
@@ -0,0 +1,61 @@
1From 6ecaeced291f935a9d41e9bc33411358c95a5e91 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
3Date: Mon, 22 Jan 2018 15:35:08 +0100
4Subject: [PATCH] Fix build after update of xfconf
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9xfconf stopped using dbus-glib so required flags must be included here
10
11Upstream-Status: Pending
12
13Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
14---
15 panel-plugin/Makefile.am | 2 ++
16 xfce4-mixer/Makefile.am | 2 ++
17 2 files changed, 4 insertions(+)
18
19diff --git a/panel-plugin/Makefile.am b/panel-plugin/Makefile.am
20index a494682..b094472 100644
21--- a/panel-plugin/Makefile.am
22+++ b/panel-plugin/Makefile.am
23@@ -27,6 +27,7 @@ libmixer_la_CFLAGS = \
24 $(LIBXFCE4UI_CFLAGS) \
25 $(LIBXFCE4PANEL_CFLAGS) \
26 $(XFCONF_CFLAGS) \
27+ $(DBUS_GLIB_CFLAGS) \
28 $(GST_PLUGINS_BASE_CFLAGS) \
29 $(KEYBINDER_CFLAGS)
30
31@@ -48,6 +49,7 @@ libmixer_la_LIBADD = \
32 $(LIBXFCE4UI_LIBS) \
33 $(LIBXFCE4PANEL_LIBS) \
34 $(XFCONF_LIBS) \
35+ $(DBUS_GLIB_LIBS) \
36 $(GST_PLUGINS_BASE_LIBS) \
37 -lgstaudio-0.10 \
38 -lgstinterfaces-0.10 \
39diff --git a/xfce4-mixer/Makefile.am b/xfce4-mixer/Makefile.am
40index 4af69e9..e076fc8 100644
41--- a/xfce4-mixer/Makefile.am
42+++ b/xfce4-mixer/Makefile.am
43@@ -32,6 +32,7 @@ xfce4_mixer_CFLAGS = \
44 $(UNIQUE_CFLAGS) \
45 $(LIBXFCE4UTIL_CFLAGS) \
46 $(LIBXFCE4UI_CFLAGS) \
47+ $(DBUS_GLIB_CFLAGS) \
48 $(XFCONF_CFLAGS) \
49 $(GST_PLUGINS_BASE_CFLAGS)
50
51@@ -46,6 +47,7 @@ xfce4_mixer_LDFLAGS = \
52 $(UNIQUE_LIBS) \
53 $(LIBXFCE4UTIL_LIBS) \
54 $(LIBXFCE4UI_LIBS) \
55+ $(DBUS_GLIB_LIBS) \
56 $(XFCONF_LIBS) \
57 $(GST_PLUGINS_BASE_LIBS) \
58 -lgstaudio-0.10 \
59--
602.14.3
61
diff --git a/meta-xfce/recipes-apps/xfce4-mixer/xfce4-mixer_4.11.0.bb b/meta-xfce/recipes-apps/xfce4-mixer/xfce4-mixer_4.11.0.bb
index bdbec458b..6c057d884 100644
--- a/meta-xfce/recipes-apps/xfce4-mixer/xfce4-mixer_4.11.0.bb
+++ b/meta-xfce/recipes-apps/xfce4-mixer/xfce4-mixer_4.11.0.bb
@@ -6,7 +6,10 @@ inherit xfce-panel-plugin
6 6
7DEPENDS += "glib-2.0 gst-plugins-base gtk+ xfconf libunique" 7DEPENDS += "glib-2.0 gst-plugins-base gtk+ xfconf libunique"
8 8
9SRC_URI = "http://archive.xfce.org/src/apps/${BPN}/${@xfce_verdir("${PV}")}/${BPN}-${PV}.tar.bz2" 9SRC_URI = " \
10 http://archive.xfce.org/src/apps/${BPN}/${@xfce_verdir("${PV}")}/${BPN}-${PV}.tar.bz2 \
11 file://0001-Fix-build-after-update-of-xfconf.patch \
12"
10 13
11SRC_URI[md5sum] = "1b3753b91224867a3a2dfddda239c28d" 14SRC_URI[md5sum] = "1b3753b91224867a3a2dfddda239c28d"
12SRC_URI[sha256sum] = "fb0c1df201ed1130f54f15b914cbe5a59286e994a137acda5609570c57112de2" 15SRC_URI[sha256sum] = "fb0c1df201ed1130f54f15b914cbe5a59286e994a137acda5609570c57112de2"