summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-apps
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2022-07-19 22:01:46 -0700
committerKhem Raj <raj.khem@gmail.com>2022-07-20 07:22:44 -0700
commitc2fb0bd1ebe04f91e97913e1e15405af0e127078 (patch)
tree4ff1806e5ed220d59d2a7248636d25510f9a37cd /meta-xfce/recipes-apps
parentc77bc200813dec8a1317ea6651d0f398a3fa5d65 (diff)
downloadmeta-openembedded-c2fb0bd1ebe04f91e97913e1e15405af0e127078.tar.gz
catfish: fix buildpaths issue
Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-xfce/recipes-apps')
-rw-r--r--meta-xfce/recipes-apps/catfish/catfish_4.16.3.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-xfce/recipes-apps/catfish/catfish_4.16.3.bb b/meta-xfce/recipes-apps/catfish/catfish_4.16.3.bb
index 98cd251d2..8fe879b81 100644
--- a/meta-xfce/recipes-apps/catfish/catfish_4.16.3.bb
+++ b/meta-xfce/recipes-apps/catfish/catfish_4.16.3.bb
@@ -12,3 +12,12 @@ SRC_URI[sha256sum] = "e9a99a62d10981391508dd43f3cbfa2d50a69bd6b7d1eeef7d30ba4c67
12FILES:${PN} += "${datadir}/metainfo" 12FILES:${PN} += "${datadir}/metainfo"
13 13
14RDEPENDS:${PN} += "python3-pygobject python3-dbus" 14RDEPENDS:${PN} += "python3-pygobject python3-dbus"
15
16do_install:append() {
17 #
18 # Until catfish upstream figures out a way to overcome this buildpath issue, we need to do such adjustments here.
19 #
20 sed -i -e 's#${RECIPE_SYSROOT_NATIVE}##g' ${D}${datadir}/applications/org.xfce.Catfish.desktop
21 sed -i -e 's#${RECIPE_SYSROOT_NATIVE}##g' ${D}${PYTHON_SITEPACKAGES_DIR}/catfish_lib/catfishconfig.py
22 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/catfish_lib/__pycache__/catfishconfig.*.pyc
23}