diff options
author | Andreas Müller <schnitzeltony@googlemail.com> | 2015-08-30 12:33:58 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-09-08 16:18:35 +0200 |
commit | a0b93d8c18ccc9ac30e55431bbdc8e860bb428b4 (patch) | |
tree | 3a9850dae5da2269e005aac25b3a8d40bb15c3a9 /meta-xfce/recipes-apps | |
parent | 387a933db677f2fa702c464e073d84bc7bf0b649 (diff) | |
download | meta-openembedded-a0b93d8c18ccc9ac30e55431bbdc8e860bb428b4.tar.gz |
xfce4-notifyd: fix build for libnotify 0.7.x
the patch included during last commit only made latest xfce4-notifyd work with
old version of libnotify. I expected it to work also for libnotify 0.7.x but
that failed so remove the patch.
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-xfce/recipes-apps')
-rw-r--r-- | meta-xfce/recipes-apps/xfce4-notifyd/files/0001-Restore-libnotify-version-7.0.0-compatibility.patch | 152 | ||||
-rw-r--r-- | meta-xfce/recipes-apps/xfce4-notifyd/xfce4-notifyd_0.2.4.bb | 1 |
2 files changed, 0 insertions, 153 deletions
diff --git a/meta-xfce/recipes-apps/xfce4-notifyd/files/0001-Restore-libnotify-version-7.0.0-compatibility.patch b/meta-xfce/recipes-apps/xfce4-notifyd/files/0001-Restore-libnotify-version-7.0.0-compatibility.patch deleted file mode 100644 index 9e61a0ecf..000000000 --- a/meta-xfce/recipes-apps/xfce4-notifyd/files/0001-Restore-libnotify-version-7.0.0-compatibility.patch +++ /dev/null | |||
@@ -1,152 +0,0 @@ | |||
1 | From ebfbe9358068716ed7f39e253bce4d13e696bc9b Mon Sep 17 00:00:00 2001 | ||
2 | From: Ivailo Monev <xakepa10@gmail.com> | ||
3 | Date: Wed, 11 Dec 2013 13:18:13 +0000 | ||
4 | Subject: [PATCH 1/1] Restore libnotify version < 7.0.0 compatibility | ||
5 | |||
6 | Upstream-Status: Pending [1] | ||
7 | |||
8 | [1] https://mail.xfce.org/pipermail/xfce/2013-December/032733.html | ||
9 | |||
10 | Signed-off-by: Ivailo Monev <xakepa10@gmail.com> | ||
11 | --- | ||
12 | Makefile.am | 4 +++- | ||
13 | configure.ac | 2 +- | ||
14 | tests/test-actions.c | 7 ++++++- | ||
15 | tests/test-positioning.c | 7 ++++++- | ||
16 | tests/test-text.c | 21 ++++++++++++++++++--- | ||
17 | xfce4-notifyd-config/main.c | 7 ++++++- | ||
18 | 6 files changed, 40 insertions(+), 8 deletions(-) | ||
19 | |||
20 | diff --git a/Makefile.am b/Makefile.am | ||
21 | index df81bea..034d6c1 100644 | ||
22 | --- a/Makefile.am | ||
23 | +++ b/Makefile.am | ||
24 | @@ -271,9 +271,11 @@ noinst_PROGRAMS = \ | ||
25 | |||
26 | tests_cflags = \ | ||
27 | -I$(top_srcdir) \ | ||
28 | - $(LIBNOTIFY_CFLAGS) | ||
29 | + $(LIBNOTIFY_CFLAGS) \ | ||
30 | + $(common_cflags) | ||
31 | |||
32 | tests_ldadd = \ | ||
33 | + $(common_ldadd) \ | ||
34 | $(LIBNOTIFY_LIBS) | ||
35 | |||
36 | tests_test_actions_SOURCES = tests/test-actions.c | ||
37 | diff --git a/configure.ac b/configure.ac | ||
38 | index cf5258f..9d2e8a7 100644 | ||
39 | --- a/configure.ac | ||
40 | +++ b/configure.ac | ||
41 | @@ -67,7 +67,7 @@ XDT_CHECK_PACKAGE([XFCONF], [libxfconf-0], [0.1.0svn-r26876]) | ||
42 | XDT_CHECK_PACKAGE([GTK], [gtk+-2.0], [2.14.0]) | ||
43 | XDT_CHECK_PACKAGE([DBUS], [dbus-1], [1.0.0]) | ||
44 | XDT_CHECK_PACKAGE([DBUS_GLIB], [dbus-glib-1], [0.72]) | ||
45 | -XDT_CHECK_PACKAGE([LIBNOTIFY], [libnotify], [0.7.0]) | ||
46 | +XDT_CHECK_PACKAGE([LIBNOTIFY], [libnotify], [0.5.0]) | ||
47 | |||
48 | AC_PATH_PROG([DBUS_BINDING_TOOL], [dbus-binding-tool]) | ||
49 | AS_IF([test -z "$DBUS_BINDING_TOOL"], | ||
50 | diff --git a/tests/test-actions.c b/tests/test-actions.c | ||
51 | index a7f6494..4cdf882 100644 | ||
52 | --- a/tests/test-actions.c | ||
53 | +++ b/tests/test-actions.c | ||
54 | @@ -106,7 +106,12 @@ int main (int argc, char **argv) | ||
55 | |||
56 | notification = notify_notification_new ("Action!", | ||
57 | "Click my shiny actions", | ||
58 | - NULL); | ||
59 | + NULL | ||
60 | +#if NOTIFY_CHECK_VERSION > (0, 6, 9) | ||
61 | + ); | ||
62 | +#else | ||
63 | + ,NULL); | ||
64 | +#endif | ||
65 | |||
66 | notify_notification_add_action (notification, | ||
67 | "action1", | ||
68 | diff --git a/tests/test-positioning.c b/tests/test-positioning.c | ||
69 | index 4478a92..2a90c6e 100644 | ||
70 | --- a/tests/test-positioning.c | ||
71 | +++ b/tests/test-positioning.c | ||
72 | @@ -60,7 +60,12 @@ int main (int argc, char **argv) | ||
73 | |||
74 | notification = notify_notification_new (summary, | ||
75 | body, | ||
76 | - NULL); | ||
77 | + NULL | ||
78 | +#if NOTIFY_CHECK_VERSION > (0, 6, 9) | ||
79 | + ); | ||
80 | +#else | ||
81 | + ,NULL); | ||
82 | +#endif | ||
83 | |||
84 | if (!notify_notification_show (notification, NULL)) | ||
85 | { | ||
86 | diff --git a/tests/test-text.c b/tests/test-text.c | ||
87 | index 7500cb2..ac95931 100644 | ||
88 | --- a/tests/test-text.c | ||
89 | +++ b/tests/test-text.c | ||
90 | @@ -40,7 +40,12 @@ int main (int argc, char **argv) | ||
91 | |||
92 | notification = notify_notification_new ("Test text support", | ||
93 | "Does it work?", | ||
94 | - NULL); | ||
95 | + NULL | ||
96 | +#if NOTIFY_CHECK_VERSION > (0, 6, 9) | ||
97 | + ); | ||
98 | +#else | ||
99 | + ,NULL); | ||
100 | +#endif | ||
101 | |||
102 | if (!notify_notification_show (notification, NULL)) | ||
103 | { | ||
104 | @@ -56,7 +61,12 @@ int main (int argc, char **argv) | ||
105 | |||
106 | notification = notify_notification_new ("Summary only support", | ||
107 | NULL, | ||
108 | - NULL); | ||
109 | + NULL | ||
110 | +#if NOTIFY_CHECK_VERSION > (0, 6, 9) | ||
111 | + ); | ||
112 | +#else | ||
113 | + ,NULL); | ||
114 | +#endif | ||
115 | |||
116 | if (!notify_notification_show (notification, NULL)) | ||
117 | { | ||
118 | @@ -75,7 +85,12 @@ int main (int argc, char **argv) | ||
119 | "<b>Bold</b>\n" | ||
120 | "<u>Underlined</u>\n" | ||
121 | "<a href=\"http://www.xfce.org\">Xfce Web site</a>", | ||
122 | - NULL); | ||
123 | + NULL | ||
124 | +#if NOTIFY_CHECK_VERSION > (0, 6, 9) | ||
125 | + ); | ||
126 | +#else | ||
127 | + ,NULL); | ||
128 | +#endif | ||
129 | |||
130 | if (!notify_notification_show (notification, NULL)) | ||
131 | { | ||
132 | diff --git a/xfce4-notifyd-config/main.c b/xfce4-notifyd-config/main.c | ||
133 | index 5977749..eff4994 100644 | ||
134 | --- a/xfce4-notifyd-config/main.c | ||
135 | +++ b/xfce4-notifyd-config/main.c | ||
136 | @@ -56,7 +56,12 @@ xfce_notifyd_config_show_notification_preview(GtkWindow *parent_window) | ||
137 | notification = | ||
138 | notify_notification_new(_("Notification Preview"), | ||
139 | _("This is how notifications will look like"), | ||
140 | - "xfce4-notifyd"); | ||
141 | + "xfce4-notifyd" | ||
142 | +#if NOTIFY_CHECK_VERSION > (0, 6, 9) | ||
143 | + ); | ||
144 | +#else | ||
145 | + ,NULL); | ||
146 | +#endif | ||
147 | |||
148 | notify_notification_add_action(notification, | ||
149 | "button", | ||
150 | -- | ||
151 | 1.9.3 | ||
152 | |||
diff --git a/meta-xfce/recipes-apps/xfce4-notifyd/xfce4-notifyd_0.2.4.bb b/meta-xfce/recipes-apps/xfce4-notifyd/xfce4-notifyd_0.2.4.bb index 9d0e19801..5f874adcd 100644 --- a/meta-xfce/recipes-apps/xfce4-notifyd/xfce4-notifyd_0.2.4.bb +++ b/meta-xfce/recipes-apps/xfce4-notifyd/xfce4-notifyd_0.2.4.bb | |||
@@ -8,7 +8,6 @@ inherit xfce-app | |||
8 | 8 | ||
9 | SRC_URI[md5sum] = "094be6f29206aac8299f27084e284e88" | 9 | SRC_URI[md5sum] = "094be6f29206aac8299f27084e284e88" |
10 | SRC_URI[sha256sum] = "8c7ed62f9496816d1391281f77d1b32216f9bf6fd22fbe4f6f3f4e07a6bbced0" | 10 | SRC_URI[sha256sum] = "8c7ed62f9496816d1391281f77d1b32216f9bf6fd22fbe4f6f3f4e07a6bbced0" |
11 | SRC_URI += "file://0001-Restore-libnotify-version-7.0.0-compatibility.patch" | ||
12 | 11 | ||
13 | do_compile_prepend() { | 12 | do_compile_prepend() { |
14 | mkdir -p xfce4-notifyd | 13 | mkdir -p xfce4-notifyd |