diff options
author | Khem Raj <raj.khem@gmail.com> | 2019-07-23 14:29:07 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-07-25 07:27:40 -0700 |
commit | 5f74c657c06b79394ddd5e532e1e10ee49a9f9c5 (patch) | |
tree | b371bfa090a0ae6d2ac17db666970c95d8b577b9 /meta-xfce/recipes-apps | |
parent | 9abf32cf346537ec7a3ffac19d4dbded70fd9527 (diff) | |
download | meta-openembedded-5f74c657c06b79394ddd5e532e1e10ee49a9f9c5.tar.gz |
orage: Fix build with libical3
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-xfce/recipes-apps')
-rw-r--r-- | meta-xfce/recipes-apps/orage/orage/0001-drop-setting-is_utc-member-of-icaltimetype.patch | 77 | ||||
-rw-r--r-- | meta-xfce/recipes-apps/orage/orage_4.12.1.bb | 2 |
2 files changed, 79 insertions, 0 deletions
diff --git a/meta-xfce/recipes-apps/orage/orage/0001-drop-setting-is_utc-member-of-icaltimetype.patch b/meta-xfce/recipes-apps/orage/orage/0001-drop-setting-is_utc-member-of-icaltimetype.patch new file mode 100644 index 000000000..517de5f92 --- /dev/null +++ b/meta-xfce/recipes-apps/orage/orage/0001-drop-setting-is_utc-member-of-icaltimetype.patch | |||
@@ -0,0 +1,77 @@ | |||
1 | From 5bdf11fe3638d279edcad911906f801751e024da Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 23 Jul 2019 14:22:08 -0700 | ||
4 | Subject: [PATCH] drop setting is_utc member of icaltimetype | ||
5 | |||
6 | This seems to be gone in libical3 | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | |||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | src/ical-code.c | 7 ------- | ||
13 | 1 file changed, 7 deletions(-) | ||
14 | |||
15 | diff --git a/src/ical-code.c b/src/ical-code.c | ||
16 | index d583140..d8e5543 100644 | ||
17 | --- a/src/ical-code.c | ||
18 | +++ b/src/ical-code.c | ||
19 | @@ -129,7 +129,6 @@ static struct icaltimetype ical_get_current_local_time() | ||
20 | && (strcmp(g_par.local_timezone, "floating") != 0)) | ||
21 | ctime = icaltime_current_time_with_zone(local_icaltimezone); | ||
22 | else { / * use floating time * / | ||
23 | - ctime.is_utc = 0; | ||
24 | ctime.is_date = 0; | ||
25 | ctime.is_daylight = 0; | ||
26 | ctime.zone = NULL; | ||
27 | @@ -2579,7 +2578,6 @@ static struct icaltimetype count_first_alarm_time(xfical_period per | ||
28 | * when counting alarm time. */ | ||
29 | if (rel == ICAL_RELATED_START) { | ||
30 | per.stime.is_date = 0; | ||
31 | - per.stime.is_utc = 1; | ||
32 | per.stime.is_daylight = 0; | ||
33 | per.stime.zone = utc_icaltimezone; | ||
34 | per.stime.hour = 0; | ||
35 | @@ -2588,7 +2586,6 @@ static struct icaltimetype count_first_alarm_time(xfical_period per | ||
36 | } | ||
37 | else { | ||
38 | per.etime.is_date = 0; | ||
39 | - per.etime.is_utc = 1; | ||
40 | per.etime.is_daylight = 0; | ||
41 | per.etime.zone = utc_icaltimezone; | ||
42 | per.etime.hour = 0; | ||
43 | @@ -2613,7 +2610,6 @@ static struct icaltimetype count_next_alarm_time(struct icaltimetype start_time | ||
44 | /* HACK: convert to UTC time so that we can use time arithmetic | ||
45 | * when counting alarm time. */ | ||
46 | start_time.is_date = 0; | ||
47 | - start_time.is_utc = 1; | ||
48 | start_time.is_daylight = 0; | ||
49 | start_time.zone = utc_icaltimezone; | ||
50 | start_time.hour = 0; | ||
51 | @@ -2768,7 +2764,6 @@ static alarm_struct *process_alarm_trigger(icalcomponent *c | ||
52 | */ | ||
53 | if (icaltime_is_date(per.stime)) { | ||
54 | if (local_icaltimezone != utc_icaltimezone) { | ||
55 | - next_alarm_time.is_utc = 0; | ||
56 | next_alarm_time.is_daylight = 0; | ||
57 | next_alarm_time.zone = local_icaltimezone; | ||
58 | } | ||
59 | @@ -2850,7 +2845,6 @@ orage_message(120, P_N "Alarm rec loop next_start:%s next_alarm:%s per.stime:%s" | ||
60 | */ | ||
61 | if (icaltime_is_date(per.stime)) { | ||
62 | if (local_icaltimezone != utc_icaltimezone) { | ||
63 | - next_alarm_time.is_utc = 0; | ||
64 | next_alarm_time.is_daylight = 0; | ||
65 | next_alarm_time.zone = local_icaltimezone; | ||
66 | } | ||
67 | @@ -2944,7 +2938,6 @@ orage_message(120, P_N "*****After loop Alarm %s %s", icaltime_as_ical_string(ne | ||
68 | */ | ||
69 | if (icaltime_is_date(per.stime)) { | ||
70 | if (local_icaltimezone != utc_icaltimezone) { | ||
71 | - next_alarm_time.is_utc = 0; | ||
72 | next_alarm_time.is_daylight = 0; | ||
73 | next_alarm_time.zone = local_icaltimezone; | ||
74 | } | ||
75 | -- | ||
76 | 2.22.0 | ||
77 | |||
diff --git a/meta-xfce/recipes-apps/orage/orage_4.12.1.bb b/meta-xfce/recipes-apps/orage/orage_4.12.1.bb index eb9da2dff..9662b614f 100644 --- a/meta-xfce/recipes-apps/orage/orage_4.12.1.bb +++ b/meta-xfce/recipes-apps/orage/orage_4.12.1.bb | |||
@@ -6,6 +6,8 @@ DEPENDS = "gtk+ xfce4-panel libical popt" | |||
6 | 6 | ||
7 | inherit xfce-app | 7 | inherit xfce-app |
8 | 8 | ||
9 | SRC_URI += "file://0001-drop-setting-is_utc-member-of-icaltimetype.patch" | ||
10 | |||
9 | SRC_URI[md5sum] = "2b7f5d38cb5c6edbcc65d0f52a742e46" | 11 | SRC_URI[md5sum] = "2b7f5d38cb5c6edbcc65d0f52a742e46" |
10 | SRC_URI[sha256sum] = "3cf9aa441ae83c8688865f82217025cdf3ebaa152cce4571777b8c2aa8dd9062" | 12 | SRC_URI[sha256sum] = "3cf9aa441ae83c8688865f82217025cdf3ebaa152cce4571777b8c2aa8dd9062" |
11 | 13 | ||