diff options
author | Jackie Huang <jackie.huang@windriver.com> | 2015-09-21 16:48:37 +0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-10-13 12:27:47 +0200 |
commit | f53738634d131cb996e16b422398a7d896450bd5 (patch) | |
tree | 4e17a01ba7a8b109a2ec1649b8a6ad484be9a995 /meta-xfce/recipes-apps/xfce4-screenshooter | |
parent | 70836105f5ada656a02babd6e7dbc0b652c3f07f (diff) | |
download | meta-openembedded-f53738634d131cb996e16b422398a7d896450bd5.tar.gz |
xfce4-screenshooter: ensure output directory is created
When build with B != S, the output directory for desktop
file doesn't exist so it will fail if it's not created
before generating the file:
/bin/sh: line 1: src/xfce4-screenshooter.desktop.in: No such file or directory
Add "$(MKDIR_P) $(dir $@)" to the rule to fix this.
Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-xfce/recipes-apps/xfce4-screenshooter')
2 files changed, 31 insertions, 0 deletions
diff --git a/meta-xfce/recipes-apps/xfce4-screenshooter/files/0001-Makefile.am-create-ouput-directory-for-desktop-file.patch b/meta-xfce/recipes-apps/xfce4-screenshooter/files/0001-Makefile.am-create-ouput-directory-for-desktop-file.patch new file mode 100644 index 000000000..62bffef1f --- /dev/null +++ b/meta-xfce/recipes-apps/xfce4-screenshooter/files/0001-Makefile.am-create-ouput-directory-for-desktop-file.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From c85bf7cc5c1e1780d215f6fe233e3ed4597c72ed Mon Sep 17 00:00:00 2001 | ||
2 | From: Jackie Huang <jackie.huang@windriver.com> | ||
3 | Date: Mon, 21 Sep 2015 06:54:28 +0000 | ||
4 | Subject: [PATCH] Makefile.am: create ouput directory for desktop file | ||
5 | |||
6 | Upstream-Status: Submitted [1] | ||
7 | |||
8 | [1]: http://bug-attachment.xfce.org/attachment.cgi?id=6460 | ||
9 | |||
10 | Signed-off-by: Jackie Huang <jackie.huang@windriver.com> | ||
11 | --- | ||
12 | Makefile.am | 1 + | ||
13 | 1 file changed, 1 insertion(+) | ||
14 | |||
15 | diff --git a/Makefile.am b/Makefile.am | ||
16 | index a22fc20..2ef0e54 100644 | ||
17 | --- a/Makefile.am | ||
18 | +++ b/Makefile.am | ||
19 | @@ -122,6 +122,7 @@ app_desktop_DATA = $(app_desktop_in_files:.desktop.in=.desktop) | ||
20 | |||
21 | src/xfce4-screenshooter.desktop.in: src/xfce4-screenshooter.desktop.in.in | ||
22 | $(AM_V_GEN) ( \ | ||
23 | + $(MKDIR_P) $(dir $@); \ | ||
24 | sed -e "s^@PLUGIN_PATH@^$(libexecdir)/applications^" \ | ||
25 | $< > $@ \ | ||
26 | ) | ||
27 | -- | ||
28 | 2.0.1 | ||
29 | |||
diff --git a/meta-xfce/recipes-apps/xfce4-screenshooter/xfce4-screenshooter_1.8.2.bb b/meta-xfce/recipes-apps/xfce4-screenshooter/xfce4-screenshooter_1.8.2.bb index ae19492f3..de2bc6151 100644 --- a/meta-xfce/recipes-apps/xfce4-screenshooter/xfce4-screenshooter_1.8.2.bb +++ b/meta-xfce/recipes-apps/xfce4-screenshooter/xfce4-screenshooter_1.8.2.bb | |||
@@ -7,6 +7,8 @@ DEPENDS = "xfce4-panel libxfce4util libxfce4ui gdk-pixbuf gtk+ glib-2.0 libsoup- | |||
7 | 7 | ||
8 | inherit xfce-app | 8 | inherit xfce-app |
9 | 9 | ||
10 | SRC_URI += "file://0001-Makefile.am-create-ouput-directory-for-desktop-file.patch" | ||
11 | |||
10 | SRC_URI[md5sum] = "3a32ecc5566453a58f6a4ddd70649444" | 12 | SRC_URI[md5sum] = "3a32ecc5566453a58f6a4ddd70649444" |
11 | SRC_URI[sha256sum] = "9dce2ddfaa87f703e870e29bae13f3fc82a1b3f06b44f8386640e45a135f5f69" | 13 | SRC_URI[sha256sum] = "9dce2ddfaa87f703e870e29bae13f3fc82a1b3f06b44f8386640e45a135f5f69" |
12 | 14 | ||