diff options
author | Haris Okanovic <haris.okanovic@ni.com> | 2016-03-18 15:35:55 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-03-25 11:27:28 +0100 |
commit | d716411b65a4065a3945124b1cdc410b15d4a301 (patch) | |
tree | 60710103bb5733c11beacbf08dc406626eadecd5 /meta-webserver | |
parent | ba81bd3063f1e048efdfd276bc7453b8a7cb546a (diff) | |
download | meta-openembedded-d716411b65a4065a3945124b1cdc410b15d4a301.tar.gz |
apache-websocket: Add recipe
The apache-websocket module is an Apache 2.x server module that may be
used to process requests using the WebSocket protocol (RFC 6455) by an
Apache 2.x server. The module consists of a plugin architecture for
handling WebSocket messaging.
Signed-off-by: Haris Okanovic <haris.okanovic@ni.com>
Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r-- | meta-webserver/recipes-httpd/apache-mod/apache-websocket_git.bb | 33 |
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-webserver/recipes-httpd/apache-mod/apache-websocket_git.bb b/meta-webserver/recipes-httpd/apache-mod/apache-websocket_git.bb new file mode 100644 index 000000000..da33115aa --- /dev/null +++ b/meta-webserver/recipes-httpd/apache-mod/apache-websocket_git.bb | |||
@@ -0,0 +1,33 @@ | |||
1 | SUMMARY = "Websocket module for Apache web server" | ||
2 | DESCRIPTION = "Process requests using the WebSocket protocol (RFC 6455)" | ||
3 | HOMEPAGE = "https://github.com/jchampio/${PN}/" | ||
4 | SECTION = "net" | ||
5 | LICENSE = "Apache-2.0" | ||
6 | |||
7 | inherit autotools-brokensep pkgconfig | ||
8 | |||
9 | DEPENDS = "apache2 apache2-native" | ||
10 | RDEPENDS_${PN} += "apache2" | ||
11 | |||
12 | # Original (github.com/disconnect/apache-websocket) is dead since 2012, the | ||
13 | # fork contains patches from the modules ML and fixes CVE compliance issues | ||
14 | SRC_URI = "git://github.com/jchampio/apache-websocket.git" | ||
15 | |||
16 | SRCREV = "f5230d8c520dccf8631da94bf90c23f3c1100dcc" | ||
17 | |||
18 | PV = "0.1.1" | ||
19 | |||
20 | S = "${WORKDIR}/git" | ||
21 | |||
22 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93" | ||
23 | |||
24 | EXTRA_OECONF = "APACHECTL=${STAGING_DIR_TARGET}${sbindir}/apachectl \ | ||
25 | LIBTOOL=${STAGING_DIR_TARGET}${bindir_crossscripts}/${HOST_SYS}-libtool" | ||
26 | |||
27 | do_install() { | ||
28 | install -d ${D}${libdir}/apache2/modules/ | ||
29 | install ${B}/.libs/mod_websocket.so ${D}${libdir}/apache2/modules/ | ||
30 | } | ||
31 | |||
32 | FILES_${PN} += " ${libdir}/apache2/modules/* " | ||
33 | FILES_${PN}-dbg += " ${libdir}/apache2/modules/.debug/* " | ||