diff options
author | Paul Eggleton <paul.eggleton@linux.intel.com> | 2013-04-18 06:39:37 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-19 02:45:28 +0200 |
commit | 9955ac116e1f57de4c1fb01a0fa47e9591db1d4a (patch) | |
tree | 127123048e2f57f027e4175f32f301ccdf18879c /meta-webserver | |
parent | 73a17ee018a2d26584b3c1b7d4fa4b9906d14b2a (diff) | |
download | meta-openembedded-9955ac116e1f57de4c1fb01a0fa47e9591db1d4a.tar.gz |
cherokee: move to meta-webserver and tweak
* Set SUMMARY instead of DESCRIPTION
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r-- | meta-webserver/recipes-httpd/cherokee/cherokee/cherokee.init | 32 | ||||
-rw-r--r-- | meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb | 56 |
2 files changed, 88 insertions, 0 deletions
diff --git a/meta-webserver/recipes-httpd/cherokee/cherokee/cherokee.init b/meta-webserver/recipes-httpd/cherokee/cherokee/cherokee.init new file mode 100644 index 000000000..93603b84d --- /dev/null +++ b/meta-webserver/recipes-httpd/cherokee/cherokee/cherokee.init | |||
@@ -0,0 +1,32 @@ | |||
1 | #!/bin/sh | ||
2 | DAEMON=/usr/sbin/cherokee | ||
3 | CONFIG=/etc/cherokee/cherokee.conf | ||
4 | PIDFILE=/var/run/cherokee.pid | ||
5 | NAME="cherokee" | ||
6 | DESC="Cherokee http server" | ||
7 | |||
8 | test -r /etc/default/cherokee && . /etc/default/cherokee | ||
9 | test -x "$DAEMON" || exit 0 | ||
10 | test ! -r "$CONFIG" && exit 0 | ||
11 | |||
12 | case "$1" in | ||
13 | start) | ||
14 | echo "Starting $DESC: " | ||
15 | start-stop-daemon --oknodo -S -x $DAEMON -- -d -C $CONFIG | ||
16 | ;; | ||
17 | |||
18 | stop) | ||
19 | echo "Stopping $DESC:" | ||
20 | start-stop-daemon -K -p $PIDFILE | ||
21 | ;; | ||
22 | |||
23 | restart) | ||
24 | $0 stop >/dev/null 2>&1 | ||
25 | $0 start | ||
26 | ;; | ||
27 | |||
28 | *) | ||
29 | echo "Usage: $0 {start|stop|restart}" | ||
30 | exit 0 | ||
31 | ;; | ||
32 | esac | ||
diff --git a/meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb b/meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb new file mode 100644 index 000000000..1510e702f --- /dev/null +++ b/meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb | |||
@@ -0,0 +1,56 @@ | |||
1 | SUMMARY = "Cherokee Web Server fast and secure" | ||
2 | SUMMARY_cget = "Small downloader based in the Cherokee client library" | ||
3 | HOMEPAGE = "http://www.cherokee-project.com/" | ||
4 | SECTION = "network" | ||
5 | LICENSE = "GPLv2" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | ||
7 | |||
8 | PR = "r9" | ||
9 | |||
10 | DEPENDS = "libpcre openssl mysql5 ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" | ||
11 | |||
12 | SRC_URI = "http://www.cherokee-project.com/download/1.2/${PV}/cherokee-${PV}.tar.gz \ | ||
13 | file://cherokee.init \ | ||
14 | file://cherokee.service \ | ||
15 | " | ||
16 | SRC_URI[md5sum] = "21b01e7d45c0e82ecc0c4257a9c27feb" | ||
17 | SRC_URI[sha256sum] = "042b5687b1a3db3ca818167548ce5d32c35e227c6640732dcb622a6f4a078b7d" | ||
18 | |||
19 | inherit autotools pkgconfig binconfig update-rc.d systemd | ||
20 | |||
21 | EXTRA_OECONF = "--disable-static \ | ||
22 | --disable-nls \ | ||
23 | ${@base_contains('DISTRO_FEATURES', 'pam', '--enable-pam', '--disable-pam', d)} \ | ||
24 | " | ||
25 | |||
26 | do_install_append () { | ||
27 | install -m 0755 -d ${D}${sysconfdir}/init.d | ||
28 | install -m 755 ${WORKDIR}/cherokee.init ${D}${sysconfdir}/init.d/cherokee | ||
29 | |||
30 | # clean up .la files for plugins | ||
31 | rm -f ${D}${libdir}/cherokee/*.la | ||
32 | |||
33 | install -d ${D}${systemd_unitdir}/system | ||
34 | install -m 0644 ${WORKDIR}/cherokee.service ${D}${systemd_unitdir}/system | ||
35 | } | ||
36 | |||
37 | # Put -dev near the front so we can move the .la files into it with a wildcard | ||
38 | PACKAGES =+ "libcherokee-server libcherokee-client libcherokee-base cget" | ||
39 | |||
40 | FILES_cget = "${bindir}/cget" | ||
41 | FILES_libcherokee-server = "${libdir}/libcherokee-server${SOLIBS}" | ||
42 | FILES_libcherokee-client = "${libdir}/libcherokee-client${SOLIBS}" | ||
43 | FILES_libcherokee-base = "${libdir}/libcherokee-base${SOLIBS}" | ||
44 | |||
45 | CONFFILES_${PN} = " \ | ||
46 | ${sysconfdir}/cherokee/cherokee.conf \ | ||
47 | ${sysconfdir}/init.d/cherokee \ | ||
48 | " | ||
49 | |||
50 | INITSCRIPT_NAME = "cherokee" | ||
51 | INITSCRIPT_PARAMS = "defaults 91 91" | ||
52 | |||
53 | RPROVIDES_${PN} += "${PN}-systemd" | ||
54 | RREPLACES_${PN} += "${PN}-systemd" | ||
55 | RCONFLICTS_${PN} += "${PN}-systemd" | ||
56 | SYSTEMD_SERVICE_${PN} = "cherokee.service" | ||