diff options
author | Robert Yang <liezhi.yang@windriver.com> | 2014-04-03 22:08:22 +0800 |
---|---|---|
committer | Paul Eggleton <paul.eggleton@linux.intel.com> | 2014-04-06 13:31:23 +0100 |
commit | 4b2a4dac0f19f1ba8a33b35b05be0808eca91b08 (patch) | |
tree | 593bb3d4ac601e3c2fa9b8bb006be249b82af786 /meta-webserver | |
parent | a60bf8c73adecf68d048c7725773d0772b22873e (diff) | |
download | meta-openembedded-4b2a4dac0f19f1ba8a33b35b05be0808eca91b08.tar.gz |
cherokee: only install configured.py once
Both the two rules install-adminpyDATA and install-generatedDATA will
install the configured.py to the same location, they can run parallel,
and they use "install -m", which would might build failures:
/usr/bin/install: setting permissions for `/path/to/configured.py': No such file or directory
This is because the first install is setting the permission while the
second install is removing the file an re-install.
Only install the configured.py once will fix the problem, I think that
there is no side effect since it installed the same file to the same
location twice in the past.
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r-- | meta-webserver/recipes-httpd/cherokee/cherokee/cherokee-install-configured.py-once.patch | 40 | ||||
-rw-r--r-- | meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb | 1 |
2 files changed, 41 insertions, 0 deletions
diff --git a/meta-webserver/recipes-httpd/cherokee/cherokee/cherokee-install-configured.py-once.patch b/meta-webserver/recipes-httpd/cherokee/cherokee/cherokee-install-configured.py-once.patch new file mode 100644 index 000000000..3336f7df7 --- /dev/null +++ b/meta-webserver/recipes-httpd/cherokee/cherokee/cherokee-install-configured.py-once.patch | |||
@@ -0,0 +1,40 @@ | |||
1 | From 98a0f19df0a31d5649ad89d395fd1b8de5591827 Mon Sep 17 00:00:00 2001 | ||
2 | From: Robert Yang <liezhi.yang@windriver.com> | ||
3 | Date: Thu, 3 Apr 2014 21:33:25 +0800 | ||
4 | Subject: [PATCH] admin/Makefile.am: only install configured.py once | ||
5 | |||
6 | Both the two rules install-adminpyDATA and install-generatedDATA will | ||
7 | install the configured.py to the same location, they can run parallel, | ||
8 | and they use "install -m", which would might build failures: | ||
9 | |||
10 | /usr/bin/install: setting permissions for `/path/to/configured.py': No such file or directory | ||
11 | |||
12 | This is because the first install is setting the permission while the | ||
13 | second install is removing the file an re-install. | ||
14 | |||
15 | Only install the configured.py once will fix the problem, I think that | ||
16 | there is no side effect since it installed the same file to the same | ||
17 | location twice in the past. | ||
18 | |||
19 | Upstream-Status: Pending | ||
20 | |||
21 | Signed-off-by: Robert Yang <liezhi.yang@windriver.com> | ||
22 | --- | ||
23 | admin/Makefile.am | 1 - | ||
24 | 1 file changed, 1 deletion(-) | ||
25 | |||
26 | diff --git a/admin/Makefile.am b/admin/Makefile.am | ||
27 | index ce5937b..6f96934 100644 | ||
28 | --- a/admin/Makefile.am | ||
29 | +++ b/admin/Makefile.am | ||
30 | @@ -73,7 +73,6 @@ SystemStatsWidgets.py \ | ||
31 | Wizard.py \ | ||
32 | XMLServerDigest.py \ | ||
33 | config_version.py \ | ||
34 | -configured.py \ | ||
35 | consts.py \ | ||
36 | util.py \ | ||
37 | popen.py \ | ||
38 | -- | ||
39 | 1.8.2.1 | ||
40 | |||
diff --git a/meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb b/meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb index 1c87aed24..054858ed3 100644 --- a/meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb +++ b/meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb | |||
@@ -12,6 +12,7 @@ DEPENDS = "libpcre openssl mysql5 ${@base_contains('DISTRO_FEATURES', 'pam', 'li | |||
12 | SRC_URI = "http://www.cherokee-project.de/mirrors/cherokee/1.2/${PV}/cherokee-${PV}.tar.gz \ | 12 | SRC_URI = "http://www.cherokee-project.de/mirrors/cherokee/1.2/${PV}/cherokee-${PV}.tar.gz \ |
13 | file://cherokee.init \ | 13 | file://cherokee.init \ |
14 | file://cherokee.service \ | 14 | file://cherokee.service \ |
15 | file://cherokee-install-configured.py-once.patch \ | ||
15 | " | 16 | " |
16 | SRC_URI[md5sum] = "21b01e7d45c0e82ecc0c4257a9c27feb" | 17 | SRC_URI[md5sum] = "21b01e7d45c0e82ecc0c4257a9c27feb" |
17 | SRC_URI[sha256sum] = "042b5687b1a3db3ca818167548ce5d32c35e227c6640732dcb622a6f4a078b7d" | 18 | SRC_URI[sha256sum] = "042b5687b1a3db3ca818167548ce5d32c35e227c6640732dcb622a6f4a078b7d" |