diff options
author | Derek Straka <derek@asterius.io> | 2016-07-27 11:54:38 -0400 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-08-05 12:16:38 +0200 |
commit | 181f5f81a39fef8658625394ddbb216fc2f4fe79 (patch) | |
tree | 916d2437bd97fb5973af0006ae5f316d8fba105b /meta-webserver | |
parent | df5141af8dfd19c2b2dbfb65f58eda7a509fafd8 (diff) | |
download | meta-openembedded-181f5f81a39fef8658625394ddbb216fc2f4fe79.tar.gz |
webmin: upgrade to version 1.801
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r-- | meta-webserver/recipes-webadmin/webmin/files/disable-version-check.patch | 48 | ||||
-rw-r--r-- | meta-webserver/recipes-webadmin/webmin/webmin_1.801.bb (renamed from meta-webserver/recipes-webadmin/webmin/webmin_1.750.bb) | 4 |
2 files changed, 36 insertions, 16 deletions
diff --git a/meta-webserver/recipes-webadmin/webmin/files/disable-version-check.patch b/meta-webserver/recipes-webadmin/webmin/files/disable-version-check.patch index a9ee40507..1ca1480c3 100644 --- a/meta-webserver/recipes-webadmin/webmin/files/disable-version-check.patch +++ b/meta-webserver/recipes-webadmin/webmin/files/disable-version-check.patch | |||
@@ -11,7 +11,7 @@ diff --git a/webmin/webmin-lib.pl b/webmin/webmin-lib.pl | |||
11 | index 57a37f7..838b944 100755 | 11 | index 57a37f7..838b944 100755 |
12 | --- a/webmin/webmin-lib.pl | 12 | --- a/webmin/webmin-lib.pl |
13 | +++ b/webmin/webmin-lib.pl | 13 | +++ b/webmin/webmin-lib.pl |
14 | @@ -1059,18 +1059,19 @@ my %miniserv; | 14 | @@ -1086,28 +1086,28 @@ |
15 | &load_theme_library(); # So that UI functions work | 15 | &load_theme_library(); # So that UI functions work |
16 | 16 | ||
17 | # Need OS upgrade | 17 | # Need OS upgrade |
@@ -20,26 +20,46 @@ index 57a37f7..838b944 100755 | |||
20 | - $realos{'os_type'} ne $gconfig{'os_type'}) && | 20 | - $realos{'os_type'} ne $gconfig{'os_type'}) && |
21 | - $realos{'os_version'} && $realos{'os_type'} && | 21 | - $realos{'os_version'} && $realos{'os_type'} && |
22 | - &foreign_available("webmin")) { | 22 | - &foreign_available("webmin")) { |
23 | - push(@notifs, | 23 | - my ($realminor) = split(/\./, $realos{'os_version'}); |
24 | - &ui_form_start("$gconfig{'webprefix'}/webmin/fix_os.cgi"). | 24 | - my ($minor) = split(/\./, $gconfig{'os_version'}); |
25 | - &text('os_incorrect', $realos{'real_os_type'}, | 25 | - if ($realos{'os_type'} eq $gconfig{'os_type'} && |
26 | - $realos{'real_os_version'})."<p>\n". | 26 | - $realminor == $minor) { |
27 | - &ui_form_end([ [ undef, $text{'os_fix'} ] ]) | 27 | - # Only the minor version number changed - no need to apply |
28 | - ); | 28 | - &apply_new_os_version(\%realos); |
29 | - } | ||
30 | - else { | ||
31 | - # Large enough change to tell the user | ||
32 | - push(@notifs, | ||
33 | - &ui_form_start("$gconfig{'webprefix'}/webmin/fix_os.cgi"). | ||
34 | - &text('os_incorrect', $realos{'real_os_type'}, | ||
35 | - $realos{'real_os_version'})."<p>\n". | ||
36 | - &ui_form_end([ [ undef, $text{'os_fix'} ] ]) | ||
37 | - ); | ||
38 | - } | ||
29 | - } | 39 | - } |
30 | +# Disabled for now as os-chooser.pl does not work on our system | ||
31 | +#my %realos = &detect_operating_system(undef, 1); | 40 | +#my %realos = &detect_operating_system(undef, 1); |
32 | +#if (($realos{'os_version'} ne $gconfig{'os_version'} || | 41 | +#if (($realos{'os_version'} ne $gconfig{'os_version'} || |
33 | +# $realos{'os_type'} ne $gconfig{'os_type'}) && | 42 | +# $realos{'os_type'} ne $gconfig{'os_type'}) && |
34 | +# $realos{'os_version'} && $realos{'os_type'} && | 43 | +# $realos{'os_version'} && $realos{'os_type'} && |
35 | +# &foreign_available("webmin")) { | 44 | +# &foreign_available("webmin")) { |
36 | +# push(@notifs, | 45 | +# my ($realminor) = split(/\./, $realos{'os_version'}); |
37 | +# &ui_form_start("$gconfig{'webprefix'}/webmin/fix_os.cgi"). | 46 | +# my ($minor) = split(/\./, $gconfig{'os_version'}); |
38 | +# &text('os_incorrect', $realos{'real_os_type'}, | 47 | +# if ($realos{'os_type'} eq $gconfig{'os_type'} && |
39 | +# $realos{'real_os_version'})."<p>\n". | 48 | +# $realminor == $minor) { |
40 | +# &ui_form_end([ [ undef, $text{'os_fix'} ] ]) | 49 | +# # Only the minor version number changed - no need to apply |
41 | +# ); | 50 | +# &apply_new_os_version(\%realos); |
51 | +# } | ||
52 | +# else { | ||
53 | +# # Large enough change to tell the user | ||
54 | +# push(@notifs, | ||
55 | +# &ui_form_start("$gconfig{'webprefix'}/webmin/fix_os.cgi"). | ||
56 | +# &text('os_incorrect', $realos{'real_os_type'}, | ||
57 | +# $realos{'real_os_version'})."<p>\n". | ||
58 | +# &ui_form_end([ [ undef, $text{'os_fix'} ] ]) | ||
59 | +# ); | ||
60 | +# } | ||
42 | +# } | 61 | +# } |
43 | 62 | ||
44 | # Password close to expiry | 63 | # Password close to expiry |
45 | my $warn_days = $config{'warn_days'}; | 64 | my $warn_days = $config{'warn_days'}; |
65 | |||
diff --git a/meta-webserver/recipes-webadmin/webmin/webmin_1.750.bb b/meta-webserver/recipes-webadmin/webmin/webmin_1.801.bb index 34052a147..3fc083a36 100644 --- a/meta-webserver/recipes-webadmin/webmin/webmin_1.750.bb +++ b/meta-webserver/recipes-webadmin/webmin/webmin_1.801.bb | |||
@@ -20,8 +20,8 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/webadmin/webmin-${PV}.tar.gz \ | |||
20 | file://mysql-config-fix.patch \ | 20 | file://mysql-config-fix.patch \ |
21 | " | 21 | " |
22 | 22 | ||
23 | SRC_URI[md5sum] = "4007c390323d840f26c2e0f43c5c81a3" | 23 | SRC_URI[md5sum] = "91d05b4e31ad1bd14bab14e0f155c088" |
24 | SRC_URI[sha256sum] = "5111f820adc6fbca997a58d4b2fa186dac6cded9cff0e70724f8cae6021123d9" | 24 | SRC_URI[sha256sum] = "ad477edb41dc1a900448afc8b5528e136b3778d2d303f23bc564afb975eb5bed" |
25 | 25 | ||
26 | inherit perlnative update-rc.d | 26 | inherit perlnative update-rc.d |
27 | 27 | ||