diff options
author | Derek Straka <derek@asterius.io> | 2016-04-29 17:43:39 -0400 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-05-06 12:40:24 +0200 |
commit | 72c6229c95d6cf4e197253ab921837d26e916cc9 (patch) | |
tree | 0389d1cc3a2fb48dce299d4b1e2c5f8f074e5c5c /meta-webserver | |
parent | e7ead2b5522b2c862e728dea5585a4e82c574c9e (diff) | |
download | meta-openembedded-72c6229c95d6cf4e197253ab921837d26e916cc9.tar.gz |
nginx: update to version 1.9.15
Remove a now redundant nginx-cross patch with stable moving to 1.10.X
Remove a duplicate DISABLE_STATIC
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-webserver')
3 files changed, 10 insertions, 223 deletions
diff --git a/meta-webserver/recipes-httpd/nginx/nginx-1.9.14/nginx-cross.patch b/meta-webserver/recipes-httpd/nginx/nginx-1.9.14/nginx-cross.patch deleted file mode 100644 index 5e96644aa..000000000 --- a/meta-webserver/recipes-httpd/nginx/nginx-1.9.14/nginx-cross.patch +++ /dev/null | |||
@@ -1,211 +0,0 @@ | |||
1 | We do not have capability to run binaries when cross compiling | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | |||
5 | |||
6 | diff -uraN nginx-1.0.11.orig/auto/feature nginx-1.0.11/auto/feature | ||
7 | --- nginx-1.0.11.orig/auto/feature 2011-05-11 06:50:19.000000000 -0500 | ||
8 | +++ nginx-1.0.11/auto/feature 2011-12-27 13:56:42.323370040 -0600 | ||
9 | @@ -49,12 +49,20 @@ | ||
10 | |||
11 | if [ -x $NGX_AUTOTEST ]; then | ||
12 | |||
13 | + if [ ".$NGX_CROSS_COMPILE" = ".yes" ]; then | ||
14 | + NGX_AUTOTEST_EXEC="true" | ||
15 | + NGX_FOUND_MSG=" (not tested, cross compiling)" | ||
16 | + else | ||
17 | + NGX_AUTOTEST_EXEC="$NGX_AUTOTEST" | ||
18 | + NGX_FOUND_MSG="" | ||
19 | + fi | ||
20 | + | ||
21 | case "$ngx_feature_run" in | ||
22 | |||
23 | yes) | ||
24 | # /bin/sh is used to intercept "Killed" or "Abort trap" messages | ||
25 | - if /bin/sh -c $NGX_AUTOTEST >> $NGX_AUTOCONF_ERR 2>&1; then | ||
26 | - echo " found" | ||
27 | + if /bin/sh -c $NGX_AUTOTEST_EXEC >> $NGX_AUTOCONF_ERR 2>&1; then | ||
28 | + echo " found$NGX_FOUND_MSG" | ||
29 | ngx_found=yes | ||
30 | |||
31 | if test -n "$ngx_feature_name"; then | ||
32 | @@ -68,17 +75,27 @@ | ||
33 | |||
34 | value) | ||
35 | # /bin/sh is used to intercept "Killed" or "Abort trap" messages | ||
36 | - if /bin/sh -c $NGX_AUTOTEST >> $NGX_AUTOCONF_ERR 2>&1; then | ||
37 | - echo " found" | ||
38 | + if /bin/sh -c $NGX_AUTOTEST_EXEC >> $NGX_AUTOCONF_ERR 2>&1; then | ||
39 | + echo " found$NGX_FOUND_MSG" | ||
40 | ngx_found=yes | ||
41 | |||
42 | - cat << END >> $NGX_AUTO_CONFIG_H | ||
43 | + if [ ".$NGX_CROSS_COMPILE" = ".yes" ]; then | ||
44 | + cat << END >> $NGX_AUTO_CONFIG_H | ||
45 | |||
46 | #ifndef $ngx_feature_name | ||
47 | -#define $ngx_feature_name `$NGX_AUTOTEST` | ||
48 | +#define $ngx_feature_name $(eval "echo \$NGX_WITH_${ngx_feature_name}") | ||
49 | #endif | ||
50 | |||
51 | END | ||
52 | + else | ||
53 | + cat << END >> $NGX_AUTO_CONFIG_H | ||
54 | + | ||
55 | +#ifndef $ngx_feature_name | ||
56 | +#define $ngx_feature_name `$NGX_AUTOTEST_EXEC` | ||
57 | +#endif | ||
58 | + | ||
59 | +END | ||
60 | + fi | ||
61 | else | ||
62 | echo " found but is not working" | ||
63 | fi | ||
64 | @@ -86,7 +105,7 @@ | ||
65 | |||
66 | bug) | ||
67 | # /bin/sh is used to intercept "Killed" or "Abort trap" messages | ||
68 | - if /bin/sh -c $NGX_AUTOTEST >> $NGX_AUTOCONF_ERR 2>&1; then | ||
69 | + if /bin/sh -c $NGX_AUTOTEST_EXEC >> $NGX_AUTOCONF_ERR 2>&1; then | ||
70 | echo " not found" | ||
71 | |||
72 | else | ||
73 | diff -uraN nginx-1.0.11.orig/auto/options nginx-1.0.11/auto/options | ||
74 | --- nginx-1.0.11.orig/auto/options 2011-12-14 07:34:16.000000000 -0600 | ||
75 | +++ nginx-1.0.11/auto/options 2011-12-27 13:56:42.323370040 -0600 | ||
76 | @@ -353,6 +353,18 @@ | ||
77 | --test-build-epoll) NGX_TEST_BUILD_EPOLL=YES ;; | ||
78 | --test-build-solaris-sendfilev) NGX_TEST_BUILD_SOLARIS_SENDFILEV=YES ;; | ||
79 | |||
80 | + # cross compile support | ||
81 | + --with-int=*) NGX_WITH_INT="$value" ;; | ||
82 | + --with-long=*) NGX_WITH_LONG="$value" ;; | ||
83 | + --with-long-long=*) NGX_WITH_LONG_LONG="$value" ;; | ||
84 | + --with-ptr-size=*) NGX_WITH_PTR_SIZE="$value" ;; | ||
85 | + --with-sig-atomic-t=*) NGX_WITH_SIG_ATOMIC_T="$value" ;; | ||
86 | + --with-size-t=*) NGX_WITH_SIZE_T="$value" ;; | ||
87 | + --with-off-t=*) NGX_WITH_OFF_T="$value" ;; | ||
88 | + --with-time-t=*) NGX_WITH_TIME_T="$value" ;; | ||
89 | + --with-sys-nerr=*) NGX_WITH_NGX_SYS_NERR="$value" ;; | ||
90 | + --with-endian=*) NGX_WITH_ENDIAN="$value" ;; | ||
91 | + | ||
92 | *) | ||
93 | echo "$0: error: invalid option \"$option\"" | ||
94 | exit 1 | ||
95 | @@ -533,6 +445,17 @@ | ||
96 | |||
97 | --with-debug enable debug logging | ||
98 | |||
99 | + --with-int=VALUE force int size | ||
100 | + --with-long=VALUE force long size | ||
101 | + --with-long-long=VALUE force long long size | ||
102 | + --with-ptr-size=VALUE force pointer size | ||
103 | + --with-sig-atomic-t=VALUE force sig_atomic_t size | ||
104 | + --with-size-t=VALUE force size_t size | ||
105 | + --with-off-t=VALUE force off_t size | ||
106 | + --with-time-t=VALUE force time_t size | ||
107 | + --with-sys-nerr=VALUE force sys_nerr value | ||
108 | + --with-endian=VALUE force system endianess | ||
109 | + | ||
110 | END | ||
111 | |||
112 | exit 1 | ||
113 | @@ -554,6 +577,8 @@ | ||
114 | |||
115 | if [ ".$NGX_PLATFORM" = ".win32" ]; then | ||
116 | NGX_WINE=$WINE | ||
117 | +elif [ ! -z "$NGX_PLATFORM" ]; then | ||
118 | + NGX_CROSS_COMPILE="yes" | ||
119 | fi | ||
120 | |||
121 | |||
122 | diff -uraN nginx-1.0.11.orig/auto/types/sizeof nginx-1.0.11/auto/types/sizeof | ||
123 | --- nginx-1.0.11.orig/auto/types/sizeof 2006-06-28 11:00:26.000000000 -0500 | ||
124 | +++ nginx-1.0.11/auto/types/sizeof 2011-12-27 13:56:42.323370040 -0600 | ||
125 | @@ -12,9 +12,12 @@ | ||
126 | |||
127 | END | ||
128 | |||
129 | -ngx_size= | ||
130 | +ngx_size=$(eval "echo \$NGX_WITH_${ngx_param}") | ||
131 | |||
132 | -cat << END > $NGX_AUTOTEST.c | ||
133 | +if [ ".$ngx_size" != "." ]; then | ||
134 | + echo " $ngx_size bytes" | ||
135 | +else | ||
136 | + cat << END > $NGX_AUTOTEST.c | ||
137 | |||
138 | #include <sys/types.h> | ||
139 | #include <sys/time.h> | ||
140 | @@ -33,15 +36,16 @@ | ||
141 | END | ||
142 | |||
143 | |||
144 | -ngx_test="$CC $CC_TEST_FLAGS $CC_AUX_FLAGS \ | ||
145 | - -o $NGX_AUTOTEST $NGX_AUTOTEST.c $NGX_LD_OPT $ngx_feature_libs" | ||
146 | + ngx_test="$CC $CC_TEST_FLAGS $CC_AUX_FLAGS \ | ||
147 | + -o $NGX_AUTOTEST $NGX_AUTOTEST.c $NGX_LD_OPT $ngx_feature_libs" | ||
148 | |||
149 | -eval "$ngx_test >> $NGX_AUTOCONF_ERR 2>&1" | ||
150 | + eval "$ngx_test >> $NGX_AUTOCONF_ERR 2>&1" | ||
151 | |||
152 | |||
153 | -if [ -x $NGX_AUTOTEST ]; then | ||
154 | - ngx_size=`$NGX_AUTOTEST` | ||
155 | - echo " $ngx_size bytes" | ||
156 | + if [ -x $NGX_AUTOTEST ]; then | ||
157 | + ngx_size=`$NGX_AUTOTEST` | ||
158 | + echo " $ngx_size bytes" | ||
159 | + fi | ||
160 | fi | ||
161 | |||
162 | |||
163 | diff -uraN nginx-1.0.11.orig/auto/unix nginx-1.0.11/auto/unix | ||
164 | --- nginx-1.0.11.orig/auto/unix 2011-12-14 07:34:16.000000000 -0600 | ||
165 | +++ nginx-1.0.11/auto/unix 2011-12-27 13:56:42.327370060 -0600 | ||
166 | @@ -393,13 +393,13 @@ | ||
167 | |||
168 | # C types | ||
169 | |||
170 | -ngx_type="int"; . auto/types/sizeof | ||
171 | +ngx_type="int"; ngx_param="INT"; . auto/types/sizeof | ||
172 | |||
173 | -ngx_type="long"; . auto/types/sizeof | ||
174 | +ngx_type="long"; ngx_param="LONG"; . auto/types/sizeof | ||
175 | |||
176 | -ngx_type="long long"; . auto/types/sizeof | ||
177 | +ngx_type="long long"; ngx_param="LONG_LONG"; . auto/types/sizeof | ||
178 | |||
179 | -ngx_type="void *"; . auto/types/sizeof; ngx_ptr_size=$ngx_size | ||
180 | +ngx_type="void *"; ngx_param="PTR_SIZE"; . auto/types/sizeof; ngx_ptr_size=$ngx_size | ||
181 | ngx_param=NGX_PTR_SIZE; ngx_value=$ngx_size; . auto/types/value | ||
182 | |||
183 | |||
184 | @@ -416,7 +416,7 @@ | ||
185 | |||
186 | ngx_type="uint64_t"; ngx_types="u_int64_t"; . auto/types/typedef | ||
187 | |||
188 | -ngx_type="sig_atomic_t"; ngx_types="int"; . auto/types/typedef | ||
189 | +ngx_type="sig_atomic_t"; ngx_param="SIG_ATOMIC_T"; ngx_types="int"; . auto/types/typedef | ||
190 | . auto/types/sizeof | ||
191 | ngx_param=NGX_SIG_ATOMIC_T_SIZE; ngx_value=$ngx_size; . auto/types/value | ||
192 | |||
193 | @@ -432,15 +432,15 @@ | ||
194 | |||
195 | . auto/endianess | ||
196 | |||
197 | -ngx_type="size_t"; . auto/types/sizeof | ||
198 | +ngx_type="size_t"; ngx_param="SIZE_T"; . auto/types/sizeof | ||
199 | ngx_param=NGX_MAX_SIZE_T_VALUE; ngx_value=$ngx_max_value; . auto/types/value | ||
200 | ngx_param=NGX_SIZE_T_LEN; ngx_value=$ngx_max_len; . auto/types/value | ||
201 | |||
202 | -ngx_type="off_t"; . auto/types/sizeof | ||
203 | +ngx_type="off_t"; ngx_param="OFF_T"; . auto/types/sizeof | ||
204 | ngx_param=NGX_MAX_OFF_T_VALUE; ngx_value=$ngx_max_value; . auto/types/value | ||
205 | ngx_param=NGX_OFF_T_LEN; ngx_value=$ngx_max_len; . auto/types/value | ||
206 | |||
207 | -ngx_type="time_t"; . auto/types/sizeof | ||
208 | +ngx_type="time_t"; ngx_param="TIME_T"; . auto/types/sizeof | ||
209 | ngx_param=NGX_TIME_T_SIZE; ngx_value=$ngx_size; . auto/types/value | ||
210 | ngx_param=NGX_TIME_T_LEN; ngx_value=$ngx_max_len; . auto/types/value | ||
211 | |||
diff --git a/meta-webserver/recipes-httpd/nginx/nginx_1.9.14.bb b/meta-webserver/recipes-httpd/nginx/nginx_1.9.14.bb deleted file mode 100644 index 585c52ce0..000000000 --- a/meta-webserver/recipes-httpd/nginx/nginx_1.9.14.bb +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | require nginx.inc | ||
2 | |||
3 | # 1.9.x is the current mainline branches containing all new features | ||
4 | # 1.8.x branch is the current stable branch, the recommended default | ||
5 | DEFAULT_PREFERENCE = "-1" | ||
6 | |||
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=0bb58ed0dfd4f5dbece3b52aba79f023" | ||
8 | |||
9 | SRC_URI[md5sum] = "a25818039f34b5d54b017d44c76321c4" | ||
10 | SRC_URI[sha256sum] = "2b4893076d28e6b4384bba8c4fdebfca6de6f8f68ec48a1ca94b9b855ff457d2" | ||
11 | |||
12 | DISABLE_STATIC = "" | ||
diff --git a/meta-webserver/recipes-httpd/nginx/nginx_1.9.15.bb b/meta-webserver/recipes-httpd/nginx/nginx_1.9.15.bb new file mode 100644 index 000000000..abbec53b9 --- /dev/null +++ b/meta-webserver/recipes-httpd/nginx/nginx_1.9.15.bb | |||
@@ -0,0 +1,10 @@ | |||
1 | require nginx.inc | ||
2 | |||
3 | # 1.10.x branch is the current stable branch, the recommended default | ||
4 | # 1.9.x is the current mainline branches containing all new features | ||
5 | DEFAULT_PREFERENCE = "-1" | ||
6 | |||
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=0bb58ed0dfd4f5dbece3b52aba79f023" | ||
8 | |||
9 | SRC_URI[md5sum] = "13cd38e9da3789035750dd45882c4a26" | ||
10 | SRC_URI[sha256sum] = "cc89b277cc03f403c0b746d60aa5943cdecf59ae48278f8cb7e2df0cbdb6dac3" | ||