diff options
author | YangHaibo <b40869@freescale.com> | 2014-08-05 15:31:33 +0800 |
---|---|---|
committer | Paul Eggleton <paul.eggleton@linux.intel.com> | 2014-08-10 17:23:22 +0100 |
commit | 4d4ab8fd320b58323033c12cf705e7b3ce10d659 (patch) | |
tree | e3bc03e58b5ed6835928769019794baf4af61413 /meta-webserver | |
parent | eb45d8b6c716c43f4acbc9f35a8c916eefbe72e5 (diff) | |
download | meta-openembedded-4d4ab8fd320b58323033c12cf705e7b3ce10d659.tar.gz |
integrate fcgi-2.4.0 and add OML license file
Signed-off-by: YangHaibo <b40869@freescale.com>
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-webserver')
3 files changed, 50 insertions, 0 deletions
diff --git a/meta-webserver/recipes-support/fcgi/Fix_EOF_not_declared_issue.patch b/meta-webserver/recipes-support/fcgi/Fix_EOF_not_declared_issue.patch new file mode 100644 index 000000000..51ddeaac2 --- /dev/null +++ b/meta-webserver/recipes-support/fcgi/Fix_EOF_not_declared_issue.patch | |||
@@ -0,0 +1,17 @@ | |||
1 | Upstream-Status: Pending | ||
2 | |||
3 | Fix EOF not declared issue, following is the error log. | ||
4 | fcgio.cpp:70:72: error: 'EOF' was not declared in this scope | ||
5 | if (FCGX_PutStr(pbase(), plen, this->fcgx) != plen) return EOF; | ||
6 | |||
7 | Signed-off-by: Yang Haibo <b40869@freescale.com> | ||
8 | --- fcgi-ori/libfcgi/fcgio.cpp 2014-07-28 18:01:00.000000000 +0800 | ||
9 | +++ fcgi-2.4.0/libfcgi/fcgio.cpp 2014-07-28 18:01:22.000000000 +0800 | ||
10 | @@ -22,6 +22,7 @@ | ||
11 | #define DLLAPI __declspec(dllexport) | ||
12 | #endif | ||
13 | |||
14 | +#include <stdio.h> | ||
15 | #include <limits.h> | ||
16 | #include "fcgio.h" | ||
17 | |||
diff --git a/meta-webserver/recipes-support/fcgi/add_foreign_to_AM_INIT_AUTOMAKE.patch b/meta-webserver/recipes-support/fcgi/add_foreign_to_AM_INIT_AUTOMAKE.patch new file mode 100644 index 000000000..eca694adc --- /dev/null +++ b/meta-webserver/recipes-support/fcgi/add_foreign_to_AM_INIT_AUTOMAKE.patch | |||
@@ -0,0 +1,18 @@ | |||
1 | Upstream-Status: Pending | ||
2 | |||
3 | use automake options "foreign" to set the strictness as appropriate | ||
4 | |||
5 | Signed-off-by: Yang Haibo <b40869@freescale.com> | ||
6 | --- fcgi-ori/configure.in 2014-08-05 14:58:35.000000000 +0800 | ||
7 | +++ fcgi-2.4.0/configure.in 2014-08-05 14:59:08.000000000 +0800 | ||
8 | @@ -4,8 +4,8 @@ | ||
9 | dnl generate the file "configure", which is run during the build | ||
10 | dnl to configure the system for the local environment. | ||
11 | |||
12 | -AC_INIT | ||
13 | -AM_INIT_AUTOMAKE(fcgi, 2.4.0) | ||
14 | +AC_INIT([fcgi], [2.4.0]) | ||
15 | +AM_INIT_AUTOMAKE([foreign]) | ||
16 | |||
17 | AM_CONFIG_HEADER(fcgi_config.h) | ||
18 | |||
diff --git a/meta-webserver/recipes-support/fcgi_2.4.0.bb b/meta-webserver/recipes-support/fcgi_2.4.0.bb new file mode 100644 index 000000000..ed718aefd --- /dev/null +++ b/meta-webserver/recipes-support/fcgi_2.4.0.bb | |||
@@ -0,0 +1,15 @@ | |||
1 | DESCRIPTION = "FastCGI is a protocol for interfacing interactive programs with a web server." | ||
2 | HOMEPAGE = "http://www.fastcgi.com" | ||
3 | LICENSE = "OML" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.TERMS;md5=e3aacac3a647af6e7e31f181cda0a06a" | ||
5 | |||
6 | SRC_URI = "http://fossies.org/linux/www/${BP}.tar.gz \ | ||
7 | file://Fix_EOF_not_declared_issue.patch \ | ||
8 | file://add_foreign_to_AM_INIT_AUTOMAKE.patch \ | ||
9 | " | ||
10 | SRC_URI[md5sum] = "d15060a813b91383a9f3c66faf84867e" | ||
11 | SRC_URI[sha256sum] = "66fc45c6b36a21bf2fbbb68e90f780cc21a9da1fffbae75e76d2b4402d3f05b9" | ||
12 | |||
13 | inherit autotools | ||
14 | |||
15 | PARALLEL_MAKE = "" | ||